aboutsummaryrefslogtreecommitdiff
path: root/sysutils/portmanager/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-10-16 16:56:51 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-10-16 16:56:51 +0000
commit264deb1f10b4c7198684e20ff756a4e66dd84835 (patch)
tree5cc5596e0dece2f14e0ce566c570db3af1ba6fd8 /sysutils/portmanager/Makefile
parent82810b0fc7d58c9fa9759b1de10ed32736581861 (diff)
downloadports-264deb1f10b4c7198684e20ff756a4e66dd84835.tar.gz
ports-264deb1f10b4c7198684e20ff756a4e66dd84835.zip
Notes
Diffstat (limited to 'sysutils/portmanager/Makefile')
-rw-r--r--sysutils/portmanager/Makefile50
1 files changed, 31 insertions, 19 deletions
diff --git a/sysutils/portmanager/Makefile b/sysutils/portmanager/Makefile
index 095f5bc5ea7c..6bfc0e2e4085 100644
--- a/sysutils/portmanager/Makefile
+++ b/sysutils/portmanager/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= portmanager
-PORTVERSION= 0.2.9
-PORTREVISION= 9
+PORTVERSION= 0.3.0
#-----------------------------------------
#for local use, remove before submitting PR
CATEGORIES= sysutils
@@ -49,28 +48,41 @@ CONFIGURE_ARGS= --with-prefix=${PREFIX} \
--with-sharedir=/share/portmanager \
--with-tempdir=/tmp
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+INSTALL_TARGET= install info
+
+# Get __FreeBSD_version
+.if !defined(OSVERSION)
+.if exists(/sbin/sysctl)
+OSVERSION!= /sbin/sysctl -n kern.osreldate
+.else
+OSVERSION!= /usr/sbin/sysctl -n kern.osreldate
+.endif
+.endif
+
+.if ${OSVERSION} >= 600000
#
-# In FreeBSD 6.0 dumps core when compiled WITHOUT debug symbols :(
+# In FreeBSD 6.0 dumps core when compiled WITHOUT debug symbols
# so for a temp fix just making the WITH_DEBUG non optional.
#
-#.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --with-debug=yes
-#.endif
+WITH_DEBUG= YES
+.endif
-INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
-INSTALL_TARGET= install info
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --with-debug=yes
+.endif
-#pre-fetch:
-#.if !defined(WITH_DEBUG)
-# @${ECHO} "***********************************************************************"
-# @${ECHO} "* portmanager *"
-# @${ECHO} "***********************************************************************"
-# @${ECHO} "* *"
-# @${ECHO} "* WITH_DEBUG=yes enables debug support and all compile warnings *"
-# @${ECHO} "* *"
-# @${ECHO} "***********************************************************************"
-#.endif
+pre-fetch:
+.if !defined(WITH_DEBUG)
+ @${ECHO} "***********************************************************************"
+ @${ECHO} "* portmanager *"
+ @${ECHO} "***********************************************************************"
+ @${ECHO} "* *"
+ @${ECHO} "* WITH_DEBUG=yes enables debug support and all compile warnings *"
+ @${ECHO} "* *"
+ @${ECHO} "***********************************************************************"
+.endif
post-configure:
@${REINPLACE_CMD} -e \