aboutsummaryrefslogtreecommitdiff
path: root/sysutils/portmanager
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-12-26 20:30:38 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-12-26 20:30:38 +0000
commitb2e4ca90479a33423bc4ddec4703dad256479ca3 (patch)
tree085742bafc491bcb09e372afa1948b1fa236eb9e /sysutils/portmanager
parenta11f5de7b807115cdd9d8891de8d057275340b2f (diff)
downloadports-b2e4ca90479a33423bc4ddec4703dad256479ca3.tar.gz
ports-b2e4ca90479a33423bc4ddec4703dad256479ca3.zip
Notes
Diffstat (limited to 'sysutils/portmanager')
-rw-r--r--sysutils/portmanager/Makefile57
-rw-r--r--sysutils/portmanager/distinfo4
-rw-r--r--sysutils/portmanager/files/patch-aa11
-rw-r--r--sysutils/portmanager/files/patch-ab372
-rw-r--r--sysutils/portmanager/files/patch-ac74
-rw-r--r--sysutils/portmanager/pkg-plist18
6 files changed, 29 insertions, 507 deletions
diff --git a/sysutils/portmanager/Makefile b/sysutils/portmanager/Makefile
index be42a2f5ba7e..feff9cefbcea 100644
--- a/sysutils/portmanager/Makefile
+++ b/sysutils/portmanager/Makefile
@@ -6,59 +6,54 @@
#
PORTNAME= portmanager
-PORTVERSION= 0.2.0
-PORTREVISION= 3
+PORTVERSION= 0.2.1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= portmanager
-MAINTAINER= ringworm@inbox.lv
+MAINTAINER= reso3w83@verizon.net
COMMENT= FreeBSD port management software
-.if !defined(NOPORTDOCS)
-BUILD_DEPENDS= c2html:${PORTSDIR}/textproc/c2html \
- tidy:${PORTSDIR}/www/tidy
+.if defined(WITH_DEBUG)
+BUILD_DEPENDS= autoheader259:${PORTSDIR}/devel/autoconf259 \
+ aclocal19:${PORTSDIR}/devel/automake19 \
+ libtoolize15:${PORTSDIR}/devel/libtool15
.endif
-USE_GMAKE= yes
+MAN1= portmanager.1
+
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+# Need INSTALL_TARGET to install /usr/local/etc/portmanager/pm-020.conf.SAMPLE
+INSTALL_TARGET= install info
-.if !defined(NOPORTDOCS)
-PORTDOCS= docbook.css index.html libPMGR.3.html libPMGR.h.html \
- PMGRrDbCreate.c.html PMGRrDbCreate.h.html PMGRrDbCreate.3.html \
- PMGRrReadConfigure.c.html PMGRrReadConfigure.h.html PMGRrReadConfigure.3.html \
- PMGRrMakeDescribe.3.html PMGRrMakeDescribe.c.html PMGRrMakeDescribe.h.html \
- MGmDbArray.3.html \
- MGrFileSize.3.html MGrFileSize.c.html MGrFileSize.h.html \
- MGrFileTime.3.html MGrFileTime.c.html MGrFileTime.h.html \
- MGrIfFileExist.3.html MGrIfFileExist.c.html MGrIfFileExist.h.html \
- MGrInStringSwap.3.html MGrInStringSwap.c.html MGrInStringSwap.h.html \
- MGrIntToString.3.html MGrIntToString.c.html MGrIntToString.h.html \
- MGrStripComment.3.html MGrStripComment.c.html MGrStripComment.h.html \
- MGsDb.7.html MGsProperty.7.html libMG.3.html libMG.h.html mgmlParse.1.html \
- mgmlParse.c.html mgmlParse.h.html portmanager.1.html portmanager.c.html \
- portmanager.h.html pmStatus.1.html pmStatus.c.html pmStatus.h.html \
- pmupgrade.1.html pmupgrade.c.html pmupgrade.h.html
-INSTALL_TARGET= install info
-
+# Only way to get WITH_DEBUG build dependencies handled prior to reconfiguring
+# is to use post-configure <sigh>
+post-configure:
+.if defined(WITH_DEBUG)
+ @${REINPLACE_CMD} -e 's|# BDECFLAGS=|BDECFLAGS=|g' ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -e 's|# CFLAGS=|CFLAGS=|g' ${WRKSRC}/configure.ac
+ cd ${WRKSRC};sh rePackage.sh;sh configure
.endif
post-install:
@${ECHO} "******************************************************"
+ @${ECHO} "* to compile with debug support try: *"
+ @${ECHO} "* make WITH_DEBUG=yes install clean *"
+ @${ECHO} "* *"
@${ECHO} "* portmanager commands: *"
@${ECHO} "* *"
@${ECHO} "* portmanager -h brief help screen *"
@${ECHO} "* -s list status of installed ports *"
@${ECHO} "* -u upgrade installed ports *"
- @${ECHO} "* *WARNING* *"
- @${ECHO} "* the formant of *"
- @${ECHO} "* /usr/local/etc/portmanager/portmanager.conf is *"
- @${ECHO} "* changed in version 0.2.0 and has been renamed to *"
- @${ECHO} "* pm-020.conf *"
+ @${ECHO} "* *"
+ @${ECHO} "* see man portmanager(1) or *"
+ @${ECHO} "* /usr/local/etc/portmanager/pm-020.conf *"
+ @${ECHO} "* for config options *"
@${ECHO} "* *"
@${ECHO} "* all feedback is welcome, send to: *"
- @${ECHO} "* Michael C. Shultz ringworm@inbox.lv *"
+ @${ECHO} "* Michael C. Shultz reso3w83@verizon.net *"
@${ECHO} "******************************************************"
.include <bsd.port.mk>
diff --git a/sysutils/portmanager/distinfo b/sysutils/portmanager/distinfo
index d6726ac8d5b1..34725c3ae974 100644
--- a/sysutils/portmanager/distinfo
+++ b/sysutils/portmanager/distinfo
@@ -1,2 +1,2 @@
-MD5 (portmanager-0.2.0.tar.gz) = aaaa4f0827daadd564172fc28b2610c3
-SIZE (portmanager-0.2.0.tar.gz) = 361877
+MD5 (portmanager-0.2.1.tar.gz) = ffd913fb57b592e9876fd006cc921eee
+SIZE (portmanager-0.2.1.tar.gz) = 383452
diff --git a/sysutils/portmanager/files/patch-aa b/sysutils/portmanager/files/patch-aa
deleted file mode 100644
index 76708dbd2af7..000000000000
--- a/sysutils/portmanager/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- libMG/src/libMG.h Thu Aug 12 10:34:49 2004
-+++ libMG/src/libMG.h Fri Aug 27 02:48:55 2004
-@@ -307,7 +307,7 @@
- { \
- errorCode = 1; \
- } \
-- strcpy( var, string );
-+ strncpy( var, string, strlen(string)+1 );
-
- #include <MGrFileSize.h>
- #include <MGrFileTime.h>
diff --git a/sysutils/portmanager/files/patch-ab b/sysutils/portmanager/files/patch-ab
deleted file mode 100644
index c4555ca2f35a..000000000000
--- a/sysutils/portmanager/files/patch-ab
+++ /dev/null
@@ -1,372 +0,0 @@
-diff -ruN ./libMG/src/libMG.h.orig ../../PATCH/portmanager-0.2.0/libMG/src/libMG.h.orig
---- ./libMG/src/libMG.h.orig Thu Aug 12 10:34:49 2004
-+++ ../../PATCH/portmanager-0.2.0/libMG/src/libMG.h.orig Wed Dec 31 16:00:00 1969
-@@ -1,320 +0,0 @@
--/************************************************************************/
--/* Copyright (C) 2004 Michael C. Shultz */
--/* */
--/* This program is free software; you can redistribute it and/or modify */
--/* it under the terms of the GNU General Public License as published by */
--/* the Free Software Foundation; either version 2 of the License, or (at*/
--/* your option) any later version. */
--/* */
--/* This program is distributed in the hope that it will be useful, */
--/* but WITHOUT ANY WARRANTY; without even the implied warranty of */
--/* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the */
--/* GNU General Public License for more details. */
--/* */
--/* You should have received a copy of the GNU General Public License */
--/* along with this program; if not, write to the Free Software */
--/* Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA */
--/* 02111-1307, USA. */
--/* */
--/* Michael C. Shultz */
--/* ringworm@inbox.lv */
--/* Box 3238 Landers, CA 92285 */
--/************************************************************************/
--
--/************************************************/
--/* macro index: */
--/* MGmSetString( var, string ) */
--/* MGmDbArray( b, c , d ) */
--/* MGmDbArrayFree( a ) */
--/************************************************/
--#ifndef __LIBMG_H__
--#define __LIBMG_H__ 1
--
--#ifndef __errno__
--extern int errno;
--#define __errno__ 1
--#endif
--
--/*
--#include <config.h>
--*/
--
--#include <dirent.h>
--#include <signal.h>
--#include <stdio.h>
--#include <stdlib.h>
--#include <string.h>
--#include <sys/stat.h>
--#include <sys/time.h>
--#include <sys/types.h>
--#include <sys/wait.h>
--#include <sysexits.h>
--#include <unistd.h>
--
--#include <sys/resource.h>
--
--#ifndef CR
--#define CR 13
--#endif
--
--#ifndef LF
--#define LF 10
--#endif
--
--#ifndef SPACE
--#define SPACE 32
--#endif
--
--#ifndef TAB
--#define TAB 9
--#endif
--
--/*.................................................
--structure MGsDb
--Used to contain the various elements of a data base
--
--name = path + name of data base file
--mode = mode data base is to be opened
-- "r" read only
-- "r+" read/write
-- "a" append
--..................................................*/
--typedef struct
--{
-- char* buffer; /* buffer used to contain data base */
-- char* field;
-- char* mode; /* mode in which to open file */
-- char* name; /* name and path of data base file */
-- char** record;
-- char** recordStartAddress;
-- char*** array; /* data base array */
-- FILE* stream; /* assigned to data base file after it is opened */
-- int bufferPtr1;
-- unsigned int eof; /* size of data base file in bytes */
-- int fieldPtr1;
-- int fieldIdx;
-- int fieldQty; /* quantity of fields per record */
-- int recordIdx;
-- int recordQty; /* quantity of records per data base */
--} MGsDb;
--
--/*.................................................
-- <a name="MGsProperty">
--structure MGsProperty
-- </a>
--
--intended use is to provide a consistant means of organizing an
--application's top level property structure. See MGsProperty(7)
--for a detailed description
--
--id = assigned application's name
--version = assigned application's version, in a string
--feedback = determines the level of verbosity as application executes
-- best to set this with MGrCommandLine(3) but it may of course
-- be set or adjused elsewhere
--..................................................*/
--typedef struct
--{
-- char* id;
-- char* version;
-- int feedBack;
--} MGsProperty;
--
--
--/***********************************
--MACROS
--************************************/
--/***********************************
--MGmDbArray:
--b = dbase structure name
--c = dbase file name string
--d = open mode string
--************************************/
--#define MGmDbArrayFree( a ) \
-- free( a.buffer ); \
-- free( a.mode ); \
-- free( a.name ); \
-- free( a.recordStartAddress ); \
-- free( a.array ); \
-- fclose( a.stream );
--
--#define MGmDbArray( b, c, d ) \
-- do{ \
-- errno = 0; \
-- if( !( b.name = ( char*)malloc( (unsigned int)sizeof( c ) + 1 ) ) ) \
-- { \
-- fprintf( stderr, "MGmDbArray error: Unable to allocate memory for %s\n", c ); \
-- perror( "system message" ); \
-- errno = 1; \
-- } \
-- if( errno==0 ) \
-- { \
-- strcpy( b.name, c ); \
-- if( !( b.mode = ( char*)malloc( (unsigned int)sizeof( d ) + 1 ) ) ) \
-- { \
-- fprintf( stderr, "MGmDbArray error: Unable to allocate 2 bytes %s mode %s\n", c, d ); \
-- perror( "system message" ); \
-- errno = 1; \
-- } \
-- if( errno==0 ) \
-- { \
-- strcpy( b.mode, d ); \
-- if( !( b.eof = MGrFileSize( b.name ) ) ) \
-- { \
-- fprintf( stderr, "MGmDbArray warning: MGrFileSize returned a size of %d for %s\n", b.eof, b.name ); \
-- errno = 2; \
-- } \
-- if( errno==0 ) \
-- { \
-- if(!(b.buffer=(char*)malloc((unsigned int)b.eof))) \
-- { \
-- fprintf( stderr, "MGmDbArray error: unable to reallocate %d bytes memory for %s\n", \
-- b.eof, b.name ); \
-- perror( "system message" ); \
-- errno = 1; \
-- } \
-- if( errno==0 ) \
-- { \
-- if( !( b.stream = fopen( b.name, b.mode ) ) ) \
-- { \
-- fprintf( stderr, "MGmDbArray error: unable to open file %s\n", b.name ); \
-- perror( "system message" ); \
-- errno = 1; \
-- } \
-- if( errno==0 ) \
-- { \
-- fread( b.buffer, b.eof, 1, b.stream ); \
-- if( ferror( b.stream ) ) \
-- { \
-- fprintf( stderr, "MGmDbArray error: reading file %s into b.buffer\n", b.name ); \
-- perror( "system message" ); \
-- errno = 1; \
-- } \
-- if( errno==0 ) \
-- { \
-- b.bufferPtr1 = 0; \
-- b.fieldQty = 0; \
-- while( b.buffer[b.bufferPtr1] != LF ) \
-- { \
-- if( !( b.buffer[b.bufferPtr1] ) ) \
-- { \
-- b.fieldQty++; \
-- } \
-- b.bufferPtr1++; \
-- } \
-- b.bufferPtr1 = 0; \
-- b.fieldPtr1 = 0; \
-- b.recordQty = 0; \
-- while( b.bufferPtr1 < b.eof ) \
-- { \
-- while( b.buffer[b.bufferPtr1] != LF ) \
-- { \
-- if( !( b.buffer[b.bufferPtr1] ) ) \
-- { \
-- b.fieldPtr1++; \
-- } \
-- b.bufferPtr1++; \
-- } \
-- if( b.fieldPtr1 != b.fieldQty ) \
-- { \
-- fprintf( stderr, \
-- "MGmDbArray error: inconsitant field count at record %d. field count is %d and should be %d\n", \
-- b.recordQty, b.fieldPtr1, \
-- b.fieldQty ); \
-- errno = 1; \
-- break; \
-- } \
-- b.bufferPtr1++; \
-- b.recordQty++; \
-- b.fieldPtr1 = 0; \
-- } \
-- if( errno==0 ) \
-- { \
-- if(!(b.record=(char**)malloc((unsigned int)b.recordQty*(unsigned int)b.fieldQty*(unsigned int)sizeof(char**)))) \
-- { \
-- fprintf( stderr, \
-- "MGmDbArray error: realloc failed to allocate %d bytes for records\n", \
-- b.fieldQty * sizeof( char* ) ); \
-- perror( "system message" ); \
-- errno = 1; \
-- } \
-- if( errno==0 ) \
-- { \
-- b.recordStartAddress = b.record; \
-- if( !( b.array = ( char*** )malloc((unsigned int)b.recordQty * (unsigned int)sizeof( char** ) ) ) ) \
-- { \
-- fprintf( stderr, \
-- "MGmDbArray error: malloc failed to allocate %d bytes for dBase\n", \
-- b.recordQty * sizeof( char** ) ); \
-- perror( "system message" ); \
-- errno = 1; \
-- } \
-- if( errno==0 ) \
-- { \
-- b.field = b.buffer; \
-- b.record[0] = ( char* )b.field; \
-- b.array[0] = ( char** )b.record; \
-- b.recordIdx = 0; \
-- while( b.recordIdx < b.recordQty ) \
-- { \
-- b.fieldIdx = 0; \
-- while( 1==1 ) \
-- { \
-- b.record[b.fieldIdx] = b.field; \
-- b.fieldPtr1 = ( int )b.field; \
-- if( !( b.field = strchr( ( char* )b.fieldPtr1, 0) ) ) \
-- { \
-- fprintf( stderr, "MGmDbArray error: next field not found\n" ); \
-- perror( "system message" ); \
-- errno = 1; \
-- break; \
-- } \
-- b.field = b.field + 1; \
-- b.fieldIdx++; \
-- if( b.field[0] == LF ) \
-- { \
-- b.field = b.field + 1; \
-- break; \
-- } \
-- } \
-- if( errno!=0 ) \
-- { \
-- break; \
-- } \
-- b.array[b.recordIdx] = ( char** )b.record; \
-- b.fieldIdx = 0; \
-- while( b.fieldIdx < b.fieldQty ) \
-- { \
-- b.record++; \
-- b.fieldIdx++; \
-- } \
-- b.recordIdx++; \
-- } \
-- } \
-- } \
-- } \
-- } \
-- } \
-- } \
-- } \
-- } \
-- }} \
-- while (0)
--
--#define MGmSetString( var, string ) \
-- errorCode = 0; \
-- if( !( var = ( char* )malloc((unsigned int)strlen( string ) + 1 ) ) )\
-- { \
-- errorCode = 1; \
-- } \
-- strcpy( var, string );
--
--#include <MGrFileSize.h>
--#include <MGrFileTime.h>
--#include <MGrIfFileExist.h>
--#include <MGrInStringSwap.h>
--#include <MGrIntToString.h>
--#include <MGrStripComment.h>
--
--
--#endif
-diff -ruN ./libPMGR/src/PMGRrMakeDescribe.c ../../PATCH/portmanager-0.2.0/libPMGR/src/PMGRrMakeDescribe.c
---- ./libPMGR/src/PMGRrMakeDescribe.c Thu Aug 19 23:52:39 2004
-+++ ../../PATCH/portmanager-0.2.0/libPMGR/src/PMGRrMakeDescribe.c Wed Sep 22 21:17:06 2004
-@@ -287,6 +287,10 @@
- return( NULL );
- }
- fread( Buffer, BufferSize, 1, tempStream );
-+ #ifdef DEBUG
-+ fprintf( stderr, "DEBUG: %s: currentPortMakefile = %s\n", id, currentPortMakefile );
-+ #endif
-+
- pclose( tempStream );
- free( currentPortMakefile );
- miscPtr = 0;
-diff -ruN ./libPMGR/src/libPMGR.h ../../PATCH/portmanager-0.2.0/libPMGR/src/libPMGR.h
---- ./libPMGR/src/libPMGR.h Tue Aug 10 20:16:27 2004
-+++ ../../PATCH/portmanager-0.2.0/libPMGR/src/libPMGR.h Wed Sep 22 21:24:35 2004
-@@ -22,7 +22,9 @@
- /************************************************************************/
- #ifndef __LIBPMGR_H__
- #define __LIBPMGR_H__ 1
--
-+/*
-+#define DEBUG 1
-+*/
- #include <libMG.h>
- #include <PMGRrDbCreate.h>
- #include <PMGRrMakeDescribe.h>
-@@ -31,7 +33,7 @@
- #include <pmupgrade.h>
-
- #ifndef VER
--static char ver[] = "0.2.0";
-+static char ver[] = "0.2.0_2";
- #define VER 1
- #endif
-
-diff -ruN ./portmanager/portmanager.c ../../PATCH/portmanager-0.2.0/portmanager/portmanager.c
---- ./portmanager/portmanager.c Thu Aug 12 13:20:37 2004
-+++ ../../PATCH/portmanager-0.2.0/portmanager/portmanager.c Wed Sep 22 21:28:12 2004
-@@ -116,6 +116,7 @@
- }
- case PMUPGRADE:
- {
-+ system( "rm /usr/local/share/portmanager/ports_cache.db" );
- errorCode = system( "pmupgrade" );
- break;
- }
diff --git a/sysutils/portmanager/files/patch-ac b/sysutils/portmanager/files/patch-ac
deleted file mode 100644
index 4212684a7470..000000000000
--- a/sysutils/portmanager/files/patch-ac
+++ /dev/null
@@ -1,74 +0,0 @@
-diff -ruN ./libPMGR/src/PMGRrDbCreate.c ../../portmanager-0.2.0/libPMGR/src/PMGRrDbCreate.c
---- ./libPMGR/src/PMGRrDbCreate.c Thu Aug 12 02:19:05 2004
-+++ ../../portmanager-0.2.0/libPMGR/src/PMGRrDbCreate.c Thu Oct 28 15:28:20 2004
-@@ -55,6 +55,7 @@
- char* portDependencyDir = NULL;
- char* portDir = NULL;
- char* portName = NULL;
-+ int address = 0;
- int errorCode = 0;
- int idx = 0;
- int portDependencyDirLen = 0;
-@@ -140,10 +141,46 @@
- }
- fread( portBuffer, 1, size, portStream );
- portBuffer[size+1] = 0;
-- portName = strstr( portBuffer, "@name " ) + strlen( "@name " );
-- portNameLen = strstr( portName, "\n" ) - portName;
-- portDir = strstr( portBuffer, "@comment ORIGIN:" ) + strlen( "@comment ORIGIN:" );
-- portDirLen = strstr( portDir, "\n" ) - portDir;
-+
-+ /* sets portName to start address of portname */
-+ /* ver 0.2.0_3 added error checking for @name not found int +CONTENTS file */
-+ if( (address = (int)strnstr(portBuffer, "@name ", size)) == 0 )
-+ {
-+ fprintf( stderr, "%s %s error: \"@name\" not found in %s\n", id, ver, pkg.portDirName );
-+ fprintf( stderr, "\t\t%s installation is corrupt!\n", pkg.entry->d_name );
-+ fprintf( stderr, "\t\trecomend running \"pkg_delete -f %s\" then manually reinstalling this port\n", pkg.entry->d_name );
-+ return(1);
-+ }
-+ portName = (char*)(address + strlen("@name "));
-+
-+ if( (address = (int)strnstr(portName, "\n", 256)) == 0 )
-+ {
-+ fprintf( stderr, "%s %s portName error: \"end of line\" not found in %s\n", id, ver, pkg.portDirName );
-+ fprintf( stderr, "\t\t%s installation is corrupt!\n", pkg.entry->d_name );
-+ fprintf( stderr, "\t\trecomend running \"pkg_delete -f %s\" then manually reinstalling this port\n", pkg.entry->d_name );
-+ return(1);
-+ }
-+ portNameLen = address - (int)portName;
-+
-+ if( (address = (int)strnstr(portBuffer, "@comment ORIGIN:", size)) == 0 )
-+ {
-+ fprintf( stderr, "%s %s error: \"@comment ORIGIN:\" not found in %s\n", id, ver, pkg.portDirName );
-+ fprintf( stderr, "\t\t%s installation is corrupt!\n", pkg.entry->d_name );
-+ fprintf( stderr, "\t\trecomend running \"pkg_delete -f %s\" then manually reinstalling this port\n", pkg.entry->d_name );
-+ return(1);
-+ }
-+ portDir = (char*)(address + strlen("@comment ORIGIN:"));
-+
-+
-+ if( (address = (int)strnstr(portDir, "\n", 256)) == 0 )
-+ {
-+ fprintf( stderr, "%s %s portDir error: \"end of line\" not found in %s\n", id, ver, pkg.portDirName );
-+ fprintf( stderr, "\t\t%s installation is corrupt!\n", pkg.entry->d_name );
-+ fprintf( stderr, "\t\trecomend running \"pkg_delete -f %s\" then manually reinstalling this port\n", pkg.entry->d_name );
-+ return(1);
-+ }
-+ portDirLen = address - (int)portDir;
-+
- portName[portNameLen] = 0;
- portDir[portDirLen] = 0;
- fprintf( portIStream, "%s%c%s%c\n", portName, NULL, portDir, NULL );
-diff -ruN ./libPMGR/src/libPMGR.h ../../portmanager-0.2.0/libPMGR/src/libPMGR.h
---- ./libPMGR/src/libPMGR.h Thu Oct 28 15:33:54 2004
-+++ ../../portmanager-0.2.0/libPMGR/src/libPMGR.h Thu Oct 28 15:31:41 2004
-@@ -33,7 +33,7 @@
- #include <pmupgrade.h>
-
- #ifndef VER
--static char ver[] = "0.2.0_2";
-+static char ver[] = "0.2.0_3";
- #define VER 1
- #endif
-
diff --git a/sysutils/portmanager/pkg-plist b/sysutils/portmanager/pkg-plist
index c8f99c4180bc..822acf29345d 100644
--- a/sysutils/portmanager/pkg-plist
+++ b/sysutils/portmanager/pkg-plist
@@ -5,31 +5,15 @@
@unexec rm -f %D/share/portmanager/ports_cache.db 2>/dev/null || true
@unexec rm -f %D/share/portmanager/ports_installed.db 2>/dev/null || true
@unexec rm -f %D/share/portmanager/ports_old.db 2>/dev/null || true
-bin/mgmlParse
-bin/pmStatus
+bin/pmstatus
bin/pmupgrade
bin/portmanager
etc/portmanager/pm-020.conf.SAMPLE
-include/MGrFileSize.h
-include/MGrFileTime.h
-include/MGrIfFileExist.h
-include/MGrInStringSwap.h
-include/MGrIntToString.h
-include/MGrStripComment.h
-include/PMGRrDbCreate.h
-include/PMGRrMakeDescribe.h
-include/PMGRrReadConfigure.h
include/libMG.h
include/libPMGR.h
-include/pmStatus.h
-include/pmupgrade.h
-include/portmanager.h
lib/libMG
lib/libMG.0
-lib/libMG.a
lib/libPMGR
lib/libPMGR.0
-lib/libPMGR.a
-share/portmanager/.keepme
@unexec rmdir %D/etc/portmanager 2>/dev/null || true
@unexec rmdir %D/share/portmanager 2>/dev/null || true