aboutsummaryrefslogtreecommitdiff
path: root/sysutils/portupgrade
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-06-30 10:06:53 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-06-30 10:06:53 +0000
commit4df325cdc99415cdb2993f701b10df021385c7d3 (patch)
treea221b6cb9ab53254117583988710baafdadba4a4 /sysutils/portupgrade
parent8d983baf417c17bb1e1d88720039bee4833d8d5b (diff)
downloadports-4df325cdc99415cdb2993f701b10df021385c7d3.tar.gz
ports-4df325cdc99415cdb2993f701b10df021385c7d3.zip
Notes
Diffstat (limited to 'sysutils/portupgrade')
-rw-r--r--sysutils/portupgrade/Makefile29
-rw-r--r--sysutils/portupgrade/distinfo6
-rw-r--r--sysutils/portupgrade/files/patch-lib-pkgtools.rb20
3 files changed, 28 insertions, 27 deletions
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index f8985a3f7cec..6bbea1a152e9 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portupgrade
-PORTVERSION= 2.1.1
+PORTVERSION= 2.1.3.1
PORTEPOCH= 2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
@@ -17,7 +17,8 @@ DISTNAME= pkgtools-${DISTVERSION}
MAINTAINER= sem@FreeBSD.org
COMMENT= FreeBSD ports/packages administration and management tool suite
-OPTIONS= BDB4 "Use Berkeley DB >=2 as backend. (Use BDB 1.85 if off)" off
+OPTIONS= BDB4 "Use Berkeley DB >=2 as backend" on \
+ BDB1 "Use Berkeley DB 1.85 as backend" off
USE_BZIP2= yes
USE_RUBY= yes
@@ -55,12 +56,32 @@ INSTALL_TARGET+= install-doc
.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
.if defined(WITH_BDB4)
-# For PKG_DBDRIVER={bdb_btree,bdb_hash,bdb}
+# For PKG_DBDRIVER={bdb_btree,bdb_hash}
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb.so:${PORTSDIR}/databases/ruby-bdb
-.else
+.endif
+.if defined(WITH_BDB1) && !defined(WITH_BDB4)
+# For PKG_DBDRIVER={bdb1_btree,bdb1_hash}
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb1.so:${PORTSDIR}/databases/ruby-bdb1
.endif
+pre-extract:
+.if !defined(WITH_BDB4) && !defined(WITH_BDB1)
+ @${ECHO_MSG} "================================================================="
+ @${ECHO_MSG} "Neither WITH_DBD4 nor WITH_BDB1 are defined. Will use DBD driver."
+ @${ECHO_MSG} "================================================================="
+.endif
+.if defined(WITH_BDB4) && defined(WITH_BDB1)
+ @${ECHO_MSG} "================================================================="
+ @${ECHO_MSG} "Both WITH_DBD4 and WITH_BDB1 are defined. Will use BDB4 driver."
+ @${ECHO_MSG} "================================================================="
+.elif defined(WITH_BDB1) && exists(${RUBY_SITEARCHLIBDIR}/bdb.so)
+ @${ECHO_MSG} "================================================================="
+ @${ECHO_MSG} "WITH_BDB1 is defined but ruby-bdb port installed."
+ @${ECHO_MSG} "Remove ruby-bdb or redefine options."
+ @${ECHO_MSG} "================================================================="
+ @exit 1
+.endif
+
post-install: install-ldconfig-file
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
diff --git a/sysutils/portupgrade/distinfo b/sysutils/portupgrade/distinfo
index 96b8f1d92784..4c312891148b 100644
--- a/sysutils/portupgrade/distinfo
+++ b/sysutils/portupgrade/distinfo
@@ -1,3 +1,3 @@
-MD5 (pkgtools-2.1.1.tar.bz2) = a3848cf5cffedf196a28b4c3b20746cb
-SHA256 (pkgtools-2.1.1.tar.bz2) = 6b6369fe18a9a2fdb1062361d4211a2e31e49999a0c037f963c7e781af7c1d4c
-SIZE (pkgtools-2.1.1.tar.bz2) = 108685
+MD5 (pkgtools-2.1.3.1.tar.bz2) = 5fedaebd06089beb4da2b102c57a9a39
+SHA256 (pkgtools-2.1.3.1.tar.bz2) = e11d5e523f5d6f7372698e00814b080a94ea0f61fd2e42c4c945fe2cea706474
+SIZE (pkgtools-2.1.3.1.tar.bz2) = 109704
diff --git a/sysutils/portupgrade/files/patch-lib-pkgtools.rb b/sysutils/portupgrade/files/patch-lib-pkgtools.rb
deleted file mode 100644
index 87dcfe5ff3a8..000000000000
--- a/sysutils/portupgrade/files/patch-lib-pkgtools.rb
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/pkgtools.rb.orig Sat Jun 3 10:05:09 2006
-+++ lib/pkgtools.rb Mon Jun 19 16:36:55 2006
-@@ -1048,7 +1048,7 @@
-
- pkg = PkgInfo.new(pkgname)
-
-- re = %r"^((?:#{Regexp.quote(localbase())}|#{Regexp.quote(x11base())})/etc/rc\.d/[^/]+(\.sh))(\.\w+)?$"
-+ re = %r"^((?:#{Regexp.quote(localbase())}|#{Regexp.quote(x11base())})/etc/rc\.d/[^/]+(\.sh)?)(\.\w+)?$"
-
- ret = []
- pkg.files.each { |file|
-@@ -1066,7 +1066,7 @@
-
- pkg = PkgInfo.new(pkgname)
-
-- re = %r"^((?:#{Regexp.quote(localbase())}|#{Regexp.quote(x11base())})/etc/rc\.d/[^/]+\.sh)(\.\w+)$"
-+ re = %r"^((?:#{Regexp.quote(localbase())}|#{Regexp.quote(x11base())})/etc/rc\.d/[^/]+(\.sh)?)(\.\w+)$"
-
- pkg.files.select { |file|
- re =~ file && File.executable?(file)