aboutsummaryrefslogtreecommitdiff
path: root/sysutils/portupgrade
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2004-07-02 04:23:19 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2004-07-02 04:23:19 +0000
commit46edc73a8424c673b6c8caced1284a6ef7057130 (patch)
tree81551162dfb57058d645dde2f33dca1e00e02fee /sysutils/portupgrade
parentb5ec194289858401103a973765bad81dca28d8e0 (diff)
Apply a patch to avoid "undefined method `each' for nil:NilClass"
error when such configuration variable as MAKE_ARGS, typically BEFORE_DEINSTALL is not defined. Reported by: krion, Tsurutani Naoki <turutani@scphys.kyoto-u.ac.jp>
Notes
Notes: svn path=/head/; revision=112720
Diffstat (limited to 'sysutils/portupgrade')
-rw-r--r--sysutils/portupgrade/Makefile1
-rw-r--r--sysutils/portupgrade/files/patch-pkgtools.rb16
2 files changed, 17 insertions, 0 deletions
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index 87deaa74b641..f434320f6a88 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -7,6 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20040701
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}
diff --git a/sysutils/portupgrade/files/patch-pkgtools.rb b/sysutils/portupgrade/files/patch-pkgtools.rb
new file mode 100644
index 000000000000..1632d02a1a08
--- /dev/null
+++ b/sysutils/portupgrade/files/patch-pkgtools.rb
@@ -0,0 +1,16 @@
+Index: lib/pkgtools.rb
+===================================================================
+RCS file: /home/cvs/pkgtools/lib/pkgtools.rb,v
+retrieving revision 1.123
+diff -u -r1.123 pkgtools.rb
+--- lib/pkgtools.rb 30 Jun 2004 16:24:12 -0000 1.123
++++ lib/pkgtools.rb 2 Jul 2004 03:51:12 -0000
+@@ -82,7 +82,7 @@
+ if !pattern.include?('/')
+ gtable[pattern] = value
+ end
+- end
++ end if hash
+
+ table = [otable, gtable]
+ end