aboutsummaryrefslogtreecommitdiff
path: root/sysutils/prips/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-06-03 14:06:38 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-06-03 14:06:38 +0000
commit19459ee4897bc71d0f0ebc338c377c49e01076c5 (patch)
tree9fcfec541c4c57b5bc68af490f785a588a9a82eb /sysutils/prips/Makefile
parent5b244d4d320cb2834dc69ffb09751bdd87f42388 (diff)
downloadports-19459ee4897bc71d0f0ebc338c377c49e01076c5.tar.gz
ports-19459ee4897bc71d0f0ebc338c377c49e01076c5.zip
Notes
Diffstat (limited to 'sysutils/prips/Makefile')
-rw-r--r--sysutils/prips/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/sysutils/prips/Makefile b/sysutils/prips/Makefile
index a1f68b56e1ea..c905dd0487f7 100644
--- a/sysutils/prips/Makefile
+++ b/sysutils/prips/Makefile
@@ -8,26 +8,25 @@
PORTNAME= prips
PORTVERSION= 0.9.4
CATEGORIES= sysutils
-MASTER_SITES= http://ipsc.sourceforge.net/dist/prips/
-DISTNAME= ${PKGNAME}-src
+MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= Prints IP subnet ranges by list or CIDR
-WRKSRC= ${WRKDIR}/prips
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+
+PORTDOCS= README
+PLIST_FILES= bin/prips
.include <bsd.port.pre.mk>
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/prips ${PREFIX}/bin
-
-post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/prips ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
-.else
- @${SED} 's#share/doc/prips/README##' ${TMPPLIST} > ${WRKDIR}/PLIST.tmp
- @${SED} 's#@dirrm share/doc/prips##' ${WRKDIR}/PLIST.tmp > ${TMPPLIST}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.post.mk>