aboutsummaryrefslogtreecommitdiff
path: root/sysutils/progsreiserfs/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-09-01 14:59:58 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-09-01 14:59:58 +0000
commit3f9458d6ba6e6e4ea39ef091b6eb9251dc7c5445 (patch)
tree6de6000fef75e534741fb0e55301276cd9b6c1d5 /sysutils/progsreiserfs/Makefile
parent8b77f79ccd344fac42d21288c14311fa44785021 (diff)
- add USE_GETOPT_LONG=yes and related patch
- add USE_LIBTOOL_VER=15 and remove *.la from pkg-plist - disable NLS support if WITHOUT_NLS=yes is defined - bump PORTREVISION
Notes
Notes: svn path=/head/; revision=117838
Diffstat (limited to 'sysutils/progsreiserfs/Makefile')
-rw-r--r--sysutils/progsreiserfs/Makefile29
1 files changed, 21 insertions, 8 deletions
diff --git a/sysutils/progsreiserfs/Makefile b/sysutils/progsreiserfs/Makefile
index 1a00576ebdca..53d6d785263c 100644
--- a/sysutils/progsreiserfs/Makefile
+++ b/sysutils/progsreiserfs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= progsreiserfs
PORTVERSION= 0.3.1.r8
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.cgsecurity.org/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
@@ -14,22 +15,34 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Utilities and library to manipulate ReiserFS partitions
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
GNU_CONFIGURE= yes
-USE_GETTEXT= yes
-USE_INC_LIBTOOL_VER= 15
+USE_GETOPT_LONG=yes
+USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib -lgnugetopt"
CONFIGURE_ARGS= --disable-debug
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+.else
+USE_GETTEXT= yes
+.endif
+
MAN8= cpfs.reiserfs.8 mkfs.reiserfs.8 reiserfs.8 \
resizefs.reiserfs.8 tunefs.reiserfs.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500041
+CFLAGS+= -Dgetopt_long_only=getopt_long
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-progsreiserfs::libmisc::Makefile.in
+.endif
+
post-patch:
- ${REINPLACE_CMD} -e 's|sys/int_types.h|inttypes.h|' ${WRKSRC}/libreiserfs/tools.c
- ${REINPLACE_CMD} -e 's|sys/int_types.h|inttypes.h|' ${WRKSRC}/include/reiserfs/*
+ @${REINPLACE_CMD} -e 's|^LIBTOOL=.*|LIBTOOL=${LIBTOOL}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|sys/int_types.h|inttypes.h|' \
+ ${WRKSRC}/libreiserfs/tools.c ${WRKSRC}/include/reiserfs/*
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>