aboutsummaryrefslogtreecommitdiff
path: root/sysutils/progsreiserfs
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2006-08-12 12:33:13 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2006-08-12 12:33:13 +0000
commit16a1d1bab40ffba11285074572008fff630ea884 (patch)
treea487ad2be77c172b291af095ec1836bf6b0eb842 /sysutils/progsreiserfs
parent48a83234dd0887629550c70e24bd24353ea6e2e9 (diff)
Notes
Diffstat (limited to 'sysutils/progsreiserfs')
-rw-r--r--sysutils/progsreiserfs/Makefile2
-rw-r--r--sysutils/progsreiserfs/files/patch-libdal-file.c26
2 files changed, 27 insertions, 1 deletions
diff --git a/sysutils/progsreiserfs/Makefile b/sysutils/progsreiserfs/Makefile
index edb4372bae1c..43baafe200a0 100644
--- a/sysutils/progsreiserfs/Makefile
+++ b/sysutils/progsreiserfs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= progsreiserfs
PORTVERSION= 0.3.1.r8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://www.cgsecurity.org/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
diff --git a/sysutils/progsreiserfs/files/patch-libdal-file.c b/sysutils/progsreiserfs/files/patch-libdal-file.c
new file mode 100644
index 000000000000..82a52fc6e393
--- /dev/null
+++ b/sysutils/progsreiserfs/files/patch-libdal-file.c
@@ -0,0 +1,26 @@
+--- libdal/file.c.orig Thu Dec 12 21:32:34 2002
++++ libdal/file.c Sat Aug 12 15:35:27 2006
+@@ -14,6 +14,7 @@
+
+ #if defined(__freebsd__)
+ # define O_LARGEFILE 0
++# include <sys/disk.h>
+ #endif
+
+ #ifndef DJGPP
+@@ -154,6 +155,15 @@
+
+ #endif
+
++#ifdef DIOCGMEDIASIZE
++
++ if (ioctl(*((int *)dal->entity), DIOCGMEDIASIZE, &size) >= 0)
++ return (count_t)(size / dal->blocksize);
++
++ file_save_error(dal);
++
++#endif
++
+ if ((max_off = lseek(*((int *)dal->entity), 0, SEEK_END)) == (off_t)-1) {
+ file_save_error(dal);
+ return 0;