aboutsummaryrefslogtreecommitdiff
path: root/sysutils/progsreiserfs
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-14 15:49:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-14 15:49:39 +0000
commitf26daa7f4eb0a3ca08d9a107074d3ba7a9f7913a (patch)
treed2cca7161e5d8682ccccab78d20ce2c8308f8f65 /sysutils/progsreiserfs
parenta08800154ba8a4f6fff0686c064cf78ecd333216 (diff)
downloadports-f26daa7f4eb0a3ca08d9a107074d3ba7a9f7913a.tar.gz
ports-f26daa7f4eb0a3ca08d9a107074d3ba7a9f7913a.zip
Notes
Diffstat (limited to 'sysutils/progsreiserfs')
-rw-r--r--sysutils/progsreiserfs/Makefile29
-rw-r--r--sysutils/progsreiserfs/distinfo2
-rw-r--r--sysutils/progsreiserfs/files/patch-libreiserfs::journal.c11
-rw-r--r--sysutils/progsreiserfs/pkg-descr11
-rw-r--r--sysutils/progsreiserfs/pkg-plist39
5 files changed, 92 insertions, 0 deletions
diff --git a/sysutils/progsreiserfs/Makefile b/sysutils/progsreiserfs/Makefile
new file mode 100644
index 000000000000..911c9e11bd7b
--- /dev/null
+++ b/sysutils/progsreiserfs/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: progsreiserfs
+# Date created: May 13 2004
+# Whom: Florent Thoumie <flz@xbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= progsreiserfs
+PORTVERSION= 0.3.1.r8
+CATEGORIES= sysutils
+MASTER_SITES= http://www.cgsecurity.org/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
+
+MAINTAINER= flz@xbsd.org
+COMMENT= Utilities and library to manipulate ReiserFS partitions
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+GNU_CONFIGURE= yes
+USE_GETTEXT= 1
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib -lgnugetopt"
+
+MAN8= cpfs.reiserfs.8 mkfs.reiserfs.8 reiserfs.8 \
+ resizefs.reiserfs.8 tunefs.reiserfs.8
+
+.include <bsd.port.mk>
diff --git a/sysutils/progsreiserfs/distinfo b/sysutils/progsreiserfs/distinfo
new file mode 100644
index 000000000000..f3e7cf262af2
--- /dev/null
+++ b/sysutils/progsreiserfs/distinfo
@@ -0,0 +1,2 @@
+MD5 (progsreiserfs-0.3.1-rc8.tar.gz) = e545a171a207ec5b9045ceb1a982c1bd
+SIZE (progsreiserfs-0.3.1-rc8.tar.gz) = 399279
diff --git a/sysutils/progsreiserfs/files/patch-libreiserfs::journal.c b/sysutils/progsreiserfs/files/patch-libreiserfs::journal.c
new file mode 100644
index 000000000000..fe5c6165905f
--- /dev/null
+++ b/sysutils/progsreiserfs/files/patch-libreiserfs::journal.c
@@ -0,0 +1,11 @@
+--- libreiserfs/journal.c Thu Dec 12 13:32:35 2002
++++ libreiserfs/journal.c.new Thu May 13 00:01:43 2004
+@@ -482,7 +482,7 @@
+ blk_t reiserfs_journal_boundary_transactions(reiserfs_journal_t *journal,
+ reiserfs_journal_trans_t *oldest, reiserfs_journal_trans_t *newest)
+ {
+- reiserfs_gauge_t *gauge;
++ reiserfs_gauge_t *gauge = NULL;
+ struct reiserfs_replay_desc desc;
+
+ desc.oldest_id = 0xffffffff; desc.newest_id = 0x0;
diff --git a/sysutils/progsreiserfs/pkg-descr b/sysutils/progsreiserfs/pkg-descr
new file mode 100644
index 000000000000..95359fafd563
--- /dev/null
+++ b/sysutils/progsreiserfs/pkg-descr
@@ -0,0 +1,11 @@
+This is a library for reiserfs filesystem access and manipulation.
+The primary goal is to develop the nice, full functionality library
+wich might be linked against any projects which needed reiserfs filesystem
+access. There are GNU Parted, GNU GRUB, Yaboot, Partimage, EVMS, etc.
+
+progsreiserfs supports versions 3.5, 3.6 with standard and relocated journal.
+
+WWW: http://reiserfs.osdn.org.ua
+
+- Florent Thoumie
+flz@xbsd.org
diff --git a/sysutils/progsreiserfs/pkg-plist b/sysutils/progsreiserfs/pkg-plist
new file mode 100644
index 000000000000..a0b7fe6ea132
--- /dev/null
+++ b/sysutils/progsreiserfs/pkg-plist
@@ -0,0 +1,39 @@
+include/dal/dal.h
+include/dal/file.h
+include/reiserfs/bitmap.h
+include/reiserfs/block.h
+include/reiserfs/core.h
+include/reiserfs/dir.h
+include/reiserfs/endian.h
+include/reiserfs/exception.h
+include/reiserfs/file.h
+include/reiserfs/filesystem.h
+include/reiserfs/gauge.h
+include/reiserfs/hashes.h
+include/reiserfs/journal.h
+include/reiserfs/key.h
+include/reiserfs/node.h
+include/reiserfs/object.h
+include/reiserfs/path.h
+include/reiserfs/reiserfs.h
+include/reiserfs/segment.h
+include/reiserfs/tools.h
+include/reiserfs/tree.h
+lib/libdal-0.3.so
+lib/libdal-0.3.so.0
+lib/libdal.a
+lib/libdal.la
+lib/libdal.so
+lib/libreiserfs-0.3.so
+lib/libreiserfs-0.3.so.0
+lib/libreiserfs.a
+lib/libreiserfs.la
+lib/libreiserfs.so
+sbin/cpfs.reiserfs
+sbin/fsck.reiserfs
+sbin/mkfs.reiserfs
+sbin/resizefs.reiserfs
+sbin/tunefs.reiserfs
+share/aclocal/progsreiserfs.m4
+@dirrm include/reiserfs
+@dirrm include/dal