aboutsummaryrefslogtreecommitdiff
path: root/sysutils/psmisc
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-11-13 08:12:15 +0000
committerJohn Marino <marino@FreeBSD.org>2015-11-13 08:12:15 +0000
commit4719581d0c957698bf02faf5687672902cab9083 (patch)
treed442582e2fb4895e768a0f24f8b9a7e720d8d4c6 /sysutils/psmisc
parent0e2684f4de1dfa39c1db50ce8ce30a1a1e1e1307 (diff)
downloadports-4719581d0c957698bf02faf5687672902cab9083.tar.gz
ports-4719581d0c957698bf02faf5687672902cab9083.zip
Notes
Diffstat (limited to 'sysutils/psmisc')
-rw-r--r--sysutils/psmisc/files/patch-doc-Makefile.in6
-rw-r--r--sysutils/psmisc/files/patch-src-Makefile.in12
-rw-r--r--sysutils/psmisc/files/patch-src-killall.c18
-rw-r--r--sysutils/psmisc/files/patch-src-pstree.c22
4 files changed, 29 insertions, 29 deletions
diff --git a/sysutils/psmisc/files/patch-doc-Makefile.in b/sysutils/psmisc/files/patch-doc-Makefile.in
index 9c5def83ebef..944bb091757c 100644
--- a/sysutils/psmisc/files/patch-doc-Makefile.in
+++ b/sysutils/psmisc/files/patch-doc-Makefile.in
@@ -1,6 +1,6 @@
---- doc/Makefile.in.orig 2010-07-12 19:38:08.000000000 +0800
-+++ doc/Makefile.in 2010-07-31 18:52:50.000000000 +0800
-@@ -189,7 +189,7 @@
+--- doc/Makefile.in.orig 2012-02-08 23:32:11 UTC
++++ doc/Makefile.in
+@@ -197,7 +197,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
diff --git a/sysutils/psmisc/files/patch-src-Makefile.in b/sysutils/psmisc/files/patch-src-Makefile.in
index ce7c33f2c4a3..be0714ff9bbc 100644
--- a/sysutils/psmisc/files/patch-src-Makefile.in
+++ b/sysutils/psmisc/files/patch-src-Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig 2010-07-12 04:38:08.000000000 -0700
-+++ src/Makefile.in 2010-08-11 23:39:30.652095791 -0700
-@@ -34,8 +34,8 @@
+--- src/Makefile.in.orig 2012-02-08 23:32:11 UTC
++++ src/Makefile.in
+@@ -34,8 +34,8 @@ PRE_UNINSTALL = :
POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
@@ -11,7 +11,7 @@
$(am__EXEEXT_3) $(am__EXEEXT_4) $(am__EXEEXT_5)
@WANT_PEEKFD_I386_TRUE@am__append_1 = peekfd
@WANT_PEEKFD_I386_TRUE@am__append_2 = -DI386
-@@ -91,10 +91,8 @@
+@@ -91,10 +91,8 @@ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUD
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
@@ -24,7 +24,7 @@
ETAGS = etags
CTAGS = ctags
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
-@@ -299,19 +297,19 @@
+@@ -303,19 +301,19 @@ clean-binPROGRAMS:
-test -z "$(bin_PROGRAMS)" || rm -f $(bin_PROGRAMS)
fuser$(EXEEXT): $(fuser_OBJECTS) $(fuser_DEPENDENCIES)
@rm -f fuser$(EXEEXT)
@@ -49,7 +49,7 @@
mostlyclean-compile:
-rm -f *.$(OBJEXT)
-@@ -547,7 +545,7 @@
+@@ -556,7 +554,7 @@ uninstall-am: uninstall-binPROGRAMS
signames.h: signames.c Makefile
export LC_ALL=C ; \
@CPP@ -dM $< |\
diff --git a/sysutils/psmisc/files/patch-src-killall.c b/sysutils/psmisc/files/patch-src-killall.c
index b83148e82175..29719b45e3ad 100644
--- a/sysutils/psmisc/files/patch-src-killall.c
+++ b/sysutils/psmisc/files/patch-src-killall.c
@@ -1,5 +1,5 @@
---- src/killall.c.orig 2011-06-20 04:43:24.000000000 -0700
-+++ src/killall.c 2011-08-06 21:48:35.014330713 -0700
+--- src/killall.c.orig 2012-02-19 23:08:52 UTC
++++ src/killall.c
@@ -36,6 +36,8 @@
#include <dirent.h>
#include <signal.h>
@@ -9,7 +9,7 @@
#include <sys/types.h>
#include <sys/stat.h>
#include <getopt.h>
-@@ -87,40 +89,35 @@
+@@ -87,40 +89,35 @@ static int verbose = 0, exact = 0, inter
ignore_case = 0, pidof;
static long younger_than = 0, older_than = 0;
@@ -74,7 +74,7 @@
}
static double
-@@ -197,7 +194,7 @@
+@@ -197,7 +194,7 @@ match_process_uid(pid_t pid, uid_t uid)
while (fgets(buf, sizeof buf, f))
{
@@ -83,7 +83,7 @@
{
re = uid==puid;
break;
-@@ -360,7 +357,7 @@
+@@ -360,7 +357,7 @@ kill_all (int signal, int names, char **
}
#endif /*WITH_SELINUX*/
/* load process name */
@@ -92,7 +92,7 @@
continue;
if (!(file = fopen (path, "r")))
{
-@@ -368,7 +365,7 @@
+@@ -368,7 +365,7 @@ kill_all (int signal, int names, char **
continue;
}
free (path);
@@ -101,7 +101,7 @@
if (!okay) {
fclose(file);
continue;
-@@ -390,65 +387,6 @@
+@@ -390,65 +387,6 @@ kill_all (int signal, int names, char **
got_long = 0;
command = NULL; /* make gcc happy */
length = strlen (comm);
@@ -167,7 +167,7 @@
/* mach by process name */
for (j = 0; j < names; j++)
{
-@@ -499,7 +437,7 @@
+@@ -499,7 +437,7 @@ kill_all (int signal, int names, char **
{
int ok = 1;
@@ -176,7 +176,7 @@
continue;
if (stat (path, &st) < 0)
-@@ -693,7 +631,7 @@
+@@ -693,7 +631,7 @@ have_proc_self_stat (void)
struct stat isproc;
pid_t pid = getpid();
diff --git a/sysutils/psmisc/files/patch-src-pstree.c b/sysutils/psmisc/files/patch-src-pstree.c
index c8005758f0a6..00c9e64869c4 100644
--- a/sysutils/psmisc/files/patch-src-pstree.c
+++ b/sysutils/psmisc/files/patch-src-pstree.c
@@ -1,20 +1,20 @@
---- src/pstree.c.orig 2009-12-27 15:46:47.000000000 +0900
-+++ src/pstree.c 2010-01-03 00:52:21.437862505 +0900
+--- src/pstree.c.orig 2012-02-19 23:07:14 UTC
++++ src/pstree.c
@@ -37,6 +37,9 @@
#include <term.h>
#include <termios.h>
#include <langinfo.h>
-+#ifdef __FreeBSD__
++#if defined __FreeBSD__ || defined __DragonFly__
+#include <limits.h>
+#endif
#include <assert.h>
#include <sys/types.h>
#include <sys/stat.h>
-@@ -590,7 +594,11 @@
+@@ -609,7 +612,11 @@ static void read_proc(void)
struct dirent *de;
FILE *file;
struct stat st;
-+#ifdef __FreeBSD__
++#if defined __FreeBSD__ || defined __DragonFly__
+ char *path, comm[COMM_LEN + 1];
+#else
char *path, *comm;
@@ -22,11 +22,11 @@
char *buffer;
size_t buffer_size;
char readbuf[BUFSIZ + 1];
-@@ -623,7 +631,11 @@
+@@ -642,7 +649,11 @@ static void read_proc(void)
if ((pid = (pid_t) atoi(de->d_name)) != 0) {
if (! (path = malloc(strlen(PROC_BASE) + strlen(de->d_name) + 10)))
exit(2);
-+#ifdef __FreeBSD__
++#if defined __FreeBSD__ || defined __DragonFly__
+ sprintf(path, "%s/%d/status", PROC_BASE, pid);
+#else
sprintf(path, "%s/%d/stat", PROC_BASE, pid);
@@ -34,11 +34,11 @@
if ((file = fopen(path, "r")) != NULL) {
empty = 0;
sprintf(path, "%s/%d", PROC_BASE, pid);
-@@ -638,6 +650,29 @@
+@@ -657,6 +668,29 @@ static void read_proc(void)
perror(path);
exit(1);
}
-+#ifdef __FreeBSD__
++#if defined __FreeBSD__ || defined __DragonFly__
+ /* Read comm and ppid */
+ if (fscanf(file, "%s %*d %d", readbuf, &ppid) == 2) {
+ tmpptr = readbuf;
@@ -64,11 +64,11 @@
size = fread(readbuf, 1, BUFSIZ, file);
if (ferror(file) == 0) {
readbuf[size] = 0;
-@@ -692,6 +727,7 @@
+@@ -711,6 +745,7 @@ static void read_proc(void)
(void) closedir(taskdir);
}
free(taskpath);
-+#endif /*__FreeBSD__*/
++#endif /*__FreeBSD__ || __DragonFly__ */
if (!print_args)
#ifdef WITH_SELINUX
add_proc(comm, pid, ppid, st.st_uid, NULL, 0, 0, scontext);