aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pstree
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-07-08 11:12:42 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-07-08 11:12:42 +0000
commit9e1083c1ed5bea8db13041510f04e7773e73bb44 (patch)
tree29a145f6cf1e1c6d17eca1a72d178a1776ad2740 /sysutils/pstree
parenta2eebabb1f459c89ffbb8650b9a4873fd8535d6e (diff)
downloadports-9e1083c1ed5bea8db13041510f04e7773e73bb44.tar.gz
ports-9e1083c1ed5bea8db13041510f04e7773e73bb44.zip
Notes
Diffstat (limited to 'sysutils/pstree')
-rw-r--r--sysutils/pstree/Makefile7
-rw-r--r--sysutils/pstree/distinfo4
-rw-r--r--sysutils/pstree/files/patch-pstree.c14
3 files changed, 6 insertions, 19 deletions
diff --git a/sysutils/pstree/Makefile b/sysutils/pstree/Makefile
index 9a546cf8e488..a71e3d513500 100644
--- a/sysutils/pstree/Makefile
+++ b/sysutils/pstree/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= pstree
-PORTVERSION= 2.21
+PORTVERSION= 2.25
CATEGORIES= sysutils
-MASTER_SITES= http://fresh.t-systems-sfr.com/unix/src/misc/
+MASTER_SITES= ftp://ftp.thp.uni-duisburg.de/pub/source/ \
+ http://fresh.t-systems-sfr.com/unix/src/misc/
MAINTAINER= ports@FreeBSD.org
COMMENT= List processes as a tree
NO_WRKSUBDIR= yes
-CONFLICTS= psmisc-*
+CONFLICTS= psmisc-[0-9]*
PLIST_FILES= bin/pstree
diff --git a/sysutils/pstree/distinfo b/sysutils/pstree/distinfo
index f0a5f9bd3131..e4bd94c67f7b 100644
--- a/sysutils/pstree/distinfo
+++ b/sysutils/pstree/distinfo
@@ -1,2 +1,2 @@
-MD5 (pstree-2.21.tar.gz) = d091946ea76b89ec74216d9ccd7b0702
-SIZE (pstree-2.21.tar.gz) = 8436
+MD5 (pstree-2.25.tar.gz) = 2d0e3a0e80c033e81f781fe718f1cfe8
+SIZE (pstree-2.25.tar.gz) = 9106
diff --git a/sysutils/pstree/files/patch-pstree.c b/sysutils/pstree/files/patch-pstree.c
deleted file mode 100644
index 122956e3f867..000000000000
--- a/sysutils/pstree/files/patch-pstree.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- pstree.c.orig
-+++ pstree.c
-@@ -655,8 +655,9 @@
- sprintf(nhead, "%s%s ", head,
- head[0] == '\0' ? "" : EXIST(P[idx].sister) ? C->bar : " ");
-
-- for (child = P[idx].child; EXIST(child); child = P[child].sister)
-- PrintTree(child, nhead);
-+ if (P[idx].pid)
-+ for (child = P[idx].child; EXIST(child); child = P[child].sister)
-+ PrintTree(child, nhead);
- }
-
- void Usage(void) {