aboutsummaryrefslogtreecommitdiff
path: root/sysutils/puppet
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-02-01 17:29:09 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-02-01 17:29:09 +0000
commit9a7174a78f82c4408d6553b00b65f9a9aeb6526b (patch)
treee5da63d904f89ee876ac77ddc699ec1224d8b9da /sysutils/puppet
parentfe5c059cc92e232b1f50b0a7da4cbe51f6d98cf3 (diff)
downloadports-9a7174a78f82c4408d6553b00b65f9a9aeb6526b.tar.gz
ports-9a7174a78f82c4408d6553b00b65f9a9aeb6526b.zip
Notes
Diffstat (limited to 'sysutils/puppet')
-rw-r--r--sysutils/puppet/Makefile1
-rw-r--r--sysutils/puppet/files/patch-lib-puppet-provider-cron-crontab.rb25
2 files changed, 26 insertions, 0 deletions
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
index 16fffd8aef5d..378ecd5ffd37 100644
--- a/sysutils/puppet/Makefile
+++ b/sysutils/puppet/Makefile
@@ -7,6 +7,7 @@
PORTNAME= puppet
PORTVERSION= 0.25.3
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.reductivelabs.com/downloads/puppet/
diff --git a/sysutils/puppet/files/patch-lib-puppet-provider-cron-crontab.rb b/sysutils/puppet/files/patch-lib-puppet-provider-cron-crontab.rb
new file mode 100644
index 000000000000..8d17e2b7fa44
--- /dev/null
+++ b/sysutils/puppet/files/patch-lib-puppet-provider-cron-crontab.rb
@@ -0,0 +1,25 @@
+--- lib/puppet/provider/cron/crontab.rb.orig 2010-01-11 23:55:13.000000000 +0000
++++ lib/puppet/provider/cron/crontab.rb 2010-01-19 02:49:58.000000000 +0000
+@@ -27,13 +27,18 @@
+
+ text_line :environment, :match => %r{^\w+=}
+
+- crontab = record_line :crontab, :fields => %w{special minute hour monthday month weekday command},
+- :match => %r{^\s*(?:@(\w+)|(\S+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S+))\s+(.+)$},
+- :optional => %w{special minute hour weekday month monthday}, :absent => "*"
++ record_line :freebsd_special, :fields => %w{special command},
++ :match => %r{^@(\w+)\s+(.+)$}, :pre_gen => proc { |record|
++ record[:special] = "@" + record[:special]
++ }
++
++ crontab = record_line :crontab, :fields => %w{minute hour monthday month weekday command},
++ :match => %r{^\s*(\S+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(.+)$},
++ :optional => %w{minute hour weekday month monthday}, :absent => "*"
+
+ class << crontab
+ def numeric_fields
+- fields - [:command, :special]
++ fields - [:command]
+ end
+ # Do some post-processing of the parsed record. Basically just
+ # split the numeric fields on ','.