aboutsummaryrefslogtreecommitdiff
path: root/sysutils/puppet
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-02-04 19:46:20 +0000
committerSteve Wills <swills@FreeBSD.org>2012-02-04 19:46:20 +0000
commit341a11671f1e040f87be6296c9c0da188a09e94b (patch)
treeefc51384ffe649d68cd2fd17a35ad44930621574 /sysutils/puppet
parent16d1e7a2f3515ca7a388daf26005c697329925fa (diff)
downloadports-341a11671f1e040f87be6296c9c0da188a09e94b.tar.gz
ports-341a11671f1e040f87be6296c9c0da188a09e94b.zip
Notes
Diffstat (limited to 'sysutils/puppet')
-rw-r--r--sysutils/puppet/Makefile4
-rw-r--r--sysutils/puppet/distinfo4
-rw-r--r--sysutils/puppet/files/patch-fix_password_provider55
3 files changed, 3 insertions, 60 deletions
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
index 2adc86a11ade..9658bc5242c0 100644
--- a/sysutils/puppet/Makefile
+++ b/sysutils/puppet/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= puppet
-PORTVERSION= 2.7.9
+PORTVERSION= 2.7.10
CATEGORIES= sysutils
MASTER_SITES= http://downloads.puppetlabs.com/puppet/
@@ -16,8 +16,6 @@ COMMENT= A configuration management framework written in Ruby
RUN_DEPENDS= facter>=0:${PORTSDIR}/sysutils/facter \
rubygem-ruby-augeas>=0:${PORTSDIR}/textproc/rubygem-augeas
-CONFLICTS= puppet-devel-[0-9]*
-
NO_BUILD= yes
USE_RUBY= yes
USE_RUBY_FEATURES= iconv
diff --git a/sysutils/puppet/distinfo b/sysutils/puppet/distinfo
index 51c2529ea52b..8f4b84826a75 100644
--- a/sysutils/puppet/distinfo
+++ b/sysutils/puppet/distinfo
@@ -1,2 +1,2 @@
-SHA256 (puppet-2.7.9.tar.gz) = b15a2031e39c8eb8768efcc2d24030258abc9e33efd9c5212ab0fd9b983e2b94
-SIZE (puppet-2.7.9.tar.gz) = 1778208
+SHA256 (puppet-2.7.10.tar.gz) = 0d0452ed2a22acb60f9fd4ebaeb6d04bb73ab5299f59003bf7b53d6391dc1127
+SIZE (puppet-2.7.10.tar.gz) = 1843484
diff --git a/sysutils/puppet/files/patch-fix_password_provider b/sysutils/puppet/files/patch-fix_password_provider
deleted file mode 100644
index 8758296d017b..000000000000
--- a/sysutils/puppet/files/patch-fix_password_provider
+++ /dev/null
@@ -1,55 +0,0 @@
---- lib/puppet/provider/user/pw.rb
-+++ lib/puppet/provider/user/pw.rb
-@@ -1,10 +1,11 @@
- require 'puppet/provider/nameservice/pw'
-+require 'open3'
-
- Puppet::Type.type(:user).provide :pw, :parent => Puppet::Provider::NameService::PW do
- desc "User management via `pw` on FreeBSD."
-
- commands :pw => "pw"
-- has_features :manages_homedir, :allows_duplicates
-+ has_features :manages_homedir, :allows_duplicates, :manages_passwords
-
- defaultfor :operatingsystem => :freebsd
-
-@@ -23,7 +24,7 @@ Puppet::Type.type(:user).provide :pw, :parent => Puppet::Provider::NameService::
- def addcmd
- cmd = [command(:pw), "useradd", @resource[:name]]
- @resource.class.validproperties.each do |property|
-- next if property == :ensure
-+ next if property == :ensure or property == :password
- # the value needs to be quoted, mostly because -c might
- # have spaces in it
- if value = @resource.should(property) and value != ""
-@@ -37,5 +38,30 @@ Puppet::Type.type(:user).provide :pw, :parent => Puppet::Provider::NameService::
-
- cmd
- end
-+
-+ def create
-+ super
-+
-+ # Set the password after create if given
-+ self.password = @resource[:password] if @resource[:password]
-+ end
-+
-+ # use pw to update password hash
-+ def password=(cryptopw)
-+ Puppet.debug "change password for user '#{@resource[:name]}' method called with hash '#{cryptopw}'"
-+ stdin, stdout, stderr = Open3.popen3("pw user mod #{@resource[:name]} -H 0")
-+ stdin.puts(cryptopw)
-+ stdin.close
-+ Puppet.debug "finished password for user '#{@resource[:name]}' method called with hash '#{cryptopw}'"
-+ end
-+
-+ # get password from /etc/master.passwd
-+ def password
-+ Puppet.debug "checking password for user '#{@resource[:name]}' method called"
-+ current_passline = `getent passwd #{@resource[:name]}`
-+ current_password = current_passline.chomp.split(':')[1] if current_passline
-+ Puppet.debug "finished password for user '#{@resource[:name]}' method called : '#{current_password}'"
-+ current_password
-+ end
- end
-