aboutsummaryrefslogtreecommitdiff
path: root/sysutils/puppet
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-02-05 02:08:09 +0000
committerSteve Wills <swills@FreeBSD.org>2016-02-05 02:08:09 +0000
commite0196b79e41f56c973f7586c3116aa5ba622d6f4 (patch)
treee70599813e0fe09f2b2cce67b193d63b2ca462e0 /sysutils/puppet
parentba8a41dac7d1fa2d17077f14e7c784bd78c4464c (diff)
downloadports-e0196b79e41f56c973f7586c3116aa5ba622d6f4.tar.gz
ports-e0196b79e41f56c973f7586c3116aa5ba622d6f4.zip
Notes
Diffstat (limited to 'sysutils/puppet')
-rw-r--r--sysutils/puppet/Makefile86
-rw-r--r--sysutils/puppet/distinfo2
-rw-r--r--sysutils/puppet/files/patch-demote_ports_provider13
-rw-r--r--sysutils/puppet/files/patch-ext__rack__config.ru13
-rw-r--r--sysutils/puppet/files/patch-lib_puppet_provider_package_pkgng.rb145
-rw-r--r--sysutils/puppet/files/patch-lib_puppet_provider_service_freebsd.rb11
-rw-r--r--sysutils/puppet/files/patch-lib_puppet_vendor_safe__yaml_lib_safe__yaml.rb11
-rw-r--r--sysutils/puppet/files/pkg-message.in14
-rw-r--r--sysutils/puppet/files/puppet.in33
-rw-r--r--sysutils/puppet/files/puppetmaster.in56
-rw-r--r--sysutils/puppet/pkg-descr7
-rw-r--r--sysutils/puppet/pkg-plist53
12 files changed, 0 insertions, 444 deletions
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
deleted file mode 100644
index 806a31b3aef8..000000000000
--- a/sysutils/puppet/Makefile
+++ /dev/null
@@ -1,86 +0,0 @@
-# Created by: Tomoyuki Sakurai <cherry@trombik.mine.nu>
-# $FreeBSD$
-
-PORTNAME= puppet
-PORTVERSION= 3.8.4
-PORTREVISION= 1
-CATEGORIES= sysutils
-MASTER_SITES= http://downloads.puppetlabs.com/puppet/
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= Configuration management framework written in Ruby
-
-LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
-BUILD_DEPENDS= rubygem-facter>=0:${PORTSDIR}/sysutils/rubygem-facter \
- rubygem-hiera1>=0:${PORTSDIR}/sysutils/rubygem-hiera1
-RUN_DEPENDS= rubygem-facter>=0:${PORTSDIR}/sysutils/rubygem-facter \
- rubygem-ruby-augeas>=0:${PORTSDIR}/textproc/rubygem-ruby-augeas \
- rubygem-hiera1>=0:${PORTSDIR}/sysutils/rubygem-hiera1
-
-USES= cpe
-CPE_VENDOR= puppetlabs
-CONFLICTS_INSTALL= puppet37-* puppet4-*
-NO_BUILD= yes
-NO_ARCH= yes
-USE_RUBY= yes
-USE_RC_SUBR= puppet puppetmaster
-PORTDOCS= LICENSE README.md
-PORTEXAMPLES= *
-USERS= puppet
-GROUPS= puppet
-SUB_FILES+= pkg-message
-SUB_LIST= RUBY=${RUBY}
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-post-patch:
- @${REINPLACE_CMD} -e "s|/etc/puppet|${ETCDIR}|" \
- ${WRKSRC}/install.rb \
- ${WRKSRC}/lib/puppet/reference/configuration.rb \
- ${WRKSRC}/lib/puppet/defaults.rb \
- ${WRKSRC}/lib/puppet/util/run_mode.rb
- @${REINPLACE_CMD} -e "s|/var/lib/puppet|/var/puppet|" \
- ${WRKSRC}/lib/puppet/reference/configuration.rb \
- ${WRKSRC}/lib/puppet/util/run_mode.rb
- @${REINPLACE_CMD} -e "s|\$$vardir/run|/var/run/puppet|" \
- ${WRKSRC}/lib/puppet/util/run_mode.rb
- @${REINPLACE_CMD} -e "s|\$$confdir/ssl|/var/puppet/ssl|" \
- ${WRKSRC}/lib/puppet/defaults.rb
- @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" \
- ${WRKSRC}/ext/rack/config.ru
-
-do-install:
- @cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} ${RUBY} ${WRKSRC}/install.rb --no-configs --destdir=${STAGEDIR}
-
-post-install:
- ${MKDIR} ${STAGEDIR}${ETCDIR}/manifests
- ${MKDIR} ${STAGEDIR}${ETCDIR}/modules
- ${MKDIR} ${STAGEDIR}/var/puppet
- ${INSTALL_DATA} ${WRKSRC}/conf/auth.conf ${STAGEDIR}${ETCDIR}/auth.conf-dist
- ${RUBY} -I ${STAGEDIR}/${RUBY_SITELIBDIR} ${STAGEDIR}${PREFIX}/bin/puppet agent --genconfig \
- --confdir=${ETCDIR} \
- --rundir=/var/run/puppet \
- --vardir=/var/puppet \
- --logdir=/var/log/puppet \
- > ${STAGEDIR}${ETCDIR}/puppet.conf-dist
- @${ECHO} ${STAGEDIR}${RUBY_SITELIBDIR}/puppet.rb | \
- ${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
- @${ECHO} ${STAGEDIR}${RUBY_SITELIBDIR}/semver.rb | \
- ${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${STAGEDIR}${RUBY_SITELIBDIR}/${PORTNAME} -type f | \
- ${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
- @${MKDIR} ${STAGEDIR}${WWWDIR}
- ${INSTALL_DATA} ${WRKSRC}/ext/rack/config.ru ${STAGEDIR}${WWWDIR}
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-
-post-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/ext/rack/example-passenger-vhost.conf ${STAGEDIR}${EXAMPLESDIR}
-
-.include <bsd.port.mk>
diff --git a/sysutils/puppet/distinfo b/sysutils/puppet/distinfo
deleted file mode 100644
index eb22e6a5d49b..000000000000
--- a/sysutils/puppet/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (puppet-3.8.4.tar.gz) = 19e83ebbbf0933a9df6696255d7ff4d65e3daba1ed8dacf87f16a87ae40a7ad7
-SIZE (puppet-3.8.4.tar.gz) = 2639537
diff --git a/sysutils/puppet/files/patch-demote_ports_provider b/sysutils/puppet/files/patch-demote_ports_provider
deleted file mode 100644
index 6e5245f4c44c..000000000000
--- a/sysutils/puppet/files/patch-demote_ports_provider
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/lib/puppet/provider/package/ports.rb b/lib/puppet/provider/package/ports.rb
-index c802092..1f2ed43 100755
---- lib/puppet/provider/package/ports.rb
-+++ lib/puppet/provider/package/ports.rb
-@@ -6,8 +6,6 @@ Puppet::Type.type(:package).provide :ports, :parent => :freebsd, :source => :fre
- :portuninstall => "/usr/local/sbin/pkg_deinstall",
- :portinfo => "/usr/sbin/pkg_info"
-
-- defaultfor :operatingsystem => :freebsd
--
- # I hate ports
- %w{INTERACTIVE UNAME}.each do |var|
- ENV.delete(var) if ENV.include?(var)
diff --git a/sysutils/puppet/files/patch-ext__rack__config.ru b/sysutils/puppet/files/patch-ext__rack__config.ru
deleted file mode 100644
index 505fac04bbe6..000000000000
--- a/sysutils/puppet/files/patch-ext__rack__config.ru
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./ext/rack/config.ru.orig 2013-12-20 16:47:22.876896492 +0000
-+++ ./ext/rack/config.ru 2013-12-20 16:47:33.826895721 +0000
-@@ -14,8 +14,8 @@
- # Rack applications typically don't start as root. Set --confdir and --vardir
- # to prevent reading configuration from ~puppet/.puppet/puppet.conf and writing
- # to ~puppet/.puppet
--ARGV << "--confdir" << "/etc/puppet"
--ARGV << "--vardir" << "/var/lib/puppet"
-+ARGV << "--confdir" << "%%PREFIX%%/etc/puppet"
-+ARGV << "--vardir" << "/var/puppet"
-
- # NOTE: it's unfortunate that we have to use the "CommandLine" class
- # here to launch the app, but it contains some initialization logic
diff --git a/sysutils/puppet/files/patch-lib_puppet_provider_package_pkgng.rb b/sysutils/puppet/files/patch-lib_puppet_provider_package_pkgng.rb
deleted file mode 100644
index bd310d35c0a7..000000000000
--- a/sysutils/puppet/files/patch-lib_puppet_provider_package_pkgng.rb
+++ /dev/null
@@ -1,145 +0,0 @@
---- /dev/null
-+++ lib/puppet/provider/package/pkgng.rb
-@@ -0,0 +1,142 @@
-+require 'puppet/provider/package'
-+
-+Puppet::Type.type(:package).provide :pkgng, :parent => Puppet::Provider::Package do
-+ desc "A PkgNG provider for FreeBSD and DragonFly."
-+
-+ commands :pkg => "/usr/local/sbin/pkg"
-+
-+ confine :operatingsystem => [:freebsd, :dragonfly]
-+
-+ defaultfor :operatingsystem => [:freebsd, :dragonfly]
-+
-+ has_feature :versionable
-+ has_feature :upgradeable
-+
-+ def self.get_query
-+ pkg(['query', '-a', '%n %v %o'])
-+ end
-+
-+ def self.get_version_list
-+ @version_info_list ||= pkg(['version', '-voRL='])
-+ end
-+
-+ def self.get_latest_version(origin)
-+ if latest_version = self.get_version_list.lines.find { |l| l =~ /^#{origin} / }
-+ latest_version = latest_version.split(' ').last.split(')').first
-+ return latest_version
-+ end
-+ nil
-+ end
-+
-+ def self.instances
-+ packages = []
-+ begin
-+ info = self.get_query
-+
-+ unless info
-+ return packages
-+ end
-+
-+ info.lines.each do |line|
-+
-+ name, version, origin = line.chomp.split(" ", 3)
-+ latest_version = get_latest_version(origin) || version
-+
-+ pkg = {
-+ :ensure => version,
-+ :name => name,
-+ :provider => self.name,
-+ :origin => origin,
-+ :version => version,
-+ :latest => latest_version
-+ }
-+ packages << new(pkg)
-+ end
-+
-+ return packages
-+ rescue Puppet::ExecutionFailure
-+ nil
-+ end
-+ end
-+
-+ def self.prefetch(resources)
-+ packages = instances
-+ resources.keys.each do |name|
-+ if provider = packages.find{|p| p.name == name or p.origin == name }
-+ resources[name].provider = provider
-+ end
-+ end
-+ end
-+
-+ def repo_tag_from_urn(urn)
-+ # extract repo tag from URN: urn:freebsd:repo:<tag>
-+ match = /^urn:freebsd:repo:(.+)$/.match(urn)
-+ raise ArgumentError urn.inspect unless match
-+ match[1]
-+ end
-+
-+ def install
-+ source = resource[:source]
-+ source = URI(source) unless source.nil?
-+
-+ # Ensure we handle the version
-+ case resource[:ensure]
-+ when true, false, Symbol
-+ installname = resource[:name]
-+ else
-+ # If resource[:name] is actually an origin (e.g. 'www/curl' instead of
-+ # just 'curl'), drop the category prefix. pkgng doesn't support version
-+ # pinning with the origin syntax (pkg install curl-1.2.3 is valid, but
-+ # pkg install www/curl-1.2.3 is not).
-+ if resource[:name] =~ /\//
-+ installname = resource[:name].split('/')[1] + '-' + resource[:ensure]
-+ else
-+ installname = resource[:name] + '-' + resource[:ensure]
-+ end
-+ end
-+
-+ if not source # install using default repo logic
-+ args = ['install', '-qy', installname]
-+ elsif source.scheme == 'urn' # install from repo named in URN
-+ tag = repo_tag_from_urn(source.to_s)
-+ args = ['install', '-qy', '-r', tag, installname]
-+ else # add package located at URL
-+ args = ['add', '-q', source.to_s]
-+ end
-+
-+ pkg(args)
-+ end
-+
-+ def uninstall
-+ pkg(['remove', '-qy', resource[:name]])
-+ end
-+
-+ def query
-+ if @property_hash[:ensure] == nil
-+ return nil
-+ else
-+ version = @property_hash[:version]
-+ return { :version => version }
-+ end
-+ end
-+
-+ def version
-+ @property_hash[:version]
-+ end
-+
-+ # Upgrade to the latest version
-+ def update
-+ install
-+ end
-+
-+ # Return the latest version of the package
-+ def latest
-+ debug "returning the latest #{@property_hash[:name].inspect} version #{@property_hash[:latest].inspect}"
-+ @property_hash[:latest]
-+ end
-+
-+ def origin
-+ @property_hash[:origin]
-+ end
-+
-+end
diff --git a/sysutils/puppet/files/patch-lib_puppet_provider_service_freebsd.rb b/sysutils/puppet/files/patch-lib_puppet_provider_service_freebsd.rb
deleted file mode 100644
index 067d40b3b1ac..000000000000
--- a/sysutils/puppet/files/patch-lib_puppet_provider_service_freebsd.rb
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/puppet/provider/service/freebsd.rb.orig 2015-05-30 18:06:50 UTC
-+++ lib/puppet/provider/service/freebsd.rb
-@@ -39,7 +39,7 @@ Puppet::Type.type(:service).provide :fre
-
- # Extract service name
- def service_name
-- extract_value_name('service', 0, /# (.*)/, '\1')
-+ extract_value_name('service', 0, /# (\S+).*/, '\1')
- end
-
- # Extract rcvar name
diff --git a/sysutils/puppet/files/patch-lib_puppet_vendor_safe__yaml_lib_safe__yaml.rb b/sysutils/puppet/files/patch-lib_puppet_vendor_safe__yaml_lib_safe__yaml.rb
deleted file mode 100644
index f81c496bd057..000000000000
--- a/sysutils/puppet/files/patch-lib_puppet_vendor_safe__yaml_lib_safe__yaml.rb
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/puppet/vendor/safe_yaml/lib/safe_yaml.rb.orig 2015-08-06 16:17:42 UTC
-+++ lib/puppet/vendor/safe_yaml/lib/safe_yaml.rb
-@@ -3,7 +3,7 @@ require "yaml"
- # This needs to be defined up front in case any internal classes need to base
- # their behavior off of this.
- module SafeYAML
-- YAML_ENGINE = defined?(YAML::ENGINE) ? YAML::ENGINE.yamler : "syck"
-+ YAML_ENGINE = defined?(YAML::ENGINE) ? YAML::ENGINE.yamler : (defined?(Psych) && YAML == Psych ? "psych" : "syck")
- end
-
- require "set"
diff --git a/sysutils/puppet/files/pkg-message.in b/sysutils/puppet/files/pkg-message.in
deleted file mode 100644
index d036be0a93e0..000000000000
--- a/sysutils/puppet/files/pkg-message.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-To enable the puppet agent, add the following to /etc/rc.conf:
-
- puppet_enable="YES"
-
-To enable the puppetmaster, add the following to /etc/rc.conf:
-
- puppetmaster_enable="YES"
-
-Individual config files such as %%PREFIX%%/etc/puppetmasterd.conf are
-deprecated. Use a single file, %%ETCDIR%%/puppet.conf.
-
-The default PID directory is /var/run/puppet
-
diff --git a/sysutils/puppet/files/puppet.in b/sysutils/puppet/files/puppet.in
deleted file mode 100644
index 8ef80e5bd240..000000000000
--- a/sysutils/puppet/files/puppet.in
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: puppet
-# REQUIRE: LOGIN
-# KEYWORD: shutdown
-
-#
-# Add the following lines to /etc/rc.conf to enable the puppet agent:
-#
-# puppet_enable="YES"
-
-. /etc/rc.subr
-
-name="puppet"
-rcvar=puppet_enable
-
-load_rc_config "$name"
-
-: ${puppet_enable="NO"}
-: ${puppet_rundir="/var/run/puppet"}
-
-command="%%PREFIX%%/bin/puppet"
-command_args="agent ${puppet_flags} --rundir=${puppet_rundir}"
-command_interpreter=%%RUBY%%
-unset puppet_flags
-
-pidfile="${puppet_rundir}/agent.pid"
-start_precmd="install -d -o puppet -g puppet ${pidfile%/*}"
-
-run_rc_command "$1"
diff --git a/sysutils/puppet/files/puppetmaster.in b/sysutils/puppet/files/puppetmaster.in
deleted file mode 100644
index 8c7a93d19033..000000000000
--- a/sysutils/puppet/files/puppetmaster.in
+++ /dev/null
@@ -1,56 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: puppetmaster
-# REQUIRE: LOGIN
-
-# Add the following lines to /etc/rc.conf to enable the puppetmaster:
-#
-# puppetmaster_enable="YES"
-#
-
-. /etc/rc.subr
-
-name="puppetmaster"
-rcvar=puppetmaster_enable
-
-load_rc_config "${name}"
-
-: ${puppetmaster_enable="NO"}
-: ${puppetmaster_rundir="/var/run/puppet"}
-: ${puppetmaster_flags="--rundir=${puppetmaster_rundir}"}
-
-command_interpreter=%%RUBY%%
-command="%%PREFIX%%/bin/puppet"
-command_args="master ${puppetmaster_flags}"
-unset puppetmaster_flags
-
-pidfile="${puppetmaster_rundir}/master.pid"
-puppet_manifest="$($command config print manifest)"
-
-start_precmd="puppetmaster_checkconfig"
-restart_precmd="puppetmaster_checkconfig"
-puppetmaster_checkconfig() {
- echo -n "Performing sanity check of ${name} configuration: "
- if ! ${command} parser validate "${puppet_manifest}"
- then
- echo "FAILED"
- return 1
- else
- echo "OK"
- return 0
- fi
-}
-
-if [ -z "${puppetmaster_mongrel_ports}" ]; then
- run_rc_command "$1"
-else
- for port in ${puppetmaster_mongrel_ports}; do
- pidfile="${puppetmaster_rundir}/mongrel.${port}.pid"
- command_args="master --pidfile=${pidfile} --servertype=mongrel --masterport=${port}"
- run_rc_command "$1"
- _rc_restart_done="false"
- done
-fi
diff --git a/sysutils/puppet/pkg-descr b/sysutils/puppet/pkg-descr
deleted file mode 100644
index 89a2fce63e8d..000000000000
--- a/sysutils/puppet/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-Puppet lets you centrally manage every important aspect of your system using
-a cross-platform specification language that manages all the separate
-elements normally aggregated in different files, like users, cron jobs, and
-hosts, along with obviously discrete elements like packages, services, and
-files.
-
-WWW: https://puppetlabs.com/puppet/puppet-open-source
diff --git a/sysutils/puppet/pkg-plist b/sysutils/puppet/pkg-plist
deleted file mode 100644
index c49bad37ddfb..000000000000
--- a/sysutils/puppet/pkg-plist
+++ /dev/null
@@ -1,53 +0,0 @@
-bin/extlookup2hiera
-bin/puppet
-man/man5/puppet.conf.5.gz
-man/man8/extlookup2hiera.8.gz
-man/man8/puppet-agent.8.gz
-man/man8/puppet-apply.8.gz
-man/man8/puppet-ca.8.gz
-man/man8/puppet-catalog.8.gz
-man/man8/puppet-cert.8.gz
-man/man8/puppet-certificate.8.gz
-man/man8/puppet-certificate_request.8.gz
-man/man8/puppet-certificate_revocation_list.8.gz
-man/man8/puppet-config.8.gz
-man/man8/puppet-describe.8.gz
-man/man8/puppet-device.8.gz
-man/man8/puppet-doc.8.gz
-man/man8/puppet-facts.8.gz
-man/man8/puppet-file.8.gz
-man/man8/puppet-filebucket.8.gz
-man/man8/puppet-help.8.gz
-man/man8/puppet-inspect.8.gz
-man/man8/puppet-instrumentation_data.8.gz
-man/man8/puppet-instrumentation_listener.8.gz
-man/man8/puppet-instrumentation_probe.8.gz
-man/man8/puppet-key.8.gz
-man/man8/puppet-kick.8.gz
-man/man8/puppet-man.8.gz
-man/man8/puppet-master.8.gz
-man/man8/puppet-module.8.gz
-man/man8/puppet-node.8.gz
-man/man8/puppet-parser.8.gz
-man/man8/puppet-plugin.8.gz
-man/man8/puppet-queue.8.gz
-man/man8/puppet-report.8.gz
-man/man8/puppet-resource.8.gz
-man/man8/puppet-resource_type.8.gz
-man/man8/puppet-secret_agent.8.gz
-man/man8/puppet-status.8.gz
-man/man8/puppet.8.gz
-%%RUBY_SITELIBDIR%%/hiera/backend/puppet_backend.rb
-%%RUBY_SITELIBDIR%%/hiera/puppet_function.rb
-%%RUBY_SITELIBDIR%%/hiera/scope.rb
-%%RUBY_SITELIBDIR%%/hiera_puppet.rb
-%%RUBY_SITELIBDIR%%/puppetx/puppetlabs/syntax_checkers/json.rb
-%%RUBY_SITELIBDIR%%/puppetx/puppet/syntax_checker.rb
-%%RUBY_SITELIBDIR%%/puppetx/puppet/bindings_scheme_handler.rb
-%%RUBY_SITELIBDIR%%/puppetx.rb
-%%ETCDIR%%/puppet.conf-dist
-%%ETCDIR%%/auth.conf-dist
-@dir(puppet,puppet,) %%ETCDIR%%/manifests
-@dir(puppet,puppet,) %%ETCDIR%%/modules
-@(puppet,puppet,) www/puppet/config.ru
-@dir(puppet,puppet,) /var/puppet