aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pv
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-06 13:41:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-06 13:41:40 +0000
commit1e5b33d7a1b07d347119e1cc4965414a7baf3b6e (patch)
treeaa8eda5530a61395dd1808f1545d6719bb9d7e32 /sysutils/pv
parent1de9574a0165bcb5d831506a9c0071e956ffdf8d (diff)
downloadports-1e5b33d7a1b07d347119e1cc4965414a7baf3b6e.tar.gz
ports-1e5b33d7a1b07d347119e1cc4965414a7baf3b6e.zip
Notes
Diffstat (limited to 'sysutils/pv')
-rw-r--r--sysutils/pv/Makefile32
-rw-r--r--sysutils/pv/distinfo2
-rw-r--r--sysutils/pv/pkg-descr9
3 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/pv/Makefile b/sysutils/pv/Makefile
new file mode 100644
index 000000000000..bddddf69538a
--- /dev/null
+++ b/sysutils/pv/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: pv
+# Date created: 04 May 2004
+# Whom: Daniel Roethlisberger <daniel@roe.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pv
+PORTVERSION= 0.8.5
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://dragon.roe.ch/mirrors/distfiles/pv/
+MASTER_SITE_SUBDIR= pipeviewer
+
+MAINTAINER= daniel@roe.ch
+COMMENT= A pipe throughput monitor
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAN1= pv.1
+INFO= pv
+
+PLIST_FILES= bin/pv
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pv ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/quickref.1 ${PREFIX}/man/man1/pv.1
+ ${INSTALL_MAN} ${WRKSRC}/doc/pv.info ${PREFIX}/info
+ install-info ${PREFIX}/info/pv.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>
diff --git a/sysutils/pv/distinfo b/sysutils/pv/distinfo
new file mode 100644
index 000000000000..8af1f4501fcf
--- /dev/null
+++ b/sysutils/pv/distinfo
@@ -0,0 +1,2 @@
+MD5 (pv-0.8.5.tar.bz2) = a6eeadbc2fbd9c23e329f47ff37b8c83
+SIZE (pv-0.8.5.tar.bz2) = 84289
diff --git a/sysutils/pv/pkg-descr b/sysutils/pv/pkg-descr
new file mode 100644
index 000000000000..c5209d352401
--- /dev/null
+++ b/sysutils/pv/pkg-descr
@@ -0,0 +1,9 @@
+Pipe Viewer (pv) is a terminal-based tool for monitoring the
+progress of data through a pipeline. It can be inserted into
+any normal pipeline between two processes to give a visual
+indication of how quickly data is passing through, how long
+it has taken, how near to completion it is, and an estimate
+of how long it will be until completion.
+
+Author: Andrew Wood <andrew.wood@ivarch.com>
+WWW: http://www.ivarch.com/programs/pv.shtml