aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-crontab
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2015-07-02 16:20:19 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2015-07-02 16:20:19 +0000
commit6f5698ee6d01fae1c7a4a27cad9428a2fe0a4764 (patch)
tree8625cf03868f5e73b58310674d664ef6271449a9 /sysutils/py-crontab
parent4e3d011569769e6a06e4bccf75fd126154afc154 (diff)
Notes
Diffstat (limited to 'sysutils/py-crontab')
-rw-r--r--sysutils/py-crontab/Makefile22
-rw-r--r--sysutils/py-crontab/distinfo2
-rw-r--r--sysutils/py-crontab/pkg-descr4
3 files changed, 28 insertions, 0 deletions
diff --git a/sysutils/py-crontab/Makefile b/sysutils/py-crontab/Makefile
new file mode 100644
index 000000000000..f59ad0346838
--- /dev/null
+++ b/sysutils/py-crontab/Makefile
@@ -0,0 +1,22 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= crontab
+PORTVERSION= 1.9.3
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Read and write crontab files using a direct API
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=1.5:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}croniter>0:${PORTSDIR}/sysutils/py-croniter
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-crontab/distinfo b/sysutils/py-crontab/distinfo
new file mode 100644
index 000000000000..f18a897cd1f9
--- /dev/null
+++ b/sysutils/py-crontab/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-crontab-1.9.3.tar.gz) = d639116beccef488fee9778bb095096b5a4020fea2f3a82a1405535a625374f7
+SIZE (python-crontab-1.9.3.tar.gz) = 40479
diff --git a/sysutils/py-crontab/pkg-descr b/sysutils/py-crontab/pkg-descr
new file mode 100644
index 000000000000..a2de4de39452
--- /dev/null
+++ b/sysutils/py-crontab/pkg-descr
@@ -0,0 +1,4 @@
+Module for reading and writing crontab files and accessing the system cron
+automatically and simply using a direct API.
+
+WWW: http://pypi.python.org/pypi/crontab/