aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-google-compute-engine
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-08-19 14:15:40 +0000
committerSteve Wills <swills@FreeBSD.org>2018-08-19 14:15:40 +0000
commit7f94536b01b0a63db0c3b91c3f8641387b537841 (patch)
treef9dbd0a78528e2a901751f7fe031ac407fc976c9 /sysutils/py-google-compute-engine
parentada18d20be41a22e561d191a5e2db9601ee7a558 (diff)
downloadports-7f94536b01b0a63db0c3b91c3f8641387b537841.tar.gz
ports-7f94536b01b0a63db0c3b91c3f8641387b537841.zip
sysutils/py-google-compute-engine: remove patches for InstanceSetup
While here, pet portlint by fixing shebang and bump PORTREVISION. PR: 230741 Submitted by: Helen Koike <helen.koike@collabora.com> (maintainer)
Notes
Notes: svn path=/head/; revision=477577
Diffstat (limited to 'sysutils/py-google-compute-engine')
-rw-r--r--sysutils/py-google-compute-engine/Makefile5
-rw-r--r--sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample4
-rw-r--r--sysutils/py-google-compute-engine/files/patch-google__compute__engine_instance__setup_instance__config.py16
-rw-r--r--sysutils/py-google-compute-engine/files/patch-setup.py10
4 files changed, 7 insertions, 28 deletions
diff --git a/sysutils/py-google-compute-engine/Makefile b/sysutils/py-google-compute-engine/Makefile
index 56df7dce11f8..4d310ff8cc08 100644
--- a/sysutils/py-google-compute-engine/Makefile
+++ b/sysutils/py-google-compute-engine/Makefile
@@ -2,7 +2,7 @@
PORTNAME= google-compute-engine
DISTVERSION= 2.8.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,9 +19,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:devel/py-boto@${PY_FLAVOR} \
google_oslogin_control:sysutils/google-compute-engine-oslogin \
sudo:security/sudo
-USES= python
+USES= python shebangfix
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+SHEBANG_FILES= scripts/set_multiqueue scripts/optimize_local_ssd
USE_RC_SUBR= google_instance_setup \
google_accounts_daemon \
diff --git a/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample b/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample
index 08d29c76bf85..2ad0c261d5c0 100644
--- a/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample
+++ b/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample
@@ -6,3 +6,7 @@ groupadd_cmd = pw groupadd {group}
[MetadataScripts]
default_shell = /bin/sh
+
+[InstanceSetup]
+set_multiqueue = false
+optimize_local_ssd = false
diff --git a/sysutils/py-google-compute-engine/files/patch-google__compute__engine_instance__setup_instance__config.py b/sysutils/py-google-compute-engine/files/patch-google__compute__engine_instance__setup_instance__config.py
deleted file mode 100644
index 610e962d9a25..000000000000
--- a/sysutils/py-google-compute-engine/files/patch-google__compute__engine_instance__setup_instance__config.py
+++ /dev/null
@@ -1,16 +0,0 @@
---- google_compute_engine/instance_setup/instance_config.py.orig 2018-06-11 23:51:09 UTC
-+++ google_compute_engine/instance_setup/instance_config.py
-@@ -74,11 +74,11 @@ class InstanceConfig(config_manager.Conf
- },
- 'InstanceSetup': {
- 'host_key_types': 'ecdsa,ed25519,rsa',
-- 'optimize_local_ssd': 'true',
-+ 'optimize_local_ssd': 'false',
- 'network_enabled': 'true',
- 'set_boto_config': 'true',
- 'set_host_keys': 'true',
-- 'set_multiqueue': 'true',
-+ 'set_multiqueue': 'false',
- },
- 'IpForwarding': {
- 'ethernet_proto_id': '66',
diff --git a/sysutils/py-google-compute-engine/files/patch-setup.py b/sysutils/py-google-compute-engine/files/patch-setup.py
deleted file mode 100644
index 69e0c17d2265..000000000000
--- a/sysutils/py-google-compute-engine/files/patch-setup.py
+++ /dev/null
@@ -1,10 +0,0 @@
---- setup.py.orig 2018-06-11 23:51:09 UTC
-+++ setup.py
-@@ -34,7 +34,6 @@ setuptools.setup(
- long_description='Google Compute Engine guest environment.',
- name='google-compute-engine',
- packages=setuptools.find_packages(),
-- scripts=glob.glob('scripts/*'),
- url='https://github.com/GoogleCloudPlatform/compute-image-packages',
- version='2.8.3',
- # Entry points create scripts in /usr/bin that call a function.