aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-pytsk
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-07-29 17:40:05 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2016-07-29 17:40:05 +0000
commit0cd0b9474b172674a7d580e6e992c20b9dae0b99 (patch)
treed4a42243ef917784548cb886ac7c6bd9a1e4b2b2 /sysutils/py-pytsk
parentf68477c719faf08780d5df76611169d86e4b8906 (diff)
Notes
Diffstat (limited to 'sysutils/py-pytsk')
-rw-r--r--sysutils/py-pytsk/Makefile2
-rw-r--r--sysutils/py-pytsk/distinfo5
-rw-r--r--sysutils/py-pytsk/files/patch-setup.py6
3 files changed, 7 insertions, 6 deletions
diff --git a/sysutils/py-pytsk/Makefile b/sysutils/py-pytsk/Makefile
index 489784ffff2d..e9b20ae1aeb6 100644
--- a/sysutils/py-pytsk/Makefile
+++ b/sysutils/py-pytsk/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pytsk
-PORTVERSION= 20160325
+PORTVERSION= 20160721
CATEGORIES= sysutils security devel python
MASTER_SITES= https://github.com/py4n6/pytsk/releases/download/${PORTVERSION}/ \
LOCAL/antoine
diff --git a/sysutils/py-pytsk/distinfo b/sysutils/py-pytsk/distinfo
index a931caaa7f64..38ada0c6c268 100644
--- a/sysutils/py-pytsk/distinfo
+++ b/sysutils/py-pytsk/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pytsk3-20160325.tar.gz) = 403b9e364eb65611a5102d808a7916096b2aa3e32d21dea2c706eae2cc29150d
-SIZE (pytsk3-20160325.tar.gz) = 2739896
+TIMESTAMP = 1469129508
+SHA256 (pytsk3-20160721.tar.gz) = de6f49e687a4eb747d052b43ec55e6eaea5bc33394680ee232af0329209ffc85
+SIZE (pytsk3-20160721.tar.gz) = 2958826
diff --git a/sysutils/py-pytsk/files/patch-setup.py b/sysutils/py-pytsk/files/patch-setup.py
index 5cdfa84bc706..91b4f0e4e3d8 100644
--- a/sysutils/py-pytsk/files/patch-setup.py
+++ b/sysutils/py-pytsk/files/patch-setup.py
@@ -1,6 +1,6 @@
# Unbundle sleuthkit and talloc
---- setup.py.orig 2016-03-25 08:41:14 UTC
+--- setup.py.orig 2016-07-21 19:02:40 UTC
+++ setup.py
@@ -169,9 +169,9 @@ class BuildExtCommand(build_ext):
@@ -14,7 +14,7 @@
if not os.access("pytsk3.c", os.R_OK):
# Generate the Python binding code (pytsk3.c).
-@@ -322,7 +322,7 @@ class ProjectBuilder(object):
+@@ -325,7 +325,7 @@ class ProjectBuilder(object):
self._argv = argv
# The path to the "tsk" directory.
@@ -23,7 +23,7 @@
# paths under the tsk/ directory which contain files we need to compile.
self._sub_library_names = "auto base docs fs hashdb img vs".split()
-@@ -330,14 +330,14 @@ class ProjectBuilder(object):
+@@ -333,14 +333,14 @@ class ProjectBuilder(object):
# The args for the extension builder.
self.extension_args = dict(
define_macros=[],