aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-pyznap
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2018-10-11 16:58:32 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2018-10-11 16:58:32 +0000
commitb84536b0fc977f04c5694d5521974454a2691a8a (patch)
tree70f920826f503ae0072b7a7b9c289145da08b00d /sysutils/py-pyznap
parent539442ccd5f502b6d1c24ba012802a4309f15695 (diff)
downloadports-b84536b0fc977f04c5694d5521974454a2691a8a.tar.gz
ports-b84536b0fc977f04c5694d5521974454a2691a8a.zip
New port: sysutils/py-pyznap: ZFS snapshot tool written in Python
pyznap is a ZFS snapshot management tool. It automatically takes and deletes snapshots and can send them to different remote and local backup locations. For example, it is possible to specify a policy for a given filesystem in the pyznap.conf file and then use cron to let it run once per quarter-hour. WWW: https://github.com/yboetz/pyznap PR: 232161 Submitted by: Dries Michiels <driesm.michiels@gmail.com> (previous version) Reviewed by: krion Approved by: krion (mentor) Differential Revision: https://reviews.freebsd.org/D17520
Notes
Notes: svn path=/head/; revision=481839
Diffstat (limited to 'sysutils/py-pyznap')
-rw-r--r--sysutils/py-pyznap/Makefile32
-rw-r--r--sysutils/py-pyznap/distinfo3
-rw-r--r--sysutils/py-pyznap/files/pkg-message.in10
-rw-r--r--sysutils/py-pyznap/pkg-descr7
4 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/py-pyznap/Makefile b/sysutils/py-pyznap/Makefile
new file mode 100644
index 000000000000..f3ec0a13b2d5
--- /dev/null
+++ b/sysutils/py-pyznap/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= pyznap
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.2
+CATEGORIES= sysutils python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= driesm.michiels@gmail.com
+COMMENT= ZFS snapshot tool written in Python
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}configparser>3.5.0:devel/py-configparser@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}paramiko>=2.4.1:security/py-paramiko@${PY_FLAVOR} \
+ mbuffer:misc/mbuffer
+
+USES= python:3.5+
+USE_PYTHON= autoplist distutils
+
+USE_GITHUB= yes
+GH_ACCOUNT= yboetz
+
+NO_ARCH= yes
+SUB_FILES= pkg-message
+SUB_LIST= BINDIR=${PREFIX}/bin
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/etc/pyznap/|${PREFIX}/etc/pyznap/|g' ${WRKSRC}/${PORTNAME}/main.py
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-pyznap/distinfo b/sysutils/py-pyznap/distinfo
new file mode 100644
index 000000000000..3ee27f0c42b3
--- /dev/null
+++ b/sysutils/py-pyznap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539192943
+SHA256 (yboetz-pyznap-v1.0.2_GH0.tar.gz) = e506a3541b3af95f06cd3920269dcad11ba5b3a231591b3a51160ac0f3022002
+SIZE (yboetz-pyznap-v1.0.2_GH0.tar.gz) = 33660
diff --git a/sysutils/py-pyznap/files/pkg-message.in b/sysutils/py-pyznap/files/pkg-message.in
new file mode 100644
index 000000000000..00d057af5651
--- /dev/null
+++ b/sysutils/py-pyznap/files/pkg-message.in
@@ -0,0 +1,10 @@
+Now it is time to set-up the main configuration file.
+
+First run "pyznap setup", a sample configuration will be copied
+to %%PREFIX%%/etc/pyznap/pysnap.conf.
+
+After configuring the file to your liking setup cron(8) with the
+following entries:
+
+*/15 * * * * root %%BINDIR%%/pyznap snap >> /var/log/pyznap.log
+0 0 * * * root %%BINDIR%%/pyznap send >> /var/log/pyznap.log
diff --git a/sysutils/py-pyznap/pkg-descr b/sysutils/py-pyznap/pkg-descr
new file mode 100644
index 000000000000..0667650874e4
--- /dev/null
+++ b/sysutils/py-pyznap/pkg-descr
@@ -0,0 +1,7 @@
+pyznap is a ZFS snapshot management tool. It automatically takes and deletes
+snapshots and can send them to different remote and local backup locations.
+
+For example, it is possible to specify a policy for a given filesystem in the
+pyznap.conf file and then use cron to let it run once per quarter-hour.
+
+WWW: https://github.com/yboetz/pyznap