aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-scandir/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-12-20 10:40:29 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-12-20 10:40:29 +0000
commitcc2444dc67fd19fdb2717bb577e1ada28b5e7d33 (patch)
treee02d7ed78926feda8dc03abefa2a95b00f9fab17 /sysutils/py-scandir/Makefile
parent657c6df3d174cfde663ff8790e538e8147836a94 (diff)
downloadports-cc2444dc67fd19fdb2717bb577e1ada28b5e7d33.tar.gz
ports-cc2444dc67fd19fdb2717bb577e1ada28b5e7d33.zip
MFH: r520359 sysutils/py-scandir: Fix unicode issues, level up ports compliance
This change fixes tests and likely runtime in certain locale environments by replace the existing test_scandir.py patch with a backported upstream patch from PR #109 [1][2], coupled with setting an appropriate locale. While I'm here: - Strip shared library and add LICENSE_FILE Tests now all pass on all Python versions (2.7-3.8) [1] https://github.com/benhoyt/scandir/pull/109 [2] https://github.com/benhoyt/scandir/issues/122 Approved by: portmgr (blanket: ports compliance, bugfix) Approved by: ports-secteam (blanket(s): ports compliance, bugfix)
Notes
Notes: svn path=/branches/2019Q4/; revision=520500
Diffstat (limited to 'sysutils/py-scandir/Makefile')
-rw-r--r--sysutils/py-scandir/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/sysutils/py-scandir/Makefile b/sysutils/py-scandir/Makefile
index f7461ab7fb56..ae8acce6ca41 100644
--- a/sysutils/py-scandir/Makefile
+++ b/sysutils/py-scandir/Makefile
@@ -4,6 +4,7 @@
PORTNAME= scandir
PORTVERSION= 1.10.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= sysutils python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,7 @@ MAINTAINER= rene@FreeBSD.org
COMMENT= Fast and featureful directory iterator
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= python
USE_PYTHON= autoplist distutils
@@ -18,7 +20,12 @@ USE_PYTHON= autoplist distutils
USE_GITHUB= yes
GH_ACCOUNT= benhoyt
+USE_LOCALE= en_US.UTF-8
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_scandir.so
+
do-test:
- ${PYTHON_CMD} ${WRKSRC}/test/run_tests.py
+ ${SETENV} ${TEST_ENV} ${PYTHON_CMD} ${WRKSRC}/test/run_tests.py
.include <bsd.port.mk>