aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-stdiff
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2010-12-11 21:09:43 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2010-12-11 21:09:43 +0000
commita8c1d5b9db3653ff67126c1ebce98f80247784ce (patch)
tree3ffbe649d9b40c1bb1a7d2efdd0ab3515ca304ce /sysutils/py-stdiff
parent64a82765d142df1511d44736825457d1c2efdf76 (diff)
Notes
Diffstat (limited to 'sysutils/py-stdiff')
-rw-r--r--sysutils/py-stdiff/Makefile33
-rw-r--r--sysutils/py-stdiff/distinfo2
-rw-r--r--sysutils/py-stdiff/files/patch-setup.py11
-rw-r--r--sysutils/py-stdiff/pkg-descr7
-rw-r--r--sysutils/py-stdiff/pkg-plist33
5 files changed, 86 insertions, 0 deletions
diff --git a/sysutils/py-stdiff/Makefile b/sysutils/py-stdiff/Makefile
new file mode 100644
index 000000000000..f26e1a2e1176
--- /dev/null
+++ b/sysutils/py-stdiff/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-stdiff
+# Date created: 11 Dec 2010
+# Whom: Marcelo Araujo <araujo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= stdiff
+PORTVERSION= 0.2.1
+CATEGORIES= sysutils python
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
+
+MAINTAINER= araujo@FreeBSD.org
+COMMENT= Spot The Difference is a file integrity checker.
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ $(INSTALL_MAN) ${WRKSRC}/INSTALL.txt ${DOCSDIR}/
+ $(INSTALL_MAN) ${WRKSRC}/LICENSE.txt ${DOCSDIR}/
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} docs ${DOCSDIR}/)
+.endif
+ @if [ ! -f ${PREFIX}/etc/stdiff.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/stdiff.conf.sample \
+ ${PREFIX}/etc/stdiff.conf; fi
+.include <bsd.port.mk>
diff --git a/sysutils/py-stdiff/distinfo b/sysutils/py-stdiff/distinfo
new file mode 100644
index 000000000000..873d9729ebe8
--- /dev/null
+++ b/sysutils/py-stdiff/distinfo
@@ -0,0 +1,2 @@
+SHA256 (stdiff-0.2.1.tar.gz) = 4c30a233395401f1f54a33eff683c8f7a5b8cbeff6ef9019db438cdffac503c0
+SIZE (stdiff-0.2.1.tar.gz) = 43603
diff --git a/sysutils/py-stdiff/files/patch-setup.py b/sysutils/py-stdiff/files/patch-setup.py
new file mode 100644
index 000000000000..bc27143b37b0
--- /dev/null
+++ b/sysutils/py-stdiff/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py 2004-11-06 11:31:49.000000000 -0200
++++ /tmp/setup.py 2010-11-07 11:45:39.000000000 -0200
+@@ -35,7 +35,7 @@
+ download_url="http://sourceforge.net/projects/stdiff/",
+ packages=["spot"],
+ scripts=["scripts/stdiff.py", "scripts/stdiff_install_db.py"],
+- data_files=[("/etc", ["stdiff.conf.sample"])],
++ data_files=[("/usr/local/etc", ["stdiff.conf.sample"])],
+ classifiers=["Development status :: 0.2.1",
+ "Environment :: Console (Text Based)",
+ "Intended Audience :: System Administrators",
diff --git a/sysutils/py-stdiff/pkg-descr b/sysutils/py-stdiff/pkg-descr
new file mode 100644
index 000000000000..5dbb8e17501c
--- /dev/null
+++ b/sysutils/py-stdiff/pkg-descr
@@ -0,0 +1,7 @@
+Spot The Difference is a file integrity checker. Its goal is to detect signs of
+intrusion by looking for suspicious changes in system files. Crackers, in fact,
+to do their evil or just to make sure they can work their way back into the
+system, often change some configuration files, executables and/or log files
+(usually with rootkits); thus leaving signs of the break-in.
+
+WWW: http://www.kernel-panic.it/software/stdiff/
diff --git a/sysutils/py-stdiff/pkg-plist b/sysutils/py-stdiff/pkg-plist
new file mode 100644
index 000000000000..88eac3bdd465
--- /dev/null
+++ b/sysutils/py-stdiff/pkg-plist
@@ -0,0 +1,33 @@
+bin/stdiff.py
+bin/stdiff_install_db.py
+%%PYTHON_SITELIBDIR%%/spot/Parser.py
+%%PYTHON_SITELIBDIR%%/spot/Parser.pyc
+%%PYTHON_SITELIBDIR%%/spot/Parser.pyo
+%%PYTHON_SITELIBDIR%%/spot/__init__.py
+%%PYTHON_SITELIBDIR%%/spot/__init__.pyc
+%%PYTHON_SITELIBDIR%%/spot/__init__.pyo
+%%PYTHON_SITELIBDIR%%/spot/install_db_mysql.py
+%%PYTHON_SITELIBDIR%%/spot/install_db_mysql.pyc
+%%PYTHON_SITELIBDIR%%/spot/install_db_mysql.pyo
+%%PYTHON_SITELIBDIR%%/spot/install_db_pgsql.py
+%%PYTHON_SITELIBDIR%%/spot/install_db_pgsql.pyc
+%%PYTHON_SITELIBDIR%%/spot/install_db_pgsql.pyo
+%%PYTHON_SITELIBDIR%%/spot/spot.py
+%%PYTHON_SITELIBDIR%%/spot/spot.pyc
+%%PYTHON_SITELIBDIR%%/spot/spot.pyo
+%%PYTHON_SITELIBDIR%%/spot/spot_dbm.py
+%%PYTHON_SITELIBDIR%%/spot/spot_dbm.pyc
+%%PYTHON_SITELIBDIR%%/spot/spot_dbm.pyo
+%%PYTHON_SITELIBDIR%%/spot/spot_mysql.py
+%%PYTHON_SITELIBDIR%%/spot/spot_mysql.pyc
+%%PYTHON_SITELIBDIR%%/spot/spot_mysql.pyo
+%%PYTHON_SITELIBDIR%%/spot/spot_pgsql.py
+%%PYTHON_SITELIBDIR%%/spot/spot_pgsql.pyc
+%%PYTHON_SITELIBDIR%%/spot/spot_pgsql.pyo
+%%PYTHON_SITELIBDIR%%/spot/spot_sqlite.py
+%%PYTHON_SITELIBDIR%%/spot/spot_sqlite.pyc
+%%PYTHON_SITELIBDIR%%/spot/spot_sqlite.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/spot
+@unexec if cmp -s %D/etc/stdiff.conf.sample %D/etc/stdiff.conf; then rm -f %D/etc/stdiff.conf ; fi
+etc/stdiff.conf.sample
+@exec if [ ! -f %D/etc/stdiff.conf ]; then cp -p %D/%F %B/stdiff.conf; fi