aboutsummaryrefslogtreecommitdiff
path: root/sysutils/qzeitgeist
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-16 23:01:09 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-16 23:01:09 +0000
commitf75527d0685740a4d964c95e491cb1739dc4c6a5 (patch)
tree9520fc9164242d241bce7407c7176f9d6bf829fc /sysutils/qzeitgeist
parentc40e8860165f9f410e4aa2e4e06657ffb971621a (diff)
downloadports-f75527d0685740a4d964c95e491cb1739dc4c6a5.tar.gz
ports-f75527d0685740a4d964c95e491cb1739dc4c6a5.zip
Notes
Diffstat (limited to 'sysutils/qzeitgeist')
-rw-r--r--sysutils/qzeitgeist/Makefile41
-rw-r--r--sysutils/qzeitgeist/distinfo2
-rw-r--r--sysutils/qzeitgeist/pkg-descr11
-rw-r--r--sysutils/qzeitgeist/pkg-message5
-rw-r--r--sysutils/qzeitgeist/pkg-plist31
5 files changed, 90 insertions, 0 deletions
diff --git a/sysutils/qzeitgeist/Makefile b/sysutils/qzeitgeist/Makefile
new file mode 100644
index 000000000000..458f2b91170a
--- /dev/null
+++ b/sysutils/qzeitgeist/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: qzeitgeist
+# Date Created: 20 April 2011
+# Whom: avilla@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= qzeitgeist
+PORTVERSION= 0.7.0
+CATEGORIES= sysutils
+MASTER_SITES= http://releases.zeitgeist-project.com/${PORTNAME}/
+DISTNAME= QtZeitgeist-${PORTVERSION}
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= Qt 4 wrapper library around the Zeitgeist DBus API
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib dbus qtestlib \
+ moc_build qmake_build rcc_build uic_build
+MAKE_JOBS_SAFE= yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}-Source
+
+post-patch:
+ ${REINPLACE_CMD} -e '/\.pc/ s|pkgconfig|../libdata/pkgconfig|' \
+ -e 's|share/${PORTNAME}/cmake|lib/cmake/${PORTNAME}|' \
+ -e "/add_subdirectory(tests)/ d" \
+ ${WRKSRC}/CMakeLists.txt \
+ ${WRKSRC}/src/CMakeLists.txt \
+ ${WRKSRC}/QZeitgeistConfig.cmake.in
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/qzeitgeist/distinfo b/sysutils/qzeitgeist/distinfo
new file mode 100644
index 000000000000..c76a46ad5386
--- /dev/null
+++ b/sysutils/qzeitgeist/distinfo
@@ -0,0 +1,2 @@
+SHA256 (QtZeitgeist-0.7.0.tar.bz2) = 12c3073196ba5ea871759e79bc0a1ecf5a3a20f1d90abd814d2555ff21175d7e
+SIZE (QtZeitgeist-0.7.0.tar.bz2) = 31260
diff --git a/sysutils/qzeitgeist/pkg-descr b/sysutils/qzeitgeist/pkg-descr
new file mode 100644
index 000000000000..1c971b8fce3a
--- /dev/null
+++ b/sysutils/qzeitgeist/pkg-descr
@@ -0,0 +1,11 @@
+Zeitgeist is a service which logs the users's activities and events
+(files opened, websites visites, conversations hold with other people,
+etc.) and makes relevant information available to other applications.
+It is able to establish relationships between items based on
+similarity and usage patterns.
+
+libQZeitgeist is a wrapper library around the Zeitgeist D-Bus API for
+Qt, and is brought to you by Collabora in cooperation with the
+Zeitgeist team and KDE.
+
+WWW: http://zeitgeist-project.com
diff --git a/sysutils/qzeitgeist/pkg-message b/sysutils/qzeitgeist/pkg-message
new file mode 100644
index 000000000000..8f852fcb5c2e
--- /dev/null
+++ b/sysutils/qzeitgeist/pkg-message
@@ -0,0 +1,5 @@
+======================================================================
+
+You'll have to install sysutils/zeitgeist to enable event logging.
+
+======================================================================
diff --git a/sysutils/qzeitgeist/pkg-plist b/sysutils/qzeitgeist/pkg-plist
new file mode 100644
index 000000000000..fadd34ff9fe3
--- /dev/null
+++ b/sysutils/qzeitgeist/pkg-plist
@@ -0,0 +1,31 @@
+include/QtZeitgeist/DataModel/DataSource
+include/QtZeitgeist/DataModel/Event
+include/QtZeitgeist/DataModel/Subject
+include/QtZeitgeist/DataModel/TimeRange
+include/QtZeitgeist/DataModel/datasource.h
+include/QtZeitgeist/DataModel/event.h
+include/QtZeitgeist/DataModel/subject.h
+include/QtZeitgeist/DataModel/timerange.h
+include/QtZeitgeist/DataSourceRegistry
+include/QtZeitgeist/Interpretation
+include/QtZeitgeist/Log
+include/QtZeitgeist/Manifestation
+include/QtZeitgeist/Monitor
+include/QtZeitgeist/QtZeitgeist
+include/QtZeitgeist/datasourceregistry.h
+include/QtZeitgeist/interpretation.h
+include/QtZeitgeist/log.h
+include/QtZeitgeist/manifestation.h
+include/QtZeitgeist/monitor.h
+include/QtZeitgeist/qtzeitgeist.h
+lib/cmake/qzeitgeist/QZeitgeistConfig.cmake
+lib/cmake/qzeitgeist/QZeitgeistExport-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/qzeitgeist/QZeitgeistExport.cmake
+lib/libqzeitgeist.so
+lib/libqzeitgeist.so.0
+lib/libqzeitgeist.so.0.7
+libdata/pkgconfig/QtZeitgeist.pc
+@dirrm lib/cmake/qzeitgeist
+@dirrmtry lib/cmake
+@dirrm include/QtZeitgeist/DataModel
+@dirrm include/QtZeitgeist