aboutsummaryrefslogtreecommitdiff
path: root/sysutils/reed
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-02-04 18:05:07 +0000
committerJohn Marino <marino@FreeBSD.org>2016-02-04 18:05:07 +0000
commit8367a132e55603ff785465f853c2c58ed0de364b (patch)
tree78d5f22da9b94e40e7d73f3d98e5e6aced428181 /sysutils/reed
parent89b1573c9f04d7739fa9648fdcc488c1d1dd379e (diff)
downloadports-8367a132e55603ff785465f853c2c58ed0de364b.tar.gz
ports-8367a132e55603ff785465f853c2c58ed0de364b.zip
sysutils/reed: document ncurses rqmt (USES+=ncurses), respect LDFLAGS
Also link with libncurses, not libcurses approved by: infrastructure blanket
Notes
Notes: svn path=/head/; revision=408064
Diffstat (limited to 'sysutils/reed')
-rw-r--r--sysutils/reed/Makefile2
-rw-r--r--sysutils/reed/files/patch-Makefile.in13
-rw-r--r--sysutils/reed/files/patch-cfg.data10
3 files changed, 24 insertions, 1 deletions
diff --git a/sysutils/reed/Makefile b/sysutils/reed/Makefile
index e9c2b9b56b6b..750c257f5e10 100644
--- a/sysutils/reed/Makefile
+++ b/sysutils/reed/Makefile
@@ -13,7 +13,7 @@ COMMENT= Text pager with autoscrolling and more
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= perl5 shebangfix
+USES= ncurses perl5 shebangfix
USE_PERL5= run build patch
SHEBANG_FILES= wrap breed
HAS_CONFIGURE= yes
diff --git a/sysutils/reed/files/patch-Makefile.in b/sysutils/reed/files/patch-Makefile.in
new file mode 100644
index 000000000000..728c1a1ead13
--- /dev/null
+++ b/sysutils/reed/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in.orig 2002-11-09 00:59:08 UTC
++++ Makefile.in
+@@ -1,8 +1,8 @@
+ all:
+- $(CC) -O2 -o reed reed.c filemode.c -lcurses
++ $(CC) -O2 -o reed reed.c filemode.c $(LDFLAGS) -lncurses
+
+ debug:
+- $(CC) -o reed reed.c filemode.c -lcurses -Wall -g
++ $(CC) -o reed reed.c filemode.c $(LDFLAGS) -lncurses -Wall -g
+
+ install:
+ install -d $(DESTDIR)PREFIX/bin
diff --git a/sysutils/reed/files/patch-cfg.data b/sysutils/reed/files/patch-cfg.data
new file mode 100644
index 000000000000..d95e81a68993
--- /dev/null
+++ b/sysutils/reed/files/patch-cfg.data
@@ -0,0 +1,10 @@
+--- cfg.data.orig 2002-11-09 00:59:08 UTC
++++ cfg.data
+@@ -1,6 +1,6 @@
+ PROGNAME="Reed"
+ VERSION="5.4"
+ PROGRAMS="perl fold"
+-LIBS="c curses"
++LIBS="c ncurses"
+ PM="Getopt/Std Text/Wrap"
+ HEADERS="sys/dir.h sys/stat.h ctype.h curses.h dirent.h getopt.h regex.h limits.h time.h unistd.h"