aboutsummaryrefslogtreecommitdiff
path: root/sysutils/reed
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2019-06-19 08:29:55 +0000
committerChris Rees <crees@FreeBSD.org>2019-06-19 08:29:55 +0000
commit9f55170f69ab938c0e1a65fdf212a7af12754567 (patch)
tree4f17a6947a0b9ebbda222a000474f6b9bebfa070 /sysutils/reed
parent7229f4082af07e53ead351492a415d80e81a02dd (diff)
downloadports-9f55170f69ab938c0e1a65fdf212a7af12754567.tar.gz
ports-9f55170f69ab938c0e1a65fdf212a7af12754567.zip
sysutils/reed: Remove sys/dir.h
It was replaced a long time ago with sys/dirent.h, which is implicitly included from dirent.h Use sed instead of perl, remove redundant seds and use a patch for the source file for clarity PR: ports/238696 Submitted by: rene
Notes
Notes: svn path=/head/; revision=504525
Diffstat (limited to 'sysutils/reed')
-rw-r--r--sysutils/reed/Makefile12
-rw-r--r--sysutils/reed/files/patch-cfg.data5
-rw-r--r--sysutils/reed/files/patch-reed.c19
3 files changed, 27 insertions, 9 deletions
diff --git a/sysutils/reed/Makefile b/sysutils/reed/Makefile
index 8faf2cf0ea38..64a4e0114518 100644
--- a/sysutils/reed/Makefile
+++ b/sysutils/reed/Makefile
@@ -14,20 +14,16 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= ncurses perl5 shebangfix
-USE_PERL5= run build patch
-SHEBANG_FILES= wrap breed
+USE_PERL5= run
+SHEBANG_FILES= wrap breed fix_bookmarks.pl
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configures
CONFIGURE_ENV+= INCDIR="${NCURSESINC}"
post-patch:
- @${PERL} -pi -e 's!/usr/local!${PREFIX}!g' ${WRKSRC}/configures
- @${PERL} -pi -e 's!sys/dir.h!dirent.h!g;s!.*getopt.h.*\n!!' \
+ @${REINPLACE_CMD} 's!/usr/local!${PREFIX}!g' ${WRKSRC}/configures
+ @${REINPLACE_CMD} 's!sys/dir.h!dirent.h!g;\!getopt.h!d' \
${WRKSRC}/reed.c
- @${PERL} -pi -e 's!getopt.h !!' ${WRKSRC}/cfg.data
- @${PERL} -pi -e 's!-O2!${CFLAGS}!' ${WRKSRC}/Makefile.in
- @${PERL} -pi -e 's!^#!/usr/bin/perl!#!${PERL}!' \
- ${WRKSRC}/fix_bookmarks.pl
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/reed ${STAGEDIR}${PREFIX}/bin
diff --git a/sysutils/reed/files/patch-cfg.data b/sysutils/reed/files/patch-cfg.data
index d95e81a68993..f46224954f91 100644
--- a/sysutils/reed/files/patch-cfg.data
+++ b/sysutils/reed/files/patch-cfg.data
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- cfg.data.orig 2002-11-09 00:59:08 UTC
+++ cfg.data
@@ -1,6 +1,6 @@
@@ -7,4 +9,5 @@
-LIBS="c curses"
+LIBS="c ncurses"
PM="Getopt/Std Text/Wrap"
- HEADERS="sys/dir.h sys/stat.h ctype.h curses.h dirent.h getopt.h regex.h limits.h time.h unistd.h"
+-HEADERS="sys/dir.h sys/stat.h ctype.h curses.h dirent.h getopt.h regex.h limits.h time.h unistd.h"
++HEADERS="sys/stat.h ctype.h ncurses.h dirent.h regex.h limits.h time.h unistd.h"
diff --git a/sysutils/reed/files/patch-reed.c b/sysutils/reed/files/patch-reed.c
new file mode 100644
index 000000000000..218a8260b859
--- /dev/null
+++ b/sysutils/reed/files/patch-reed.c
@@ -0,0 +1,19 @@
+$FreeBSD$
+
+--- reed.c.orig 2002-11-09 00:59:08 UTC
++++ reed.c
+@@ -24,13 +24,12 @@
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-#include <sys/dir.h>
++#include <dirent.h>
+
+ #include <ctype.h>
+ #include <curses.h>
+ #include <dirent.h>
+ #include <errno.h>
+-#include <getopt.h>
+ #include <grp.h>
+ #include <limits.h>
+ #include <pwd.h>