aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rfstool
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-02 13:34:33 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-02 13:34:33 +0000
commitda9462706d8c75eac21986fcfecaddb720f964b4 (patch)
tree265186e312ac0741a4a5d9c201d71059ceeebd6d /sysutils/rfstool
parentac6a3870689db56111ea01137dc845b3e53b000a (diff)
downloadports-da9462706d8c75eac21986fcfecaddb720f964b4.tar.gz
ports-da9462706d8c75eac21986fcfecaddb720f964b4.zip
Notes
Diffstat (limited to 'sysutils/rfstool')
-rw-r--r--sysutils/rfstool/Makefile3
-rw-r--r--sysutils/rfstool/files/patch-reiserfs.h11
2 files changed, 14 insertions, 0 deletions
diff --git a/sysutils/rfstool/Makefile b/sysutils/rfstool/Makefile
index 3f50e1fcc788..303f9ab55603 100644
--- a/sysutils/rfstool/Makefile
+++ b/sysutils/rfstool/Makefile
@@ -25,6 +25,9 @@ MAKEFILE= makefile.gcc3x
MAKEFILE= makefile.gcc2x
.endif
+post-extract:
+ @${REINPLACE_CMD} -e "s,g++,\$${CXX},g" ${WRKSRC}/${MAKEFILE}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rfstool ${PREFIX}/bin
diff --git a/sysutils/rfstool/files/patch-reiserfs.h b/sysutils/rfstool/files/patch-reiserfs.h
new file mode 100644
index 000000000000..21e8ea1b6eae
--- /dev/null
+++ b/sysutils/rfstool/files/patch-reiserfs.h
@@ -0,0 +1,11 @@
+--- reiserfs.h.orig Mon Oct 2 13:58:35 2006
++++ reiserfs.h Mon Oct 2 13:58:39 2006
+@@ -268,7 +268,7 @@
+ {
+ }
+
+- ReiserFsBlock::~ReiserFsBlock()
++ ~ReiserFsBlock()
+ {
+ delete m_lpbMemory;
+ }