aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rsyslog3/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2008-05-06 15:25:01 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2008-05-06 15:25:01 +0000
commitb9b5b02aa2c03f12eb89312c77348f36b7438de0 (patch)
treefcbb816b389765d872f2b8c0d000117f9da1f0ae /sysutils/rsyslog3/Makefile
parent54a99f327266949db27fe01f75892a5668bb03f2 (diff)
Add rsyslog 3.x to ports:
Rsyslog is an enhanced multi-threaded syslogd supporting, among others, syslog/tcp, permitted sender lists, filtering on any message part, and fine grain output format control. Its advanced features make it suitable for enterprise-class, encryption protected syslog relay chains while at the same time being very easy to setup for the novice user. The following features are supported through modules: logging to MySQL, PostgreSQL, any libdbi-supported backend; SNMP trap sender, GSS API, RELP. WWW: http://www.rsyslog.com/
Notes
Notes: svn path=/head/; revision=212741
Diffstat (limited to 'sysutils/rsyslog3/Makefile')
-rw-r--r--sysutils/rsyslog3/Makefile38
1 files changed, 7 insertions, 31 deletions
diff --git a/sysutils/rsyslog3/Makefile b/sysutils/rsyslog3/Makefile
index 2529906dfeed..c2fa4b40a45f 100644
--- a/sysutils/rsyslog3/Makefile
+++ b/sysutils/rsyslog3/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: rsyslog
+# New ports collection makefile for: rsyslog3
# Date created: 9 July 2007
# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
#
@@ -6,55 +6,31 @@
#
PORTNAME= rsyslog
-PORTVERSION= 2.0.4
-PORTREVISION= 1
-CATEGORIES= sysutils
-MASTER_SITES= CENKES http://download.rsyslog.com/rsyslog/
-MAINTAINER= infofarmer@FreeBSD.org
-COMMENT?= Enhanced syslog daemon
+COMMENT= Enhanced syslog daemon
-LIB_DEPENDS= logging.0:${PORTSDIR}/devel/liblogging
-.ifndef PKGNAMESUFFIX
USE_RC_SUBR= ${PORTNAME}d
SUB_FILES= pkg-message
-MAN8= rfc3195d.8 rklogd.8 rsyslogd.8
+MAN8= rsyslogd.8
MAN5= rsyslog.conf.5
-.endif
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--disable-klogd --disable-static
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-PORT_VERBS= rfc3195d rklogd ${PORTNAME}
+CONFIGURE_ARGS+=--enable-klog --disable-static --enable-mail \
+ --enable-imfile --enable-imtemplate --enable-openssl \
post-patch:
- @${REINPLACE_CMD} -e 's|<wait.h>|<sys/wait.h>|' ${WRKSRC}/srUtils.c
- @${REINPLACE_CMD} -e '/^rfc3195d_LDADD =/s|$$| -llogging|;s|-ldl||'\
- ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/lib/rsyslog/|${PREFIX}/lib/rsyslog/|'\
- ${WRKSRC}/Makefile.in ${WRKSRC}/syslogd.c
- @${REINPLACE_CMD} -e 's|rs_strerror_r|strerror_r|g' ${WRKSRC}/rfc3195d.c
+ ${WRKSRC}/syslogd.c
@${GREP} -rl '/etc/rsyslog.conf' ${WRKSRC}|${XARGS} ${REINPLACE_CMD} -e\
's|/etc/rsyslog.conf|${PREFIX}/etc/rsyslog.conf|'
- @${ECHO_CMD} '#include <sys/socket.h>' >> ${WRKSRC}/net.h
- @${ECHO_CMD} '#include <paths.h>' >> ${WRKSRC}/omusrmsg.h
@${FIND} ${WRKSRC} -name '*.bak' -delete
-post-configure:
- @${ECHO_CMD} '#define FEATURE_RFC3195 1' >> ${WRKSRC}/config.h
- @${ECHO_CMD} '#define PATCHLEVEL "0"' >> ${WRKSRC}/config.h
-
-.ifndef PKGNAMESUFFIX
post-install:
.ifndef NOPORTDOCS
@${INSTALL} -d ${DOCSDIR}/
@${INSTALL_DATA} ${WRKSRC}/doc/*html ${DOCSDIR}/
.endif
@${CAT} ${PKGMESSAGE}
-.endif
+.include "${.CURDIR}/bsd.rsyslog.mk"
.include <bsd.port.mk>