aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rsyslog5-relp
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-27 19:50:24 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-27 19:50:24 +0000
commit45e55c9ffbfe1cf68ca4c1ce7210fc2a8b2e8d69 (patch)
tree8b3740084d63854020aeb3236c9803d715dd1be0 /sysutils/rsyslog5-relp
parent1585fdcd8b00783fd02d14fbcbf9b7c195844272 (diff)
downloadports-45e55c9ffbfe1cf68ca4c1ce7210fc2a8b2e8d69.tar.gz
ports-45e55c9ffbfe1cf68ca4c1ce7210fc2a8b2e8d69.zip
Notes
Diffstat (limited to 'sysutils/rsyslog5-relp')
-rw-r--r--sysutils/rsyslog5-relp/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/rsyslog5-relp/Makefile b/sysutils/rsyslog5-relp/Makefile
new file mode 100644
index 000000000000..c1d976478c78
--- /dev/null
+++ b/sysutils/rsyslog5-relp/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: rsyslog4-relp
+# Date created: 29 December 2008
+# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
+#
+# $FreeBSD$
+#
+
+COMMENT= RELP input/output module for rsyslog
+
+MNAME= relp
+BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
+LIB_DEPENDS= relp.0:${PORTSDIR}/devel/librelp
+
+.include "${.CURDIR}/../rsyslog4/bsd.rsyslog.mk"
+
+CONFIGURE_ARGS+=--enable-relp
+
+PLIST_FILES+= lib/rsyslog/imrelp.la \
+ lib/rsyslog/imrelp.so \
+ lib/rsyslog/omrelp.la \
+ lib/rsyslog/omrelp.so
+
+do-install:
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/omrelp/.libs/omrelp.so ${PREFIX}/lib/rsyslog
+ @${INSTALL_DATA} \
+ ${WRKSRC}/plugins/omrelp/omrelp.la ${PREFIX}/lib/rsyslog
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/imrelp/.libs/imrelp.so ${PREFIX}/lib/rsyslog
+ @${INSTALL_DATA} \
+ ${WRKSRC}/plugins/imrelp/imrelp.la ${PREFIX}/lib/rsyslog
+.include <bsd.port.mk>