aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rsyslog7-devel
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-20 15:59:09 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-20 15:59:09 +0000
commit6abb9fe776dbe77b80511774218b4e16b881a462 (patch)
tree52b72ca96a53defb14dfe7b76ef88c5de9915ddd /sysutils/rsyslog7-devel
parent162780ab6284bfd7d9b9864efccce0fd25d125af (diff)
Notes
Diffstat (limited to 'sysutils/rsyslog7-devel')
-rw-r--r--sysutils/rsyslog7-devel/Makefile2
-rw-r--r--sysutils/rsyslog7-devel/files/patch-runtime__lookup.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/sysutils/rsyslog7-devel/Makefile b/sysutils/rsyslog7-devel/Makefile
index 3beecf84fe69..7dc19909f99d 100644
--- a/sysutils/rsyslog7-devel/Makefile
+++ b/sysutils/rsyslog7-devel/Makefile
@@ -13,7 +13,7 @@ BUILD_DEPENDS= libgcrypt-config:${PORTSDIR}/security/libgcrypt
LIB_DEPENDS= libee.so:${PORTSDIR}/devel/libee \
libestr.so:${PORTSDIR}/devel/libestr \
- libjson.so:${PORTSDIR}/devel/json-c \
+ libjson-c.so:${PORTSDIR}/devel/json-c \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid
USE_LDCONFIG= yes
diff --git a/sysutils/rsyslog7-devel/files/patch-runtime__lookup.c b/sysutils/rsyslog7-devel/files/patch-runtime__lookup.c
new file mode 100644
index 000000000000..530996d60b0a
--- /dev/null
+++ b/sysutils/rsyslog7-devel/files/patch-runtime__lookup.c
@@ -0,0 +1,13 @@
+--- ./runtime/lookup.c.orig 2014-08-20 11:50:14.000000000 -0400
++++ ./runtime/lookup.c 2014-08-20 11:52:52.000000000 -0400
+@@ -26,8 +26,8 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+-#include <json/json.h>
+-#include <json/json.h>
++#include <json-c/json.h>
++#include <json-c/json.h>
+ #include <assert.h>
+
+ #include "rsyslog.h"