aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rsyslog8
diff options
context:
space:
mode:
authorBrad Davis <brd@FreeBSD.org>2015-01-14 03:06:48 +0000
committerBrad Davis <brd@FreeBSD.org>2015-01-14 03:06:48 +0000
commit8eda03674b6155ea912d14c0a74d39f9ebbb4ba2 (patch)
tree232f0f6ef74fa1657c446842b46bf109fa206014 /sysutils/rsyslog8
parent4342e6637eaff813f48417b547199d68ac923b42 (diff)
downloadports-8eda03674b6155ea912d14c0a74d39f9ebbb4ba2.tar.gz
ports-8eda03674b6155ea912d14c0a74d39f9ebbb4ba2.zip
Notes
Diffstat (limited to 'sysutils/rsyslog8')
-rw-r--r--sysutils/rsyslog8/Makefile3
-rw-r--r--sysutils/rsyslog8/distinfo4
-rw-r--r--sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c38
-rw-r--r--sysutils/rsyslog8/files/patch-tools_rsyslogd.c10
4 files changed, 41 insertions, 14 deletions
diff --git a/sysutils/rsyslog8/Makefile b/sysutils/rsyslog8/Makefile
index 1d8460fc4372..c2868cb43858 100644
--- a/sysutils/rsyslog8/Makefile
+++ b/sysutils/rsyslog8/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= rsyslog
-PORTVERSION= 8.6.0
-PORTREVISION= 1
+PORTVERSION= 8.7.0
CATEGORIES= sysutils
MASTER_SITES= http://www.rsyslog.com/files/download/rsyslog/
diff --git a/sysutils/rsyslog8/distinfo b/sysutils/rsyslog8/distinfo
index 5f371007a039..863b6ae09a76 100644
--- a/sysutils/rsyslog8/distinfo
+++ b/sysutils/rsyslog8/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rsyslog-8.6.0.tar.gz) = 759f836be460c794a7649f2b5b5ef8d423388ec599bf3b49f51fded3f8c02431
-SIZE (rsyslog-8.6.0.tar.gz) = 1975854
+SHA256 (rsyslog-8.7.0.tar.gz) = c77125b67a623569c9bdca8136b9aac013f1c6fd82fb8595e3ea267e61800f9c
+SIZE (rsyslog-8.7.0.tar.gz) = 2003365
diff --git a/sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c b/sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c
new file mode 100644
index 000000000000..36ca7b7317c6
--- /dev/null
+++ b/sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c
@@ -0,0 +1,38 @@
+--- runtime/nsd_ptcp.c.orig 2015-01-13 22:06:22 UTC
++++ runtime/nsd_ptcp.c
+@@ -656,7 +656,11 @@ EnableKeepAlive(nsd_t *pNsd)
+ if(pThis->iKeepAliveProbes > 0) {
+ optval = pThis->iKeepAliveProbes;
+ optlen = sizeof(optval);
++#if defined(SOL_TCP)
+ ret = setsockopt(pThis->sock, SOL_TCP, TCP_KEEPCNT, &optval, optlen);
++#else
++ ret = setsockopt(pThis->sock, SOL_SOCKET, TCP_KEEPCNT, &optval, optlen);
++#endif
+ } else {
+ ret = 0;
+ }
+@@ -671,7 +675,11 @@ EnableKeepAlive(nsd_t *pNsd)
+ if(pThis->iKeepAliveTime > 0) {
+ optval = pThis->iKeepAliveTime;
+ optlen = sizeof(optval);
++#if defined(SOL_TCP)
+ ret = setsockopt(pThis->sock, SOL_TCP, TCP_KEEPIDLE, &optval, optlen);
++#else
++ ret = setsockopt(pThis->sock, SOL_SOCKET, TCP_KEEPIDLE, &optval, optlen);
++#endif
+ } else {
+ ret = 0;
+ }
+@@ -686,7 +694,11 @@ EnableKeepAlive(nsd_t *pNsd)
+ if(pThis->iKeepAliveIntvl > 0) {
+ optval = pThis->iKeepAliveIntvl;
+ optlen = sizeof(optval);
++#if defined(SOL_TCP)
+ ret = setsockopt(pThis->sock, SOL_TCP, TCP_KEEPINTVL, &optval, optlen);
++#else
++ ret = setsockopt(pThis->sock, SOL_SOCKET, TCP_KEEPINTVL, &optval, optlen);
++#endif
+ } else {
+ ret = 0;
+ }
diff --git a/sysutils/rsyslog8/files/patch-tools_rsyslogd.c b/sysutils/rsyslog8/files/patch-tools_rsyslogd.c
deleted file mode 100644
index 75439dc6ce31..000000000000
--- a/sysutils/rsyslog8/files/patch-tools_rsyslogd.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- tools/rsyslogd.c.orig 2014-12-10 15:46:03 UTC
-+++ tools/rsyslogd.c
-@@ -32,6 +32,7 @@
- #else
- # include <sys/errno.h>
- #endif
-+#include <unistd.h>
- #include "sd-daemon.h"
-
- #include "wti.h"