aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ruby-log4r/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-12 18:20:18 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-12 18:20:18 +0000
commit503d35e63793f0e966663161872a0ed3f667e086 (patch)
tree882fe23a308562da72bc6ecfe3d01748b1468e68 /sysutils/ruby-log4r/Makefile
parent93a737418229d9f7d957035d05a5da86a015e7a9 (diff)
downloadports-503d35e63793f0e966663161872a0ed3f667e086.tar.gz
ports-503d35e63793f0e966663161872a0ed3f667e086.zip
Notes
Diffstat (limited to 'sysutils/ruby-log4r/Makefile')
-rw-r--r--sysutils/ruby-log4r/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/ruby-log4r/Makefile b/sysutils/ruby-log4r/Makefile
new file mode 100644
index 000000000000..d136032b5fa0
--- /dev/null
+++ b/sysutils/ruby-log4r/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Log4r
+# Date created: 13 January 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= log4r
+PORTVERSION= 0.9.7
+CATEGORIES= sysutils ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+EXAMPLES= examples/*
+DOCS= README changelog doc/*
+
+do-install:
+ cd ${WRKSRC}; ${RUBY} ./install.rb
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES}
+ ${CP} -R ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${CP} -R ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>