aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rubygem-hammer_cli_foreman_salt
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2015-03-09 14:51:55 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2015-03-09 14:51:55 +0000
commit5b0c3e7959d898ebf42eb8b946079f37a17180b5 (patch)
tree1d97514b1bf25a9ffc4c638ef4b54eb58cc7ddc0 /sysutils/rubygem-hammer_cli_foreman_salt
parentb4e48856dbc3eee33af2e26f1be806bc8ccbbe8c (diff)
Notes
Diffstat (limited to 'sysutils/rubygem-hammer_cli_foreman_salt')
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_salt/Makefile27
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_salt/distinfo2
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_salt/pkg-descr4
3 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/rubygem-hammer_cli_foreman_salt/Makefile b/sysutils/rubygem-hammer_cli_foreman_salt/Makefile
new file mode 100644
index 000000000000..832ed4a79784
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_salt/Makefile
@@ -0,0 +1,27 @@
+# Created by: Michael Moll <kvedulv@kvedulv.de>
+# $FreeBSD$
+
+PORTNAME= hammer_cli_foreman_salt
+PORTVERSION= 0.0.4
+CATEGORIES= sysutils ruby
+MASTER_SITES= RG
+
+MAINTAINER= kvedulv@kvedulv.de
+COMMENT= SaltStack integration commands for Hammer CLI
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= rubygem-hammer_cli_foreman>=0.1.2:${PORTSDIR}/sysutils/rubygem-hammer_cli_foreman
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= "@sample etc/hammer/cli.modules.d/foreman_salt.yml.sample"
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/hammer
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/hammer/cli.modules.d
+ ${INSTALL_DATA} ${WRKSRC}/config/foreman_salt.yml \
+ ${STAGEDIR}${PREFIX}/etc/hammer/cli.modules.d/foreman_salt.yml.sample
+
+.include <bsd.port.mk>
diff --git a/sysutils/rubygem-hammer_cli_foreman_salt/distinfo b/sysutils/rubygem-hammer_cli_foreman_salt/distinfo
new file mode 100644
index 000000000000..220d66ba8a85
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_salt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/hammer_cli_foreman_salt-0.0.4.gem) = 22aa5efe026222efd0241b7d428bb511e7f032c7e0b7e0f775330e6f34e55571
+SIZE (rubygem/hammer_cli_foreman_salt-0.0.4.gem) = 5632
diff --git a/sysutils/rubygem-hammer_cli_foreman_salt/pkg-descr b/sysutils/rubygem-hammer_cli_foreman_salt/pkg-descr
new file mode 100644
index 000000000000..3c73d9efdb89
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_salt/pkg-descr
@@ -0,0 +1,4 @@
+This Hammer CLI plugin contains a set of commands for foreman_salt,
+a plugin to Foreman for SaltStack integration.
+
+WWW: https://github.com/theforeman/hammer_cli_foreman_salt