aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rubygem-ohai
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-24 11:55:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-24 11:55:45 +0000
commitca11f7bb6eca59a151bb4cd646d5464e25791123 (patch)
tree1e3a2f07c2c98b10db9707461998052da5254cb4 /sysutils/rubygem-ohai
parentde3cf2d25db42736304ac974ec62cd9444ba5d0d (diff)
downloadports-ca11f7bb6eca59a151bb4cd646d5464e25791123.tar.gz
ports-ca11f7bb6eca59a151bb4cd646d5464e25791123.zip
Notes
Diffstat (limited to 'sysutils/rubygem-ohai')
-rw-r--r--sysutils/rubygem-ohai/Makefile33
-rw-r--r--sysutils/rubygem-ohai/distinfo3
-rw-r--r--sysutils/rubygem-ohai/pkg-descr7
3 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/rubygem-ohai/Makefile b/sysutils/rubygem-ohai/Makefile
new file mode 100644
index 000000000000..b9a347afb865
--- /dev/null
+++ b/sysutils/rubygem-ohai/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: rubygem-ohai
+# Date created: 18 Mar 2010
+# Whom: Renaud Chaput <renchap@cocoa-x.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ohai
+PORTVERSION= 0.5.0
+CATEGORIES= sysutils
+MASTER_SITES= http://gemcutter.org/gems/
+
+MAINTAINER= renchap@cocoa-x.com
+COMMENT= Ohai profiles your system and emits JSON
+
+BUILD_DEPENDS= rubygem-mixlib-log>=1.1.0:${PORTSDIR}/devel/rubygem-mixlib-log \
+ rubygem-mixlib-config>=1.1.0:${PORTSDIR}/devel/rubygem-mixlib-config \
+ rubygem-mixlib-cli>=1.1.0:${PORTSDIR}/devel/rubygem-mixlib-cli \
+ rubygem-systemu>=1.2.0:${PORTSDIR}/devel/rubygem-systemu \
+ rubygem-extlib>=0.9.14:${PORTSDIR}/devel/rubygem-extlib \
+ rubygem-json>=1.1.9:${PORTSDIR}/devel/rubygem-json
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+PLIST_FILES= bin/ohai
+
+# we care about not passing -A to allow HTTP redirects
+FETCH_ARGS= -pRr
+
+.include <bsd.port.mk>
diff --git a/sysutils/rubygem-ohai/distinfo b/sysutils/rubygem-ohai/distinfo
new file mode 100644
index 000000000000..75b1828ed0e5
--- /dev/null
+++ b/sysutils/rubygem-ohai/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/ohai-0.5.0.gem) = c732696877356d9fef48ac07d18dc7e5
+SHA256 (rubygem/ohai-0.5.0.gem) = 914bd9a485b10faf1ff85f53fcb8acbea8e922af693b4f1a495dfb5092d11688
+SIZE (rubygem/ohai-0.5.0.gem) = 56320
diff --git a/sysutils/rubygem-ohai/pkg-descr b/sysutils/rubygem-ohai/pkg-descr
new file mode 100644
index 000000000000..c45289a842d8
--- /dev/null
+++ b/sysutils/rubygem-ohai/pkg-descr
@@ -0,0 +1,7 @@
+Ohai detects data about your operating system. It can be used standalone, but
+it's primary purpose is to provide node data to Chef.
+
+Ohai will print out a JSON data blob for all the known data about your system.
+When used with Chef, that data is reported back via node attributes.
+
+WWW: http://wiki.opscode.com/display/ohai/Home