aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rubygem-win32-file-stat
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2018-05-01 15:37:55 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2018-05-01 15:37:55 +0000
commit7d56f5626518fa51b233fe39cb389e0563e0f1db (patch)
tree6339a63f2806c278fe84e75c21c5cb297636703f /sysutils/rubygem-win32-file-stat
parent54a6f60be7170291e7f89fc67bdfe028ee9fd966 (diff)
downloadports-7d56f5626518fa51b233fe39cb389e0563e0f1db.tar.gz
ports-7d56f5626518fa51b233fe39cb389e0563e0f1db.zip
Notes
Diffstat (limited to 'sysutils/rubygem-win32-file-stat')
-rw-r--r--sysutils/rubygem-win32-file-stat/Makefile20
-rw-r--r--sysutils/rubygem-win32-file-stat/distinfo3
-rw-r--r--sysutils/rubygem-win32-file-stat/pkg-descr7
3 files changed, 30 insertions, 0 deletions
diff --git a/sysutils/rubygem-win32-file-stat/Makefile b/sysutils/rubygem-win32-file-stat/Makefile
new file mode 100644
index 000000000000..5e52835764cd
--- /dev/null
+++ b/sysutils/rubygem-win32-file-stat/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= win32-file-stat
+PORTVERSION= 1.5.5
+CATEGORIES= sysutils rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= A File::Stat class tailored to MS Windows
+
+LICENSE= ART20
+
+RUN_DEPENDS= rubygem-ffi>0:devel/rubygem-ffi \
+ rubygem-ffi-win32-extensions>0:devel/rubygem-ffi-win32-extensions
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/sysutils/rubygem-win32-file-stat/distinfo b/sysutils/rubygem-win32-file-stat/distinfo
new file mode 100644
index 000000000000..a4cd43a120d2
--- /dev/null
+++ b/sysutils/rubygem-win32-file-stat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1525180872
+SHA256 (rubygem/win32-file-stat-1.5.5.gem) = c890b9eda616c4465da13d0ebd9bef11988946b22ae224f752bda3c5a4f28351
+SIZE (rubygem/win32-file-stat-1.5.5.gem) = 27136
diff --git a/sysutils/rubygem-win32-file-stat/pkg-descr b/sysutils/rubygem-win32-file-stat/pkg-descr
new file mode 100644
index 000000000000..f380222c66b7
--- /dev/null
+++ b/sysutils/rubygem-win32-file-stat/pkg-descr
@@ -0,0 +1,7 @@
+The win32-file-stat library provides a custom File::Stat class
+specifically tailored for MS Windows. Examples include the ability
+to retrieve file attributes (hidden, archive, etc) as well as the
+redefinition of certain core methods that aren't implemented at all,
+such as File.blksize.
+
+WWW: https://github.com/chef/win32-file-stat/