aboutsummaryrefslogtreecommitdiff
path: root/sysutils/samesame/Makefile
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-04-30 15:31:00 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-04-30 15:31:00 +0000
commit48098be05a6b301ec11d1633ae8a23045c9f1565 (patch)
tree8dd33e2ffd1bcc24e013859db76aec3c9024b94f /sysutils/samesame/Makefile
parent36c416aea22b7fdd187c83b1fa28d76d67b6b45f (diff)
downloadports-48098be05a6b301ec11d1633ae8a23045c9f1565.tar.gz
ports-48098be05a6b301ec11d1633ae8a23045c9f1565.zip
Notes
Diffstat (limited to 'sysutils/samesame/Makefile')
-rw-r--r--sysutils/samesame/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/samesame/Makefile b/sysutils/samesame/Makefile
new file mode 100644
index 000000000000..8643c53f5c40
--- /dev/null
+++ b/sysutils/samesame/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: samesame
+# Date created: 14 April 2009
+# Whom: Alex de Kruijff
+#
+# $FreeBSD$
+
+PORTNAME= samesame
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.akruijff.dds.nl/samesame/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= dhn
+
+MAINTAINER= freebsd@akruijff.dds.nl
+COMMENT= Find files with identical contents and replaces them with links
+
+CONFLICTS= samefile-[0-9]*
+
+MAN1= samearchive.1 samearchive-lite.1 samefile.1 samelink.1
+MANCOMPRESSED= yes
+PLIST_FILES= bin/samearchive \
+ bin/samearchive-lite \
+ bin/samefile \
+ bin/samelink
+
+USE_BZIP2= yes
+
+OPTIONS= DEBUG "Enables debugging support" Off \
+ DISK_STORAGE "Allow temporarily storage paths on disk" On \
+ LOGIC "Determine results by using logic when posible" On
+
+.if defined(WITH_DEBUG)
+CFLAGS+= -DDEBUG
+.endif
+
+.if defined(WITH_DISK_STORAGE)
+CFLAGS+= -DWITH_DISK_STORAGE
+.endif
+
+.if defined(WITH_LOGIC)
+CFLAGS+= -DWITH_LOGIC
+.endif
+
+CFLAGS+= -DWITH_MMAP
+CFLAGS+= -D'TEMP_STORAGE_DIR=\"/tmp\"'
+CFLAGS+= -DPATH_INIT=256
+CFLAGS+= -DSTATIC_CACHE_CAPACITY=8192
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/bin/samefile
+ ${STRIP_CMD} ${PREFIX}/bin/samelink
+ ${STRIP_CMD} ${PREFIX}/bin/samearchive
+ ${STRIP_CMD} ${PREFIX}/bin/samearchive-lite
+
+.include <bsd.port.mk>