aboutsummaryrefslogtreecommitdiff
path: root/sysutils/samesame/Makefile
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-07-07 22:08:29 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-07-07 22:08:29 +0000
commit95b65fc48ac1d1d3554ca3c595653b328ef70232 (patch)
tree6da54805f1944ecae22817cf91f27c02f9c8f6f2 /sysutils/samesame/Makefile
parent2a2f4f0d33cc6992caa6cadfd336e7bea3f19063 (diff)
downloadports-95b65fc48ac1d1d3554ca3c595653b328ef70232.tar.gz
ports-95b65fc48ac1d1d3554ca3c595653b328ef70232.zip
Notes
Diffstat (limited to 'sysutils/samesame/Makefile')
-rw-r--r--sysutils/samesame/Makefile37
1 files changed, 17 insertions, 20 deletions
diff --git a/sysutils/samesame/Makefile b/sysutils/samesame/Makefile
index 805eb62003f1..3008623b99f6 100644
--- a/sysutils/samesame/Makefile
+++ b/sysutils/samesame/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= samesame
-PORTVERSION= 1.2
-PORTREVISION= 1
+PORTVERSION= 1.3
CATEGORIES= sysutils
MASTER_SITES= http://samesame.kruijff.org/ \
${MASTER_SITE_LOCAL}
@@ -18,55 +17,53 @@ COMMENT= Find identical files and optionally link them together
CONFLICTS= samefile-[0-9]*
MAN1= samearchive.1 samearchive-lite.1 samefile.1 samelink.1
-MANCOMPRESSED= yes
+MANCOMPRESSED= no
+
PLIST_FILES= bin/samearchive bin/samefile \
bin/samearchive-lite bin/samelink \
etc/rc.d/samesame.sh
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir="${MANPREFIX}/man" --prefix="${PREFIX}" \
+ --includedir="${LOCALBASE}/include" --libdir="${LOCALBASE}/lib"
USE_BZIP2= yes
OPTIONS= DEBUG "Enables debugging support" Off \
- DISK_STORAGE "Allow temporarily storage paths on disk" On \
+ DISK_STORAGE "Allows temporarily storage paths on disk" On \
LOGIC "Determine results by using logic when posible" On \
TEST "Run quality assurance test" Off
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
-CFLAGS+= -DDEBUG
+CONFIGURE_ARGS+= --enable-debug
.endif
.if defined(WITH_DISK_STORAGE)
-CFLAGS+= -DWITH_DISK_STORAGE
+CONFIGURE_ARGS+= --enable-disk-storage
.endif
.if defined(WITHOUT_LOGIC)
-CFLAGS+= -DWITHOUT_LOGIC
+CONFIGURE_ARGS+= --disable-logic
.endif
-CFLAGS+= -DWITH_MMAP
-CFLAGS+= -D'TEMP_STORAGE_DIR=\"/tmp\"'
-CFLAGS+= -DPATH_INIT=256
-CFLAGS+= -DSTATIC_CACHE_CAPACITY=8192
-
-post-patch:
- @${REINPLACE_CMD} -e 's|@||g' ${WRKSRC}/Makefile
-
-post-build:
-.if defined(WITH_TEST)
- cd ${WRKSRC}; ${MAKE} test
-.endif
+test: build
+ @cd ${WRKSRC}; ${MAKE} check
pre-install:
.if defined(WITH_TEST)
- cd ${WRKSRC}; ${MAKE} test
+ @cd ${WRKSRC}; ${MAKE} check
.endif
post-install:
+.if defined(WITHOUT_DEBUG)
${STRIP_CMD} ${PREFIX}/bin/samefile
${STRIP_CMD} ${PREFIX}/bin/samelink
${STRIP_CMD} ${PREFIX}/bin/samearchive
${STRIP_CMD} ${PREFIX}/bin/samearchive-lite
+.endif
+
${INSTALL_SCRIPT} ${FILESDIR}/samesame.sh ${PREFIX}/etc/rc.d/
+ @${CAT} pkg-message
.include <bsd.port.post.mk>