aboutsummaryrefslogtreecommitdiff
path: root/sysutils/screen
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2014-11-26 01:37:15 +0000
committerCy Schubert <cy@FreeBSD.org>2014-11-26 01:37:15 +0000
commit35d023ef001d0ceb7f8bad68d762b721562319c7 (patch)
treec62fc3dd51193a72d24defbd015ec25301c339fc /sysutils/screen
parentec988c7cc13ba22e323bbe6c8b72680a985d1a61 (diff)
downloadports-35d023ef001d0ceb7f8bad68d762b721562319c7.tar.gz
ports-35d023ef001d0ceb7f8bad68d762b721562319c7.zip
Notes
Diffstat (limited to 'sysutils/screen')
-rw-r--r--sysutils/screen/Makefile16
-rw-r--r--sysutils/screen/files/screenrc.sample11
-rw-r--r--sysutils/screen/pkg-plist7
3 files changed, 27 insertions, 7 deletions
diff --git a/sysutils/screen/Makefile b/sysutils/screen/Makefile
index 08668116fc2f..d5640177ca65 100644
--- a/sysutils/screen/Makefile
+++ b/sysutils/screen/Makefile
@@ -20,8 +20,8 @@ COMMENT= Multi-screen window manager
LICENSE= GPLv3
-OPTIONS_DEFINE= INFO MAN NETHACK XTERM_256 SHOWENC
-OPTIONS_DEFAULT= INFO MAN NETHACK XTERM_256 SOCKETS
+OPTIONS_DEFINE= INFO MAN NETHACK XTERM_256 SHOWENC SYSTEM_SCREENRC
+OPTIONS_DEFAULT= INFO MAN NETHACK XTERM_256 SOCKETS SYSTEM_SCREENRC
OPTIONS_SINGLE= IPC
OPTIONS_SINGLE_IPC= SOCKETS NAMED_PIPES
INFO_DESC= Build and install info documentation
@@ -31,6 +31,7 @@ XTERM_256_DESC= Enable support for 256 colour xterm
SHOWENC_DESC= Show encoding on the status line
SOCKETS_DESC= Use new (4.2.1+) sockets for IPC (default)
NAMED_PIPES_DESC= Use legacy (4.0.3) named pipes for IPC (override)
+SYSTEM_SCREENRC_DESC= Install system screenrc with helpful status line
OPTIONS_SUB=
@@ -85,9 +86,16 @@ post-configure:
@${ECHO_CMD} User selected named pipes override set.
.endif
+ETCDIR?= ${PREFIX}/etc
+
post-install:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+.if ${PORT_OPTIONS:MSYSTEM_SCREENRC}
+ ${INSTALL_DATA} ${FILESDIR}/screenrc.sample \
+ ${STAGEDIR}${ETCDIR}/screenrc.sample
+.else
${INSTALL_DATA} ${WRKSRC}/etc/etcscreenrc \
- ${STAGEDIR}${EXAMPLESDIR}/screenrc
+ ${STAGEDIR}${ETCDIR}/screenrc.sample
+.endif
.include <bsd.port.mk>
diff --git a/sysutils/screen/files/screenrc.sample b/sysutils/screen/files/screenrc.sample
new file mode 100644
index 000000000000..102369f0ec04
--- /dev/null
+++ b/sysutils/screen/files/screenrc.sample
@@ -0,0 +1,11 @@
+startup_message off
+defscrollback 5000
+termcapinfo xterm ti@:te@
+termcapinfo xterm-color ti@:te@
+hardstatus alwayslastline
+hardstatus string '%{gk}[%{G}%H%{g}][%= %{wk}%?%-Lw%?%{=b kR}(%{W}%n*%f %t%?(%u)%?%{=b kR})%{= kw}%?%+Lw%?%?%= %{g}]%{=b C}[%m/%d/%y %C %A]%{W}'
+vbell off
+shell -$SHELL
+logtstamp on
+logtstamp after 1
+logfile flush
diff --git a/sysutils/screen/pkg-plist b/sysutils/screen/pkg-plist
index 4a17ddf537d8..d6b6914c5355 100644
--- a/sysutils/screen/pkg-plist
+++ b/sysutils/screen/pkg-plist
@@ -1,8 +1,5 @@
bin/screen
%%MAN%%man/man1/screen.1.gz
-@unexec if cmp -s %D/etc/screenrc %D/%%EXAMPLESDIR%%/screenrc; then rm -f %D/etc/screenrc; else echo If permanently deleting this package, %%PREFIX%%/etc/screenrc must be removed manually; fi
-%%EXAMPLESDIR%%/screenrc
-@exec [ -f %D/etc/screenrc ] || cp %B/%f %D/etc/screenrc
%%DATADIR%%/utf8encodings/01
%%DATADIR%%/utf8encodings/02
%%DATADIR%%/utf8encodings/03
@@ -20,3 +17,7 @@ bin/screen
%%DATADIR%%/utf8encodings/cc
%%DATADIR%%/utf8encodings/cd
%%DATADIR%%/utf8encodings/d6
+@comment We always install the same screenrc it just depends on if we
+@comment are installing the the one bundled with source, or the one from
+@comment FILESDIR/screenrc.sample
+@sample %%ETCDIR%%/screenrc.sample