aboutsummaryrefslogtreecommitdiff
path: root/sysutils/screen
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2015-07-01 01:51:16 +0000
committerCy Schubert <cy@FreeBSD.org>2015-07-01 01:51:16 +0000
commit6170c01bdd43ae2a8d628ad3696ec37bf293884d (patch)
tree01dcb04eb858093b3f1c1cad02557c29ccd45b89 /sysutils/screen
parentf8edd1bd9c80a4a0a369a422d9e4d520665a73b0 (diff)
Notes
Diffstat (limited to 'sysutils/screen')
-rw-r--r--sysutils/screen/Makefile3
-rw-r--r--sysutils/screen/distinfo4
-rw-r--r--sysutils/screen/files/patch-ansi.c10
-rw-r--r--sysutils/screen/files/patch-os.h22
-rw-r--r--sysutils/screen/files/patch-screen.c9
5 files changed, 3 insertions, 45 deletions
diff --git a/sysutils/screen/Makefile b/sysutils/screen/Makefile
index 9f7ef089842f..25ae83a408e6 100644
--- a/sysutils/screen/Makefile
+++ b/sysutils/screen/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= screen
-PORTVERSION= 4.2.1
-PORTREVISION= 5
+PORTVERSION= 4.3.1
CATEGORIES= sysutils
MASTER_SITES= http://ftp.gnu.org/gnu/screen/ \
ftp://ftp.gnu.org/gnu/screen/ \
diff --git a/sysutils/screen/distinfo b/sysutils/screen/distinfo
index 2bff6b3312c3..a1a282cde248 100644
--- a/sysutils/screen/distinfo
+++ b/sysutils/screen/distinfo
@@ -1,2 +1,2 @@
-SHA256 (screen-4.2.1.tar.gz) = 5468545047e301d2b3579f9d9ce00466d14a7eec95ce806e3834a3d6b0b9b080
-SIZE (screen-4.2.1.tar.gz) = 1062485
+SHA256 (screen-4.3.1.tar.gz) = fa4049f8aee283de62e283d427f2cfd35d6c369b40f7f45f947dbfd915699d63
+SIZE (screen-4.3.1.tar.gz) = 845958
diff --git a/sysutils/screen/files/patch-ansi.c b/sysutils/screen/files/patch-ansi.c
deleted file mode 100644
index 55f8f3a498f8..000000000000
--- a/sysutils/screen/files/patch-ansi.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ansi.c.orig 2014-04-26 04:32:54.000000000 -0700
-+++ ansi.c 2014-04-29 19:08:26.631287189 -0700
-@@ -569,6 +569,7 @@
- case '0': case '1': case '2': case '3': case '4':
- case '5': case '6': case '7': case '8': case '9':
- if (curr->w_NumArgs < MAXARGS)
-+ if (curr->w_NumArgs >= 0 && curr->w_NumArgs < MAXARGS)
- {
- if (curr->w_args[curr->w_NumArgs] < 100000000)
- curr->w_args[curr->w_NumArgs] =
diff --git a/sysutils/screen/files/patch-os.h b/sysutils/screen/files/patch-os.h
index e139965bd9fa..67ebdc446c45 100644
--- a/sysutils/screen/files/patch-os.h
+++ b/sysutils/screen/files/patch-os.h
@@ -1,27 +1,5 @@
--- os.h.orig 2014-04-26 03:58:35.000000000 -0700
+++ os.h 2014-04-29 19:16:31.730773575 -0700
-@@ -252,7 +252,11 @@
- #if defined(UTMPOK) || defined(BUGGYGETLOGIN)
- # if defined(SVR4) && !defined(DGUX) && !defined(__hpux) && !defined(linux)
- # include <utmpx.h>
--# define UTMPFILE UTMPX_FILE
-+# ifdef UTMPX_FILE
-+# define UTMPFILE UTMPX_FILE
-+# else
-+# define UTMPFILE "/nonexistent"
-+# endif
- # define utmp utmpx
- # define getutent getutxent
- # define getutid getutxid
-@@ -260,7 +264,7 @@
- # define pututline pututxline
- # define setutent setutxent
- # define endutent endutxent
--# define ut_time ut_xtime
-+# define ut_time ut_tv.tv_sec
- # else /* SVR4 */
- # include <utmp.h>
- # endif /* SVR4 */
@@ -524,6 +528,6 @@
/* Changing those you won't be able to attach to your old sessions
* when changing those values in official tree don't forget to bump
diff --git a/sysutils/screen/files/patch-screen.c b/sysutils/screen/files/patch-screen.c
index 23757543afe8..7ef644f33e55 100644
--- a/sysutils/screen/files/patch-screen.c
+++ b/sysutils/screen/files/patch-screen.c
@@ -9,12 +9,3 @@
{
winmsg_rendpos[--r] = pn - buf;
continue;
-@@ -2271,8 +2271,6 @@
- while (i-- > 0)
- *pn-- = ' ';
- numpad--;
-- if (r && p - buf == winmsg_rendpos[r - 1])
-- winmsg_rendpos[--r] = pn - buf;
- }
- }
- return pn2;