aboutsummaryrefslogtreecommitdiff
path: root/sysutils/sd-agent/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-07-20 15:33:20 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-07-20 15:33:20 +0000
commite50dc2a33659f6b4119906eca4efb0e803b64bfb (patch)
treed74ba65fed8db0fd098d71428aebd9af6e665d09 /sysutils/sd-agent/Makefile
parent699288db85300808717293ff894f66a1b6091b29 (diff)
Cleanup $() variables in ports Makefiles.
Mostly replace with ${}, but sometime, replace with $$() because it is what was intended in the first place. (I think.) Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=418840
Diffstat (limited to 'sysutils/sd-agent/Makefile')
-rw-r--r--sysutils/sd-agent/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/sysutils/sd-agent/Makefile b/sysutils/sd-agent/Makefile
index 0f28ac47b683..c1d9e25ae84a 100644
--- a/sysutils/sd-agent/Makefile
+++ b/sysutils/sd-agent/Makefile
@@ -9,7 +9,7 @@ COMMENT= Server Density Agent for FreeBSD
LICENSE= BSD3CLAUSE
-RUN_DEPENDS= $(LOCALBASE)/sbin/sysinfo:sysutils/sysinfo
+RUN_DEPENDS= ${LOCALBASE}/sbin/sysinfo:sysutils/sysinfo
USERS= sd-agent
GROUPS= sd-agent
@@ -20,23 +20,23 @@ GH_ACCOUNT= serverdensity
USES= python shebangfix
SHEBANG_FILES= agent.py
-USE_RC_SUBR= $(PORTNAME)
-SUB_LIST+= RCNAME=$(PORTNAME:S/-/_/g)
+USE_RC_SUBR= ${PORTNAME}
+SUB_LIST+= RCNAME=${PORTNAME:S/-/_/g}
NO_ARCH= yes
-INSTALLDIR= $(STAGEDIR)$(PREFIX)/libexec/$(PORTNAME)
+INSTALLDIR= ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
FLIST= agent.py checks.py daemon.py logtail.py minjson.py pep8.sh plugins.py sd-deploy.py
do-build::
- $(SED) -i .bak 's,%%PREFIX%%,$(PREFIX),' $(WRKSRC)/agent.py
+ ${SED} -i .bak 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/agent.py
do-install::
- $(MKDIR) $(INSTALLDIR)/plugins
-.for f in $(FLIST)
- $(INSTALL_SCRIPT) $(WRKSRC)/$f $(INSTALLDIR)
+ ${MKDIR} ${INSTALLDIR}/plugins
+.for f in ${FLIST}
+ ${INSTALL_SCRIPT} ${WRKSRC}/$f ${INSTALLDIR}
.endfor
- $(MKDIR) $(STAGEDIR)$(ETCDIR)
- $(INSTALL_DATA) $(WRKSRC)/config.cfg $(STAGEDIR)$(ETCDIR)/config.cfg.sample
+ ${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/config.cfg ${STAGEDIR}${ETCDIR}/config.cfg.sample
.include <bsd.port.mk>