aboutsummaryrefslogtreecommitdiff
path: root/sysutils/seatools
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2007-04-08 22:17:39 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2007-04-08 22:17:39 +0000
commit0ee1187c37455bd490eed2caa42385774b09ba33 (patch)
treed5137595844d0e8278b5273cc34b2420a01fbe27 /sysutils/seatools
parent4e942cf5260c84abb8f04a59a62e81ea90115ee3 (diff)
downloadports-0ee1187c37455bd490eed2caa42385774b09ba33.tar.gz
ports-0ee1187c37455bd490eed2caa42385774b09ba33.zip
Notes
Diffstat (limited to 'sysutils/seatools')
-rw-r--r--sysutils/seatools/Makefile56
-rw-r--r--sysutils/seatools/distinfo3
-rw-r--r--sysutils/seatools/pkg-descr4
-rw-r--r--sysutils/seatools/pkg-plist3
4 files changed, 66 insertions, 0 deletions
diff --git a/sysutils/seatools/Makefile b/sysutils/seatools/Makefile
new file mode 100644
index 000000000000..56647d86f9f3
--- /dev/null
+++ b/sysutils/seatools/Makefile
@@ -0,0 +1,56 @@
+# Ports collection makefile for: linux-seatools
+# Date created: 08 Apr 2007
+# Whom: Boris Samorodov <bsam@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= seatools
+PORTVERSION= 2.54
+CATEGORIES= sysutils linux
+MASTER_SITES= ${DOWNLOAD_URL}
+PKGNAMEPREFIX= linux-
+DISTNAME= seatools_cli
+EXTRACT_SUFX= .tar
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= Seagate's SeaTools for Linux
+
+DOWNLOAD_URL= http://download.seagate.com/seatools/registration.nsf/linux_cli?openform
+NO_WRKSUBDIR= yes
+RESTRICTED= The distfile should be downloaded by hand
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= yes
+
+do-build:
+ @${BRANDELF} -t Linux ${WRKSRC}/st
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/st ${PREFIX}/sbin/st
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/sthelp.txt ${DOCSDIR}/sthelp.txt
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= PORTDOCS="@comment "
+.else
+PLIST_SUB+= PORTDOCS=
+.endif
+
+.if (!exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}))
+ECHO_MSG=/usr/bin/printf
+IGNORE= :\n\
+Please access\n\
+\n\
+ ${DOWNLOAD_URL}\n\
+\n\
+with a web browser, fill the web form. Please place the downloaded\n\
+${DISTNAME}${EXTRACT_SUFX} in ${DISTDIR}\n\n
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/seatools/distinfo b/sysutils/seatools/distinfo
new file mode 100644
index 000000000000..a357dd098e7c
--- /dev/null
+++ b/sysutils/seatools/distinfo
@@ -0,0 +1,3 @@
+MD5 (seatools_cli.tar) = f712bfdfa37b854a5fc933e1ab1426af
+SHA256 (seatools_cli.tar) = b7f8eab4cc80828ec18aeab34ea5e298dbf0f4360adbc03402c5f5c9fafae3b6
+SIZE (seatools_cli.tar) = 235520
diff --git a/sysutils/seatools/pkg-descr b/sysutils/seatools/pkg-descr
new file mode 100644
index 000000000000..7e56ba2082e9
--- /dev/null
+++ b/sysutils/seatools/pkg-descr
@@ -0,0 +1,4 @@
+Here is the port of Seagate's SeaTools Enterprise Edition for Linux
+Disc Diagnostic Software (cli version).
+
+WWW: http://www.seagate.com
diff --git a/sysutils/seatools/pkg-plist b/sysutils/seatools/pkg-plist
new file mode 100644
index 000000000000..7eaaf632bd1c
--- /dev/null
+++ b/sysutils/seatools/pkg-plist
@@ -0,0 +1,3 @@
+sbin/st
+%%PORTDOCS%%%%DOCSDIR%%/sthelp.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%