aboutsummaryrefslogtreecommitdiff
path: root/sysutils/service-config/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-07-06 15:34:55 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-07-06 15:34:55 +0000
commitc31290a31b5ac126d74afaa7e9b3d73648be35a2 (patch)
tree42f0727d8454386366d7551c42e0b06e22015d1d /sysutils/service-config/Makefile
parent3354a6b2e508d4b0e70dce7f253d2ed83f536b6c (diff)
Notes
Diffstat (limited to 'sysutils/service-config/Makefile')
-rw-r--r--sysutils/service-config/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/sysutils/service-config/Makefile b/sysutils/service-config/Makefile
new file mode 100644
index 000000000000..0554303849b8
--- /dev/null
+++ b/sysutils/service-config/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: service-config
+# Date created: 2 July 2001
+# Whom: petef@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= service-config
+PORTVERSION= 0.51
+CATEGORIES= sysutils
+MASTER_SITES= http://www.superscript.com/service-config/
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= supervise:${PORTSDIR}/sysutils/daemontools
+
+ALL_TARGET= it
+INSTALL_TARGET= setup check
+
+NO_PACKAGE= A possibly inherited DJB-style license would prohibit \
+ distribution of modified binary packages
+
+post-patch:
+ @${ECHO} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
+ @${ECHO} "${CC} ${CFLAGS} ${STRIP}" > ${WRKSRC}/conf-ld
+ @${PERL} -pi -e 's!/usr/local!${PREFIX}!g' ${WRKSRC}/conf-home
+
+.include <bsd.port.mk>