aboutsummaryrefslogtreecommitdiff
path: root/sysutils/setsid/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-06-27 17:47:21 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-06-27 19:37:59 +0000
commit31b7e90bd6b77158dfd4cf186fd7b233fe68848d (patch)
tree32e679257fb47300f6e54b51f8e4984dc5ee2335 /sysutils/setsid/Makefile
parent16bef8b16b7f0d398196f421aa76336af785d5ff (diff)
downloadports-31b7e90bd6b77158dfd4cf186fd7b233fe68848d.tar.gz
ports-31b7e90bd6b77158dfd4cf186fd7b233fe68848d.zip
Diffstat (limited to 'sysutils/setsid/Makefile')
-rw-r--r--sysutils/setsid/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/sysutils/setsid/Makefile b/sysutils/setsid/Makefile
new file mode 100644
index 000000000000..478748e75739
--- /dev/null
+++ b/sysutils/setsid/Makefile
@@ -0,0 +1,21 @@
+# Created by: Martin Wilke <miwi@FreeBSD.org>
+
+PORTNAME= setsid
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+MASTER_SITES= http://dl.suckless.org/tools/
+DISTNAME= ssid-${DISTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Run a command in a new session
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PLIST_FILES= bin/setsid bin/ssid
+
+post-install:
+ ${LN} ${STAGEDIR}${PREFIX}/bin/ssid \
+ ${STAGEDIR}${PREFIX}/bin/setsid
+
+.include <bsd.port.mk>