aboutsummaryrefslogtreecommitdiff
path: root/sysutils/sformat
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-05-21 15:12:48 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-05-21 15:12:48 +0000
commit063fc0a057606ca0155fa1ee5ecf5c12aaf535ad (patch)
tree6894775fd8b3df7737ddb1c3498c6de592c3e660 /sysutils/sformat
parent400bbbe1739b94d41db36774566886887fad0a71 (diff)
Fix potential root exploit.
THE FREEBSD PORT DOES NOT SET THE SUID BIT, YOU ARE ONLY VULNERABLE IF YOU SET IT ON YOUR OWN! See http://marc.theaimsgroup.com/?l=bugtraq&m=105285564307225&w=2 for more. Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=81615
Diffstat (limited to 'sysutils/sformat')
-rw-r--r--sysutils/sformat/Makefile1
-rw-r--r--sysutils/sformat/files/patch-libscg::scsiopen.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/sformat/Makefile b/sysutils/sformat/Makefile
index e68884a198df..00d15762dba9 100644
--- a/sysutils/sformat/Makefile
+++ b/sysutils/sformat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sformat
PORTVERSION= 3.5
+PORTREVISON= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.zeist.de/pub/distfiles/ \
ftp://ftp.berlios.de/pub/sformat/
diff --git a/sysutils/sformat/files/patch-libscg::scsiopen.c b/sysutils/sformat/files/patch-libscg::scsiopen.c
new file mode 100644
index 000000000000..2a3e9878f1d3
--- /dev/null
+++ b/sysutils/sformat/files/patch-libscg::scsiopen.c
@@ -0,0 +1,11 @@
+--- libscg/scsiopen.c.orig Sun Mar 18 14:54:18 2001
++++ libscg/scsiopen.c Tue May 20 22:58:07 2003
+@@ -239,7 +239,7 @@
+ }
+ if (scg__open(scgp, devname) <= 0) {
+ if (errs && scgp->errstr)
+- js_snprintf(errs, slen, scgp->errstr);
++ js_snprintf(errs, slen, "%s", scgp->errstr);
+ scg_sfree(scgp);
+ return ((SCSI *)0);
+ }