aboutsummaryrefslogtreecommitdiff
path: root/sysutils/slmon
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-13 08:05:40 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-13 08:05:40 +0000
commit65df8489a4449f7280974442b0ab433698fc8158 (patch)
tree3b58e8df240e68c421698db185e17ffe0339a8fd /sysutils/slmon
parent7668e8de7f9bb34b29093a072e0725a57e2ba239 (diff)
downloadports-65df8489a4449f7280974442b0ab433698fc8158.tar.gz
ports-65df8489a4449f7280974442b0ab433698fc8158.zip
Notes
Diffstat (limited to 'sysutils/slmon')
-rw-r--r--sysutils/slmon/Makefile35
-rw-r--r--sysutils/slmon/distinfo1
-rw-r--r--sysutils/slmon/files/patch-Makefile.in11
-rw-r--r--sysutils/slmon/files/patch-defines.h10
-rw-r--r--sysutils/slmon/files/patch-draw.c10
-rw-r--r--sysutils/slmon/pkg-comment1
-rw-r--r--sysutils/slmon/pkg-descr9
-rw-r--r--sysutils/slmon/pkg-plist1
8 files changed, 78 insertions, 0 deletions
diff --git a/sysutils/slmon/Makefile b/sysutils/slmon/Makefile
new file mode 100644
index 000000000000..a809ac7aa336
--- /dev/null
+++ b/sysutils/slmon/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# New ports collection makefile for: slmon
+# Date created: Nov 13, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= slmon
+PORTVERSION= 0.5.6
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= slang:${PORTSDIR}/devel/libslang \
+ gtop:${PORTSDIR}/devel/libgtop \
+ intl:${PORTSDIR}/devel/gettext \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+GNU_CONFIGURE= yes
+LIBGTOP_CONFIG= ${LOCALBASE}/bin/libgtop-config
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lncurses -lintl -lgnugetopt"
+USE_GMAKE= yes
+MAN1= slmon.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400010
+LIB_DEPENDS+= ncurses:${PORTSDIR}/devel/ncurses
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/slmon/distinfo b/sysutils/slmon/distinfo
new file mode 100644
index 000000000000..ee5c8c70f6fc
--- /dev/null
+++ b/sysutils/slmon/distinfo
@@ -0,0 +1 @@
+MD5 (slmon-0.5.6.tar.gz) = a6445ef5e54069638e267dfef076fdfd
diff --git a/sysutils/slmon/files/patch-Makefile.in b/sysutils/slmon/files/patch-Makefile.in
new file mode 100644
index 000000000000..ff54c2549d44
--- /dev/null
+++ b/sysutils/slmon/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Sep 8 16:43:50 2001
++++ Makefile.in Sat Sep 8 16:46:44 2001
+@@ -70,7 +70,7 @@
+ LIBGTOP_INCS = @LIBGTOP_INCS@
+ LIBGTOP_INTERFACE_AGE = @LIBGTOP_INTERFACE_AGE@
+ LIBGTOP_LIBDIR = @LIBGTOP_LIBDIR@
+-LIBGTOP_LIBS = @LIBGTOP_LIBS@
++LIBGTOP_LIBS = @LIBGTOP_LIBS@ @LIBGTOP_EXTRA_LIBS@
+ LIBGTOP_MAJOR_VERSION = @LIBGTOP_MAJOR_VERSION@
+ LIBGTOP_MICRO_VERSION = @LIBGTOP_MICRO_VERSION@
+ LIBGTOP_MINOR_VERSION = @LIBGTOP_MINOR_VERSION@
diff --git a/sysutils/slmon/files/patch-defines.h b/sysutils/slmon/files/patch-defines.h
new file mode 100644
index 000000000000..b48f5819d8d8
--- /dev/null
+++ b/sysutils/slmon/files/patch-defines.h
@@ -0,0 +1,10 @@
+--- defines.h.orig Tue Nov 6 14:33:50 2001
++++ defines.h Tue Nov 6 14:34:20 2001
+@@ -17,6 +17,7 @@
+ #ifndef SLMON_DEFINES_H
+ #define SLMON_DEFINES_H
+
++#include <sys/types.h>
+ #include <stdlib.h>
+ #include <time.h>
+ #include <string.h>
diff --git a/sysutils/slmon/files/patch-draw.c b/sysutils/slmon/files/patch-draw.c
new file mode 100644
index 000000000000..1d8691f3bd16
--- /dev/null
+++ b/sysutils/slmon/files/patch-draw.c
@@ -0,0 +1,10 @@
+--- draw.c.orig Tue Nov 13 16:00:39 2001
++++ draw.c Tue Nov 13 16:00:56 2001
+@@ -26,6 +26,7 @@
+ #include <glibtop/netload.h>
+
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h>
+
+ /*
diff --git a/sysutils/slmon/pkg-comment b/sysutils/slmon/pkg-comment
new file mode 100644
index 000000000000..aec2fb65d60e
--- /dev/null
+++ b/sysutils/slmon/pkg-comment
@@ -0,0 +1 @@
+S-Lang System Monitor
diff --git a/sysutils/slmon/pkg-descr b/sysutils/slmon/pkg-descr
new file mode 100644
index 000000000000..bc54450ea6ce
--- /dev/null
+++ b/sysutils/slmon/pkg-descr
@@ -0,0 +1,9 @@
+SLmon is a tool for monitoring system's performance. It displays results
+using nice and (hopefully) readable text-based UI. Currently monitored are:
+
+ - CPU load (SMP is supported)
+ - memory (including swap)
+ - uptime, date and time
+ - number of logged in users
+
+WWW: http://slmon.sourceforge.net/
diff --git a/sysutils/slmon/pkg-plist b/sysutils/slmon/pkg-plist
new file mode 100644
index 000000000000..2c20d39994db
--- /dev/null
+++ b/sysutils/slmon/pkg-plist
@@ -0,0 +1 @@
+bin/slmon