aboutsummaryrefslogtreecommitdiff
path: root/sysutils/sloth
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-09 13:45:49 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-09 13:45:49 +0000
commit1b6970f8ae8fabcffa9f509a5f32fc8865d7a4c7 (patch)
tree050f42b8c36c1a811ff6ca0b4eae81ea65f65f46 /sysutils/sloth
parent566683dcf542acdfa8274efeeb5b2186730f496e (diff)
downloadports-1b6970f8ae8fabcffa9f509a5f32fc8865d7a4c7.tar.gz
ports-1b6970f8ae8fabcffa9f509a5f32fc8865d7a4c7.zip
Notes
Diffstat (limited to 'sysutils/sloth')
-rw-r--r--sysutils/sloth/Makefile24
-rw-r--r--sysutils/sloth/distinfo1
-rw-r--r--sysutils/sloth/pkg-comment1
-rw-r--r--sysutils/sloth/pkg-descr6
-rw-r--r--sysutils/sloth/pkg-plist1
5 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/sloth/Makefile b/sysutils/sloth/Makefile
new file mode 100644
index 000000000000..b2c79385ac44
--- /dev/null
+++ b/sysutils/sloth/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# Ports collection makefile for: sloth
+# Date created: May 9, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sloth
+PORTVERSION= 1.1.0
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.namodn.com/pub/projects/ \
+ http://communityprojects.org/apps/sloth/
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+MAN1= sloth.1
+
+post-patch:
+ @${PERL} -pi -e "s,wait.h,sys/wait.h,g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/sysutils/sloth/distinfo b/sysutils/sloth/distinfo
new file mode 100644
index 000000000000..b8da032b9298
--- /dev/null
+++ b/sysutils/sloth/distinfo
@@ -0,0 +1 @@
+MD5 (sloth-1.1.0.tar.gz) = 15a4e3a6dc2796c2ba09d7c5722d7f35
diff --git a/sysutils/sloth/pkg-comment b/sysutils/sloth/pkg-comment
new file mode 100644
index 000000000000..379184691d54
--- /dev/null
+++ b/sysutils/sloth/pkg-comment
@@ -0,0 +1 @@
+Slow down a process
diff --git a/sysutils/sloth/pkg-descr b/sysutils/sloth/pkg-descr
new file mode 100644
index 000000000000..5f60f2231eca
--- /dev/null
+++ b/sysutils/sloth/pkg-descr
@@ -0,0 +1,6 @@
+Sloth allows you to slow down a specified application by specifying (in
+miliseconds) the delay on the process. It slows down the process by sending
+SIGSTOP & SIGCONT signals to the process over a very fast period of time,
+giving the appearance of a slower application.
+
+WWW: http://www.communityprojects.org/apps/sloth/
diff --git a/sysutils/sloth/pkg-plist b/sysutils/sloth/pkg-plist
new file mode 100644
index 000000000000..a0471ce9a78a
--- /dev/null
+++ b/sysutils/sloth/pkg-plist
@@ -0,0 +1 @@
+bin/sloth