aboutsummaryrefslogtreecommitdiff
path: root/sysutils/smartmontools
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2016-06-16 03:50:06 +0000
committerCy Schubert <cy@FreeBSD.org>2016-06-16 03:50:06 +0000
commita6a726d3dd7a0f26df351e980635a5097da27c9b (patch)
tree404d51ecf046127be573dc42eeadb521516f8eb9 /sysutils/smartmontools
parent9b5a8ba97dfce0571fb71ec594ccf6d2ee224293 (diff)
downloadports-a6a726d3dd7a0f26df351e980635a5097da27c9b.tar.gz
ports-a6a726d3dd7a0f26df351e980635a5097da27c9b.zip
Notes
Diffstat (limited to 'sysutils/smartmontools')
-rw-r--r--sysutils/smartmontools/Makefile2
-rw-r--r--sysutils/smartmontools/files/patch-atacmds.h12
-rw-r--r--sysutils/smartmontools/files/patch-freebsd_nvme_ioctl.h18
3 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/smartmontools/Makefile b/sysutils/smartmontools/Makefile
index 67ba44587076..c46d6439b01e 100644
--- a/sysutils/smartmontools/Makefile
+++ b/sysutils/smartmontools/Makefile
@@ -3,6 +3,7 @@
PORTNAME= smartmontools
PORTVERSION= 6.5
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF
@@ -21,6 +22,7 @@ SHEBANG_FILES= examplescripts/Example5
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking \
--enable-sample \
+ --with-nvme-devicescan=yes \
--with-initscriptdir=${PREFIX}/etc/rc.d
SUB_FILES= pkg-message smart
diff --git a/sysutils/smartmontools/files/patch-atacmds.h b/sysutils/smartmontools/files/patch-atacmds.h
new file mode 100644
index 000000000000..72d3379b8a4d
--- /dev/null
+++ b/sysutils/smartmontools/files/patch-atacmds.h
@@ -0,0 +1,12 @@
+--- atacmds.h.orig 2015-10-31 09:36:16.000000000 -0700
++++ atacmds.h 2016-06-15 19:39:43.425233000 -0700
+@@ -74,7 +74,9 @@
+ #define ATA_IDLE 0xe3
+ #define ATA_SMART_CMD 0xb0
+ #define ATA_SECURITY_FREEZE_LOCK 0xf5
++#ifndef ATA_SET_FEATURES
+ #define ATA_SET_FEATURES 0xef
++#endif
+ #define ATA_STANDBY_IMMEDIATE 0xe0
+
+ // SET_FEATURES subcommands
diff --git a/sysutils/smartmontools/files/patch-freebsd_nvme_ioctl.h b/sysutils/smartmontools/files/patch-freebsd_nvme_ioctl.h
new file mode 100644
index 000000000000..4cd8a5909c35
--- /dev/null
+++ b/sysutils/smartmontools/files/patch-freebsd_nvme_ioctl.h
@@ -0,0 +1,18 @@
+--- freebsd_nvme_ioctl.h.orig 2016-03-28 09:25:56.000000000 -0700
++++ freebsd_nvme_ioctl.h 2016-06-15 20:43:22.389493000 -0700
+@@ -31,6 +31,7 @@
+
+ #define NVME_PASSTHROUGH_CMD _IOWR('n', 0, struct nvme_pt_command)
+
++#if __FreeBSD_version < 1100110
+ struct nvme_command
+ {
+ /* dword 0 */
+@@ -143,6 +144,7 @@
+ */
+ struct mtx * driver_lock;
+ };
++#endif
+
+ #define nvme_completion_is_error(cpl) \
+ ((cpl)->status.sc != 0 || (cpl)->status.sct != 0)