aboutsummaryrefslogtreecommitdiff
path: root/sysutils/snowlog
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-07-30 19:26:52 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-07-30 19:26:52 +0000
commit51939469a04b1ecdb20e01edd01d009de5fa8248 (patch)
tree3949e22f8d04f3a2c3bda61505cdb8264e107795 /sysutils/snowlog
parentebd8d87932bdf942650509a43443b2577f63e2ba (diff)
downloadports-51939469a04b1ecdb20e01edd01d009de5fa8248.tar.gz
ports-51939469a04b1ecdb20e01edd01d009de5fa8248.zip
Notes
Diffstat (limited to 'sysutils/snowlog')
-rw-r--r--sysutils/snowlog/Makefile34
-rw-r--r--sysutils/snowlog/distinfo2
-rw-r--r--sysutils/snowlog/files/patch-Makefile27
-rw-r--r--sysutils/snowlog/pkg-descr8
-rw-r--r--sysutils/snowlog/pkg-message11
-rw-r--r--sysutils/snowlog/pkg-plist8
6 files changed, 90 insertions, 0 deletions
diff --git a/sysutils/snowlog/Makefile b/sysutils/snowlog/Makefile
new file mode 100644
index 000000000000..1efaa9aa2439
--- /dev/null
+++ b/sysutils/snowlog/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# New ports collection makefile for: snowlog
+# Date created: Jul 30 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= snowlog
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://home.kcore.de/~kiza/software/snowlog/download/
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= A webserver access log browser/analyzer
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+MAN1= snowlog.1
+DOCS= INSTALLATION doc/README doc/filters.example
+SHAREDOCS= referers.regexp useragents.regexp
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/share && ${INSTALL_DATA} ${SHAREDOCS} ${DATADIR}
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/snowlog/distinfo b/sysutils/snowlog/distinfo
new file mode 100644
index 000000000000..144b253ff90c
--- /dev/null
+++ b/sysutils/snowlog/distinfo
@@ -0,0 +1,2 @@
+MD5 (snowlog-1.0.tar.gz) = 57c1f56f713aa9707d8f1a9a7c7109b4
+SIZE (snowlog-1.0.tar.gz) = 27065
diff --git a/sysutils/snowlog/files/patch-Makefile b/sysutils/snowlog/files/patch-Makefile
new file mode 100644
index 000000000000..65d07c9c7bbc
--- /dev/null
+++ b/sysutils/snowlog/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig Thu Jul 29 03:04:24 2004
++++ Makefile Fri Jul 30 09:45:19 2004
+@@ -1,13 +1,10 @@
+-CC= gcc
+-MAKE= make
+ INSTALL= install
+-PREFIX= /usr/local
+ DATAPATH= $(PREFIX)/share
+ LOCALEPATH= $(DATAPATH)/locale
+ DOCPATH= $(DATAPATH)/doc
+
+-CFLAGS= -Wall -O2 -I/usr/local/include -DDATAPATH="\"$(DATAPATH)\"" -DVERSION=\"$(VERSION)\"
+-LDFLAGS= -L/usr/local/lib -lncurses -lpcre
++CFLAGS+= -Wall -O2 -I$(LOCALBASE)/include -DDATAPATH="\"$(DATAPATH)\"" -DVERSION=\"$(VERSION)\"
++LDFLAGS= -L$(LOCALBASE)/lib -lncurses -lpcre
+
+ OBJFILES= main.o loadlog.o internals.o interface.o snowtk.o regexp.o filters.o setup.o
+
+@@ -27,7 +24,7 @@
+ sed s#DATAPATH#$(DATAPATH)# | sed s#VERSION#$(VERSION)# \
+ > doc/man/snowlog.1
+
+-install: install-bin install-data install-man install-doc
++install: install-bin install-man
+
+ install-bin: snowlog
+ if [ ! -d "$(PREFIX)/bin" ]; then \
diff --git a/sysutils/snowlog/pkg-descr b/sysutils/snowlog/pkg-descr
new file mode 100644
index 000000000000..ea531cb7b0e1
--- /dev/null
+++ b/sysutils/snowlog/pkg-descr
@@ -0,0 +1,8 @@
+Snowlog is a program that lets you browse your web server's access log files.
+It does not generate static HTML status reports but instead shows you all
+accesses in a list that you can filter, sort and search easily. It's a
+console application and supposed to run on the server via ssh.
+
+Filters that accept regular expressions can be applied.
+
+WWW: http://home.kcore.de/~kiza/software/snowlog/
diff --git a/sysutils/snowlog/pkg-message b/sysutils/snowlog/pkg-message
new file mode 100644
index 000000000000..22620ef76d04
--- /dev/null
+++ b/sysutils/snowlog/pkg-message
@@ -0,0 +1,11 @@
+#########################################################
+
+To use snowlog, adding this to httpd.conf
+
+LogFormat "%a\t%l\t%u\t%{%s}t\t%r\t%>s\t%X\t%{Content-Type}o\t%b\t%{Referer}i\t%{User-Agent}i\t%V\t%{LogHint}e" parsable
+
+Next, tell apache to make parsable logs:
+
+CustomLog /path/to/httpd_access_parsable.log parsable
+
+#########################################################
diff --git a/sysutils/snowlog/pkg-plist b/sysutils/snowlog/pkg-plist
new file mode 100644
index 000000000000..af9d28d21304
--- /dev/null
+++ b/sysutils/snowlog/pkg-plist
@@ -0,0 +1,8 @@
+bin/snowlog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALLATION
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/filters.example
+%%PORTDOCS%%%%DATADIR%%/referers.regexp
+%%PORTDOCS%%%%DATADIR%%/useragents.regexp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DATADIR%%