aboutsummaryrefslogtreecommitdiff
path: root/sysutils/sortu
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2008-03-13 14:50:57 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2008-03-13 14:50:57 +0000
commit2a51f06664f4cc07bf064be2f5ed7455abe4d7c2 (patch)
treeb5c3e6932e391d2aa9821db25bd76b39354d1bad /sysutils/sortu
parent2d73db35333e6fc7a451669d2944eb5d5e73dc3a (diff)
downloadports-2a51f06664f4cc07bf064be2f5ed7455abe4d7c2.tar.gz
ports-2a51f06664f4cc07bf064be2f5ed7455abe4d7c2.zip
Notes
Diffstat (limited to 'sysutils/sortu')
-rw-r--r--sysutils/sortu/Makefile31
-rw-r--r--sysutils/sortu/distinfo3
-rw-r--r--sysutils/sortu/pkg-descr16
-rw-r--r--sysutils/sortu/pkg-plist3
4 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/sortu/Makefile b/sysutils/sortu/Makefile
new file mode 100644
index 000000000000..85cec8c5ab7f
--- /dev/null
+++ b/sysutils/sortu/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: sortu
+# Date created: Wed Mar 12 18:13:34 PDT 2008
+# Whom: Matt Peterson <matt@peterson.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sortu
+PORTVERSION= 2.1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://256.com/sources/sortu/ \
+ http://matt.peterson.org/FreeBSD/ports/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= matt@peterson.org
+COMMENT= Tool that combines sort and uniq functionality
+
+ALL_TARGET= sortu
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sortu ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/sortu/distinfo b/sysutils/sortu/distinfo
new file mode 100644
index 000000000000..aa181094742b
--- /dev/null
+++ b/sysutils/sortu/distinfo
@@ -0,0 +1,3 @@
+MD5 (sortu-2.1.0.tgz) = 9543af82871164d0b71895aefb9a4d75
+SHA256 (sortu-2.1.0.tgz) = 009aee18702dcf70270d5363254411fab83691a92fcf84055f69e52c7c772a95
+SIZE (sortu-2.1.0.tgz) = 56365
diff --git a/sysutils/sortu/pkg-descr b/sysutils/sortu/pkg-descr
new file mode 100644
index 000000000000..fb4f9d55fc6d
--- /dev/null
+++ b/sysutils/sortu/pkg-descr
@@ -0,0 +1,16 @@
+The sortu program is a replacement for the sort and uniq programs. It is
+common for Unix script writers to want to count how many separate patterns
+are in a file. For example, if you have a list of addresses, you may want
+to see how many are from each state. So you cut out the state part, sort
+these, and then pass them through uniq -c. Sortu does all this for you in a
+fraction of the time.
+
+Sortu uses a hash table and some decent line processing to provide this
+functionality. For a relatively small number of keys, it can be signifcantly
+smaller than using sort, because it does not have to keep temporary files.
+If you are dealing with a large number of unique keys then sortu will run out
+of memory and stop. Sortu has some basic field and delimiter handling which
+should do most basic awk or cut features to separate out the field that you
+are sorting on.
+
+WWW: http://256.com/sources/sortu/
diff --git a/sysutils/sortu/pkg-plist b/sysutils/sortu/pkg-plist
new file mode 100644
index 000000000000..ce3f62a4cde3
--- /dev/null
+++ b/sysutils/sortu/pkg-plist
@@ -0,0 +1,3 @@
+bin/sortu
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%