aboutsummaryrefslogtreecommitdiff
path: root/sysutils/spassgen/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-31 09:24:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-31 09:24:39 +0000
commit43bbfe439b93a091ab9b0b9aa403ee16b749f2a4 (patch)
tree7b764298004fcc4259669a059759037f7af43c6e /sysutils/spassgen/Makefile
parentfea7a23b8b2f63bdfa00465ddd92ed4d52386fae (diff)
downloadports-43bbfe439b93a091ab9b0b9aa403ee16b749f2a4.tar.gz
ports-43bbfe439b93a091ab9b0b9aa403ee16b749f2a4.zip
Notes
Diffstat (limited to 'sysutils/spassgen/Makefile')
-rw-r--r--sysutils/spassgen/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/sysutils/spassgen/Makefile b/sysutils/spassgen/Makefile
new file mode 100644
index 000000000000..b700326edef4
--- /dev/null
+++ b/sysutils/spassgen/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: spassgen
+# Date created: 29 Jul 2004
+# Whom: Rashid N. Achilov <shelton@granch.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spassgen
+PORTVERSION= 1.5
+CATEGORIES= sysutils kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= spassgen
+
+MAINTAINER= shelton@granch.ru
+COMMENT= Qt GUI secure password generator
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+USE_QT_VER= 3
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+QMAKE_LOCATION= ${LOCALBASE}/bin
+
+MAKE_ENV+= QTDIR="${QT_PREFIX}"
+DOCSDIR= share/doc/HTML/en/${PORTNAME}
+
+pre-build:
+ (cd ${WRKSRC}; \
+ ${QMAKE_LOCATION}/qmake -project spassgen.pro; \
+ ${SETENV} QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
+ ${QMAKE_LOCATION}/qmake)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/spassgen ${PREFIX}/bin
+.for i in 128x128 16x16 32x32 48x48 64x64
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/${i}/apps
+ ${INSTALL_DATA} ${WRKSRC}/icons/${i}/password.png ${PREFIX}/share/icons/hicolor/${i}/apps
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/${DOCSDIR}
+.for i in AUTHORS LICENCE README TODO INSTALL
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>