aboutsummaryrefslogtreecommitdiff
path: root/sysutils/spiped
diff options
context:
space:
mode:
authorColin Percival <cperciva@FreeBSD.org>2016-06-18 23:35:02 +0000
committerColin Percival <cperciva@FreeBSD.org>2016-06-18 23:35:02 +0000
commit710fd7cbf9d3d211ca20774c67c62fa4c78c8a09 (patch)
treefe2f394445f69cfbdca77b03319c785dfd9c57b1 /sysutils/spiped
parent16987126cb14f4deb8793b428059fe257d309d04 (diff)
downloadports-710fd7cbf9d3d211ca20774c67c62fa4c78c8a09.tar.gz
ports-710fd7cbf9d3d211ca20774c67c62fa4c78c8a09.zip
Notes
Diffstat (limited to 'sysutils/spiped')
-rw-r--r--sysutils/spiped/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/sysutils/spiped/Makefile b/sysutils/spiped/Makefile
index ca42235297ad..e70a5c26ebf0 100644
--- a/sysutils/spiped/Makefile
+++ b/sysutils/spiped/Makefile
@@ -2,6 +2,7 @@
PORTNAME= spiped
PORTVERSION= 1.5.0
+PORTREVISION= 1
CATEGORIES= sysutils security
MASTER_SITES= http://www.tarsnap.com/spiped/
@@ -14,13 +15,16 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
# The spiped build only needs C99, but this will help to get us a compiler
# which has support for AESNI on x86 systems
USES= compiler:c11 tar:tgz
+USE_OPENSSL= YES
# Install into ${STAGEDIR}${PREFIX}
MAKE_ARGS+= BINDIR=${STAGEDIR}${PREFIX}/bin
MAKE_ARGS+= MAN1DIR=${STAGEDIR}${PREFIX}/man/man1
-# Force __BSD_VISIBLE on since it works and improves performance
-MAKE_ARGS+= CFLAGS="-O2 -D__BSD_VISIBLE"
+# Force __BSD_VISIBLE on since it works and improves performance;
+# add -I and -L directories for OpenSSL
+MAKE_ARGS+= CFLAGS="-O2 -D__BSD_VISIBLE -I${OPENSSLINC}"
+MAKE_ARGS+= LDADD_EXTRA="-L${OPENSSLLIB}"
PORTDOCS= BUILDING CHANGELOG COPYRIGHT README STYLE
PLIST_FILES= bin/spipe \