aboutsummaryrefslogtreecommitdiff
path: root/sysutils/squashfs-tools
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2010-05-05 18:19:43 +0000
committerRene Ladan <rene@FreeBSD.org>2010-05-05 18:19:43 +0000
commit8a407131f8532d7ffdaca32ddce6636f5129c935 (patch)
treeac1776872dc291bcd8d383938d604e35013ee65d /sysutils/squashfs-tools
parent3e430aa3e6e7ac292c98b49cae5ec541d469edb3 (diff)
downloadports-8a407131f8532d7ffdaca32ddce6636f5129c935.tar.gz
ports-8a407131f8532d7ffdaca32ddce6636f5129c935.zip
Notes
Diffstat (limited to 'sysutils/squashfs-tools')
-rw-r--r--sysutils/squashfs-tools/Makefile39
-rw-r--r--sysutils/squashfs-tools/distinfo3
-rw-r--r--sysutils/squashfs-tools/files/patch-squashfs-tools_Makefile15
-rw-r--r--sysutils/squashfs-tools/files/patch-squashfs-tools_pseudo.c15
-rw-r--r--sysutils/squashfs-tools/files/patch-squashfs-tools_unsquashfs.c15
-rw-r--r--sysutils/squashfs-tools/pkg-descr10
6 files changed, 97 insertions, 0 deletions
diff --git a/sysutils/squashfs-tools/Makefile b/sysutils/squashfs-tools/Makefile
new file mode 100644
index 000000000000..12b01371277b
--- /dev/null
+++ b/sysutils/squashfs-tools/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: squashfs-tools
+# Date created: 2010-04-21
+# Whom: Ashish SHUKLA <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= squashfs-tools
+PORTVERSION= 4.0
+CATEGORIES= sysutils
+MASTER_SITES= SF/squashfs/squashfs/${DISTNAME}/
+DISTNAME= squashfs${PORTVERSION}
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= Set of tools to manipulate squashfs images
+
+PLIST_FILES= bin/mksquashfs \
+ bin/unsquashfs
+
+.ifndef NOPORTDOCS
+PORTDOCS= ACKNOWLEDGEMENTS CHANGES COPYING \
+ PERFORMANCE.README README README-4.0
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:g" \
+ ${WRKSRC}/squashfs-tools/Makefile
+
+do-build:
+ @${MAKE} -C ${WRKSRC}/squashfs-tools
+
+do-install:
+ @${MAKE} -C ${WRKSRC}/squashfs-tools ${INSTALL}
+.ifndef NOPORTDOCS
+ @${MKDIR} ${DOCSDIR}
+ @for i in ${PORTDOCS}; do ${INSTALL_DATA} ${WRKSRC}/$$i ${DOCSDIR}; done
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/squashfs-tools/distinfo b/sysutils/squashfs-tools/distinfo
new file mode 100644
index 000000000000..fd727e3b6efc
--- /dev/null
+++ b/sysutils/squashfs-tools/distinfo
@@ -0,0 +1,3 @@
+MD5 (squashfs4.0.tar.gz) = a3c23391da4ebab0ac4a75021ddabf96
+SHA256 (squashfs4.0.tar.gz) = 18948edbe06bac2c4307eea99bfb962643e4b82e5b7edd541b4d743748e12e21
+SIZE (squashfs4.0.tar.gz) = 103979
diff --git a/sysutils/squashfs-tools/files/patch-squashfs-tools_Makefile b/sysutils/squashfs-tools/files/patch-squashfs-tools_Makefile
new file mode 100644
index 000000000000..479bedd20033
--- /dev/null
+++ b/sysutils/squashfs-tools/files/patch-squashfs-tools_Makefile
@@ -0,0 +1,15 @@
+$FreeBSD$
+
+--- squashfs-tools/Makefile.orig 2010-04-29 17:40:26.000000000 +0200
++++ squashfs-tools/Makefile 2010-04-29 17:43:19.000000000 +0200
+@@ -1,8 +1,8 @@
+-INSTALL_DIR = /usr/local/bin
++INSTALL_DIR = %%PREFIX%%/bin
+
+ INCLUDEDIR = .
+
+-CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -O2
++CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -O2 -DFNM_EXTMATCH=0
+
+ all: mksquashfs unsquashfs
+
diff --git a/sysutils/squashfs-tools/files/patch-squashfs-tools_pseudo.c b/sysutils/squashfs-tools/files/patch-squashfs-tools_pseudo.c
new file mode 100644
index 000000000000..c5e766b47b5b
--- /dev/null
+++ b/sysutils/squashfs-tools/files/patch-squashfs-tools_pseudo.c
@@ -0,0 +1,15 @@
+$FreeBSD$
+
+--- squashfs-tools/pseudo.c.orig 2009-04-05 04:01:58.000000000 +0200
++++ squashfs-tools/pseudo.c 2010-04-29 17:45:49.000000000 +0200
+@@ -31,6 +31,10 @@
+ #include <stdlib.h>
+ #include <sys/types.h>
+
++#ifdef __FreeBSD__
++#include <sys/stat.h>
++#endif
++
+ #include "pseudo.h"
+
+ #ifdef SQUASHFS_TRACE
diff --git a/sysutils/squashfs-tools/files/patch-squashfs-tools_unsquashfs.c b/sysutils/squashfs-tools/files/patch-squashfs-tools_unsquashfs.c
new file mode 100644
index 000000000000..83d7a223447f
--- /dev/null
+++ b/sysutils/squashfs-tools/files/patch-squashfs-tools_unsquashfs.c
@@ -0,0 +1,15 @@
+$FreeBSD$
+
+--- squashfs-tools/unsquashfs.c.orig 2009-04-05 23:23:06.000000000 +0200
++++ squashfs-tools/unsquashfs.c 2010-04-29 17:48:22.000000000 +0200
+@@ -26,6 +26,10 @@
+ #include "squashfs_compat.h"
+ #include "read_fs.h"
+
++#ifdef __FreeBSD__
++#include <sys/sysctl.h>
++#endif
++
+ struct cache *fragment_cache, *data_cache;
+ struct queue *to_reader, *to_deflate, *to_writer, *from_writer;
+ pthread_t *thread, *deflator_thread;
diff --git a/sysutils/squashfs-tools/pkg-descr b/sysutils/squashfs-tools/pkg-descr
new file mode 100644
index 000000000000..d2fc6eae74c2
--- /dev/null
+++ b/sysutils/squashfs-tools/pkg-descr
@@ -0,0 +1,10 @@
+Squashfs is a compressed read-only filesystem for Linux. Squashfs is
+intended for general read-only filesystem use, for archival use (i.e.
+in cases where a .tar.gz file may be used), and in constrained block
+device/memory systems (e.g. embedded systems) where low overhead is
+needed. The filesystem is currently stable, and has been tested on
+PowerPC, i586, Sparc and ARM architectures.
+
+squashfs-tools are the set of tools to manipulate squashfs images.
+
+WWW: http://squashfs.sourceforge.net/