aboutsummaryrefslogtreecommitdiff
path: root/sysutils/stalepid/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-12-09 08:34:26 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-12-09 08:34:26 +0000
commit8f9a790ec213aa3a5df851ff6259ac3e21b241cc (patch)
tree57c43cc135caf128e182f02664ce7031548ca2b0 /sysutils/stalepid/Makefile
parentae599a126a6c9cd9427b7ca96d9fed9e1d98a9c5 (diff)
downloadports-8f9a790ec213aa3a5df851ff6259ac3e21b241cc.tar.gz
ports-8f9a790ec213aa3a5df851ff6259ac3e21b241cc.zip
Notes
Diffstat (limited to 'sysutils/stalepid/Makefile')
-rw-r--r--sysutils/stalepid/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/sysutils/stalepid/Makefile b/sysutils/stalepid/Makefile
new file mode 100644
index 000000000000..3d9e7216a097
--- /dev/null
+++ b/sysutils/stalepid/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: stalepid
+# Date created: 4 December 2003
+# Whom: roam@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= stalepid
+PORTVERSION= 1.0.b1
+CATEGORIES= sysutils
+MASTER_SITES= http://devel.ringlet.net/sysutils/stalepid/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/pre/}
+
+MAINTAINER= roam@FreeBSD.org
+COMMENT= Check for stale pid files and remove them
+
+.include <bsd.port.pre.mk>
+RUN_DEPENDS= ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS+= ${SITE_PERL}/Errno.pm:${PORTSDIR}/devel/p5-Errno
+.endif
+
+USE_PERL5_RUN= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+MAN1= stalepid.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.post.mk>